summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-08 07:01:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-08 07:01:57 +0000
commit2d87b76ae0011ab33799e6403089fe6ad7ed4a86 (patch)
tree93d632a1c453d5aa8122e3e3fc644b40e3b318e8 /dev-python/pyzmq
parentVersion bump. (diff)
downloadgentoo-2-2d87b76ae0011ab33799e6403089fe6ad7ed4a86.tar.gz
gentoo-2-2d87b76ae0011ab33799e6403089fe6ad7ed4a86.tar.bz2
gentoo-2-2d87b76ae0011ab33799e6403089fe6ad7ed4a86.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/ChangeLog4
-rw-r--r--dev-python/pyzmq/pyzmq-13.1.0.ebuild60
-rw-r--r--dev-python/pyzmq/pyzmq-14.3.1.ebuild58
-rw-r--r--dev-python/pyzmq/pyzmq-2.1.10.ebuild41
4 files changed, 2 insertions, 161 deletions
diff --git a/dev-python/pyzmq/ChangeLog b/dev-python/pyzmq/ChangeLog
index 45eec6de1c54..c189e618e230 100644
--- a/dev-python/pyzmq/ChangeLog
+++ b/dev-python/pyzmq/ChangeLog
@@ -1,9 +1,9 @@
# ChangeLog for dev-python/pyzmq
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.57 2014/12/08 06:54:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.58 2014/12/08 07:01:57 idella4 Exp $
08 Dec 2014; Ian Delaney <idella4@gentoo.org> pyzmq-14.4.1.ebuild:
- set REQUIRED_USE for test
+ set REQUIRED_USE for test, rm old
05 Dec 2014; Agostino Sarubbo <ago@gentoo.org> pyzmq-14.4.0.ebuild:
Stable for x86, wrt bug #530592
diff --git a/dev-python/pyzmq/pyzmq-13.1.0.ebuild b/dev-python/pyzmq/pyzmq-13.1.0.ebuild
deleted file mode 100644
index d56fdef99d42..000000000000
--- a/dev-python/pyzmq/pyzmq-13.1.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-13.1.0.ebuild,v 1.9 2014/02/16 20:12:15 vapier Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples green test"
-
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-
-RDEPEND=">=net-libs/zeromq-2.1.9
- green? ( dev-python/gevent[${PY2_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? (
- !arm? ( dev-python/cffi[${PYTHON_USEDEP}] )
- dev-python/nose[${PY2_USEDEP}]
- dev-python/gevent[${PY2_USEDEP}]
- dev-python/cython[${PY2_USEDEP}]
- )"
-
-# Configure checks write to cwd.
-# https://github.com/zeromq/pyzmq/issues/318
-DISTUTILS_IN_SOURCE_BUILD=1
-
-REQUIRED_USE="test? ( !arm )"
-
-python_configure_all() {
- tc-export CC
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- if [[ "${EPYTHON}" == python3* ]]; then
- einfo "Skipping python3 due to many incompatibilities"
- else
- nosetests -svw build/lib/ || die "Tests fail with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/pyzmq/pyzmq-14.3.1.ebuild b/dev-python/pyzmq/pyzmq-14.3.1.ebuild
deleted file mode 100644
index ed546ddbb1d3..000000000000
--- a/dev-python/pyzmq/pyzmq-14.3.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.3.1.ebuild,v 1.4 2014/10/26 14:17:29 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples green test"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-RDEPEND=">=net-libs/zeromq-2.1.9
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi[${PYTHON_USEDEP}]
- green? ( dev-python/gevent[${PY2_USEDEP}] )"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_configure_all() {
- tc-export CC
-}
-
-python_prepare_all() {
- sed -e s':intersphinx_mapping:#&:' -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- if python_is_python3; then
- einfo "Skipping python3 due to lack of support by gevent"
- else
- nosetests -svw "${BUILD_DIR}/lib/"
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyzmq/pyzmq-2.1.10.ebuild b/dev-python/pyzmq/pyzmq-2.1.10.ebuild
deleted file mode 100644
index 6e12d8a42768..000000000000
--- a/dev-python/pyzmq/pyzmq-2.1.10.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.1.10.ebuild,v 1.6 2014/08/14 23:22:48 blueness Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples"
-
-RDEPEND=">=net-libs/zeromq-2.1.9"
-DEPEND="${RDEPEND}"
-
-DOCS="README.rst"
-PYTHON_MODNAME="zmq"
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}