summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-25 03:11:25 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-25 03:11:25 +0000
commit93ded4da16381b3f02dcc7070ffd57a1882b9c34 (patch)
tree9ec6323f8edc6b69e426835717205deeb33a2566 /dev-python/pylint/pylint-0.28.0.ebuild
parentDrop python3.3 support due to bug 449276. (diff)
downloadgentoo-2-93ded4da16381b3f02dcc7070ffd57a1882b9c34.tar.gz
gentoo-2-93ded4da16381b3f02dcc7070ffd57a1882b9c34.tar.bz2
gentoo-2-93ded4da16381b3f02dcc7070ffd57a1882b9c34.zip
Fixup dependencies and drop invalid python targets.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pylint/pylint-0.28.0.ebuild')
-rw-r--r--dev-python/pylint/pylint-0.28.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pylint/pylint-0.28.0.ebuild b/dev-python/pylint/pylint-0.28.0.ebuild
index edea00d0eda4..ff64c63aeab9 100644
--- a/dev-python/pylint/pylint-0.28.0.ebuild
+++ b/dev-python/pylint/pylint-0.28.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.28.0.ebuild,v 1.1 2013/06/21 15:39:51 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.28.0.ebuild,v 1.2 2013/06/25 03:11:25 floppym Exp $
EAPI=5
-PYTHON_COMPAT=( python2_{6,7} python{3_1,3_2,3_3} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
#PYTHON_REQ_USE="tk"
inherit distutils-r1
@@ -17,8 +17,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-lin
IUSE="examples"
# Versions specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.19.0[$(python_gen_usedep python{2_6,2_7,3_2})]
- >=dev-python/astng-0.16.1[$(python_gen_usedep python{2_6,2_7,3_2})]"
+RDEPEND=">=dev-python/logilab-common-0.19.0[${PYTHON_USEDEP}]
+ >=dev-python/astng-0.16.1[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -31,8 +31,8 @@ python_test() {
# Test suite broken with Python 3
local msg="Test suite broken with ${EPYTHON}"
if [[ "${EPYTHON}" == python3* ]]; then
- einfo "${msg}"
- else
+ einfo "${msg}"
+ else
# https://bitbucket.org/logilab/pylint/issue/11/apparent-regression-in-testsuite-pylint
# This 'issue' became' declared fixed by accident for version 0.27.0 despite being made citing 0.28.0
pytest || die "Tests failed under ${EPYTHON}"