summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-22 20:24:43 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-22 20:24:43 +0000
commitfc79b057f622b7b106b5b678e987923b88f46c45 (patch)
treecf5e742060498a51527a7cabd46c7f0bad53e5c5 /dev-python/pip
parentVersion bump. (diff)
downloadgentoo-2-fc79b057f622b7b106b5b678e987923b88f46c45.tar.gz
gentoo-2-fc79b057f622b7b106b5b678e987923b88f46c45.tar.bz2
gentoo-2-fc79b057f622b7b106b5b678e987923b88f46c45.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-6.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 7272e740624c..1f24e9dfd11d 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.44 2014/12/05 10:16:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.45 2014/12/22 20:24:43 radhermit Exp $
+
+*pip-6.0 (22 Dec 2014)
+
+ 22 Dec 2014; Tim Harder <radhermit@gentoo.org> +pip-6.0.ebuild:
+ Version bump.
05 Dec 2014; Agostino Sarubbo <ago@gentoo.org> pip-1.5.6.ebuild:
Stable for x86, wrt bug #530548
diff --git a/dev-python/pip/pip-6.0.ebuild b/dev-python/pip/pip-6.0.ebuild
new file mode 100644
index 000000000000..79a42114476c
--- /dev/null
+++ b/dev-python/pip/pip-6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-6.0.ebuild,v 1.1 2014/12/22 20:24:43 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}