summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-08 13:26:36 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-08 13:26:36 +0000
commit34107335930e92132c03f322a6357bacd2d5a875 (patch)
tree5374dc3671bffe68a3d7751a615b3c4f730c59ac /dev-python/m2secret/m2secret-0.1.1-r1.ebuild
parentVersion bump to 1.0.15. (diff)
downloadgentoo-2-34107335930e92132c03f322a6357bacd2d5a875.tar.gz
gentoo-2-34107335930e92132c03f322a6357bacd2d5a875.tar.bz2
gentoo-2-34107335930e92132c03f322a6357bacd2d5a875.zip
revbump; migrate -> distutils-r1, remove old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/m2secret/m2secret-0.1.1-r1.ebuild')
-rw-r--r--dev-python/m2secret/m2secret-0.1.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/m2secret/m2secret-0.1.1-r1.ebuild b/dev-python/m2secret/m2secret-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..d6cf5e84a34e
--- /dev/null
+++ b/dev-python/m2secret/m2secret-0.1.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/m2secret/m2secret-0.1.1-r1.ebuild,v 1.1 2013/07/08 13:26:36 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Encryption and decryption module and CLI utility"
+HOMEPAGE="http://www.heikkitoivonen.net/m2secret http://pypi.python.org/pypi/m2secret"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/m2crypto-0.18[${PYTHON_USEDEP}]"