summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-31 10:19:19 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-31 10:19:19 +0000
commit09c928676eb943d50fbb60feef8ca827bf0e2c44 (patch)
tree8ebf0c94c32ecad3d752c369e63effe5eb847b5c /dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild
parent0.9.33 version bump. (diff)
downloadgentoo-2-09c928676eb943d50fbb60feef8ca827bf0e2c44.tar.gz
gentoo-2-09c928676eb943d50fbb60feef8ca827bf0e2c44.tar.bz2
gentoo-2-09c928676eb943d50fbb60feef8ca827bf0e2c44.zip
fix to test phase, switch to use of manage.py
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild')
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild
index b65df6a1076f..3229530b1d96 100644
--- a/dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild,v 1.1 2013/05/23 17:52:07 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/django-oauth-plus-2.1.0-r1.ebuild,v 1.2 2013/05/31 10:19:19 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -23,11 +23,7 @@ DEPEND="${RDEPEND}
dev-python/setuptools_hg[${PYTHON_USEDEP}]"
python_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- export SECRET_KEY='green'
- if "${PYTHON}" -c \
- "from django.conf import global_settings;global_settings.SECRET_KEY='$SECRET_KEY'" \
- -m oauth_provider.tests.tests; then
+ if "${PYTHON}" oauth_provider/runtests/manage.py test; then
einfo "Testsuite passed under ${EPYTHON}"
else
die "Testsuite failed under ${EPYTHON}"