summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-11-25 01:16:25 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-11-25 01:16:25 +0000
commitec65e29cbc5e7653b08ab7cb2436517fe9a2b94b (patch)
tree6e8e41d4f68d77003b06ec2691fa573100e54209 /dev-python/apiextractor
parentMarking bugzilla-3.2.9 ppc64 for bug 344081 (diff)
downloadgentoo-2-ec65e29cbc5e7653b08ab7cb2436517fe9a2b94b.tar.gz
gentoo-2-ec65e29cbc5e7653b08ab7cb2436517fe9a2b94b.tar.bz2
gentoo-2-ec65e29cbc5e7653b08ab7cb2436517fe9a2b94b.zip
Version bump, remove old
(Portage version: 2.2_rc90/cvs/Linux i686)
Diffstat (limited to 'dev-python/apiextractor')
-rw-r--r--dev-python/apiextractor/ChangeLog8
-rw-r--r--dev-python/apiextractor/apiextractor-0.3.2.ebuild41
-rw-r--r--dev-python/apiextractor/apiextractor-0.3.3.ebuild41
-rw-r--r--dev-python/apiextractor/apiextractor-0.6.0.ebuild41
-rw-r--r--dev-python/apiextractor/apiextractor-0.7.0-r1.ebuild41
-rw-r--r--dev-python/apiextractor/apiextractor-0.8.1.ebuild (renamed from dev-python/apiextractor/apiextractor-0.8.0.ebuild)8
6 files changed, 9 insertions, 171 deletions
diff --git a/dev-python/apiextractor/ChangeLog b/dev-python/apiextractor/ChangeLog
index abae02aae0d5..c0a83d6afa7b 100644
--- a/dev-python/apiextractor/ChangeLog
+++ b/dev-python/apiextractor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/apiextractor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.8 2010/10/06 20:47:52 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.9 2010/11/25 01:16:25 chiiph Exp $
+
+ 21 Nov 2010; Tomas Touceda <chiiph@gentoo.org> -apiextractor-0.3.2.ebuild,
+ -apiextractor-0.3.3.ebuild, -apiextractor-0.6.0.ebuild,
+ -apiextractor-0.7.0-r1.ebuild, -apiextractor-0.8.0.ebuild,
+ +apiextractor-0.8.1.ebuild:
+ Version bump, remove old
*apiextractor-0.8.0 (06 Oct 2010)
diff --git a/dev-python/apiextractor/apiextractor-0.3.2.ebuild b/dev-python/apiextractor/apiextractor-0.3.2.ebuild
deleted file mode 100644
index d15dfdb2076e..000000000000
--- a/dev-python/apiextractor/apiextractor-0.3.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.3.2.ebuild,v 1.3 2010/01/06 19:50:54 ayoy Exp $
-
-EAPI="2"
-
-inherit cmake-utils virtualx
-
-DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND=">=dev-libs/boost-1.41.0[python]
- dev-libs/libxml2
- dev-libs/libxslt
- >=x11-libs/qt-core-4.5.0
- >=x11-libs/qt-xmlpatterns-4.5.0"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- sed -e 's:share/cmake-2.6/Modules:share/cmake/Modules:' \
- -e '/^install/s/lib/lib${LIB_SUFFIX}/' \
- -i CMakeLists.txt || die "sed failed"
-}
-
-src_test() {
- # bug 299766
- Xemake test -C "${CMAKE_BUILD_DIR}/tests" || die "running tests failed"
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog || die "dodoc failed"
-}
diff --git a/dev-python/apiextractor/apiextractor-0.3.3.ebuild b/dev-python/apiextractor/apiextractor-0.3.3.ebuild
deleted file mode 100644
index 6537d4774465..000000000000
--- a/dev-python/apiextractor/apiextractor-0.3.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.3.3.ebuild,v 1.1 2010/01/20 23:38:16 ayoy Exp $
-
-EAPI="2"
-
-inherit cmake-utils virtualx
-
-DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND=">=dev-libs/boost-1.41.0[python]
- dev-libs/libxml2
- dev-libs/libxslt
- >=x11-libs/qt-core-4.5.0
- >=x11-libs/qt-xmlpatterns-4.5.0"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- sed -e 's:cmake-${CMAKE_MAJOR_VERSION}\.${CMAKE_MINOR_VERSION}:cmake:' \
- -e '/^install/s/lib/lib${LIB_SUFFIX}/' \
- -i CMakeLists.txt || die "sed failed"
-}
-
-src_test() {
- # bug 299766
- Xemake test -C "${CMAKE_BUILD_DIR}/tests" || die "running tests failed"
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog || die "dodoc failed"
-}
diff --git a/dev-python/apiextractor/apiextractor-0.6.0.ebuild b/dev-python/apiextractor/apiextractor-0.6.0.ebuild
deleted file mode 100644
index e47571129f7e..000000000000
--- a/dev-python/apiextractor/apiextractor-0.6.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.6.0.ebuild,v 1.1 2010/06/16 18:53:16 ayoy Exp $
-
-EAPI="2"
-
-inherit cmake-utils virtualx
-
-DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND=">=dev-libs/boost-1.41.0[python]
- dev-libs/libxml2
- dev-libs/libxslt
- >=x11-libs/qt-core-4.5.0
- >=x11-libs/qt-xmlpatterns-4.5.0"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- sed -e 's:cmake-${CMAKE_MAJOR_VERSION}\.${CMAKE_MINOR_VERSION}:cmake:' \
- -e '/^install/s/lib/lib${LIB_SUFFIX}/' \
- -i CMakeLists.txt || die "sed failed"
-}
-
-src_test() {
- # bug 299766
- Xemake test -C "${CMAKE_BUILD_DIR}/tests" || die "running tests failed"
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog || die "dodoc failed"
-}
diff --git a/dev-python/apiextractor/apiextractor-0.7.0-r1.ebuild b/dev-python/apiextractor/apiextractor-0.7.0-r1.ebuild
deleted file mode 100644
index bdcfb5ec98b3..000000000000
--- a/dev-python/apiextractor/apiextractor-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.7.0-r1.ebuild,v 1.1 2010/09/13 15:32:53 ayoy Exp $
-
-EAPI="2"
-
-inherit cmake-utils virtualx
-
-DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug test"
-
-RDEPEND=">=dev-libs/boost-1.41.0[python]
- dev-libs/libxml2
- dev-libs/libxslt
- >=x11-libs/qt-core-4.5.0
- >=x11-libs/qt-xmlpatterns-4.5.0"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- test? ( >=x11-libs/qt-test-4.5.0 )"
-
-src_configure() {
- mycmakeargs="$(cmake-utils_use_build test TESTS)"
- cmake-utils_src_configure
-}
-
-src_test() {
- # bug 299766
- Xemake test -C "${CMAKE_BUILD_DIR}/tests" || die "running tests failed"
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog || die "dodoc failed"
-}
diff --git a/dev-python/apiextractor/apiextractor-0.8.0.ebuild b/dev-python/apiextractor/apiextractor-0.8.1.ebuild
index 28c9530b9b10..fdb69b9b017a 100644
--- a/dev-python/apiextractor/apiextractor-0.8.0.ebuild
+++ b/dev-python/apiextractor/apiextractor-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.8.0.ebuild,v 1.1 2010/10/06 20:47:52 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.8.1.ebuild,v 1.1 2010/11/25 01:16:25 chiiph Exp $
EAPI="2"
@@ -24,17 +24,13 @@ RDEPEND=">=dev-libs/boost-1.41.0[python]
DEPEND="${RDEPEND}
dev-util/pkgconfig
test? ( >=x11-libs/qt-test-4.5.0 )"
+TEST_VERBOSE="1"
src_configure() {
mycmakeargs="$(cmake-utils_use_build test TESTS)"
cmake-utils_src_configure
}
-src_test() {
- # bug 299766
- Xemake test -C "${CMAKE_BUILD_DIR}/tests" || die "running tests failed"
-}
-
src_install() {
cmake-utils_src_install
dodoc AUTHORS ChangeLog || die "dodoc failed"