summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-05-19 05:55:59 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-05-19 05:55:59 +0000
commit748bc957872db42ef7b4d94c7ae0d5a2af31e98e (patch)
treedba0c7280685ef770f116107bab6ad133773e6fb /dev-php
parentRemove old. (diff)
downloadgentoo-2-748bc957872db42ef7b4d94c7ae0d5a2af31e98e.tar.gz
gentoo-2-748bc957872db42ef7b4d94c7ae0d5a2af31e98e.tar.bz2
gentoo-2-748bc957872db42ef7b4d94c7ae0d5a2af31e98e.zip
Version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpunit/ChangeLog7
-rw-r--r--dev-php/phpunit/phpunit-3.7.20.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-php/phpunit/ChangeLog b/dev-php/phpunit/ChangeLog
index 4413444015ca..0e46dc3e9ade 100644
--- a/dev-php/phpunit/ChangeLog
+++ b/dev-php/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/phpunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.13 2013/03/28 10:35:54 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.14 2013/05/19 05:55:59 olemarkus Exp $
+
+*phpunit-3.7.20 (19 May 2013)
+
+ 19 May 2013; Ole Markus With <olemarkus@gentoo.org> +phpunit-3.7.20.ebuild:
+ Version bump
*phpunit-3.7.19 (28 Mar 2013)
diff --git a/dev-php/phpunit/phpunit-3.7.20.ebuild b/dev-php/phpunit/phpunit-3.7.20.ebuild
new file mode 100644
index 000000000000..ad298702cb29
--- /dev/null
+++ b/dev-php/phpunit/phpunit-3.7.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/phpunit-3.7.20.ebuild,v 1.1 2013/05/19 05:55:59 olemarkus Exp $
+
+EAPI=5
+
+DESCRIPTION="A PHP Unit Testing framework"
+HOMEPAGE="http://phpunit.de"
+
+PHPUNIT_PHAR="${P}.phar"
+
+SRC_URI="http://dev.gentoo.org/~olemarkus/phpunit/${PHPUNIT_PHAR}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/php[phar,xml]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/php/phpunit
+ insopts -m755
+ newins "${DISTDIR}"/${PHPUNIT_PHAR} phpunit.phar
+ dosym /usr/share/php/phpunit/phpunit.phar /usr/bin/phpunit
+}
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}