summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-09-05 07:42:35 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-09-05 07:42:35 +0000
commit7004ca6eb045fdc8ab5aa3ea84487b907aa07111 (patch)
tree8fab1ff8d7032ade822d1bd7056c1a481c0e3472 /dev-php5
parentRestoring accidentically removed patch (diff)
downloadgentoo-2-7004ca6eb045fdc8ab5aa3ea84487b907aa07111.tar.gz
gentoo-2-7004ca6eb045fdc8ab5aa3ea84487b907aa07111.tar.bz2
gentoo-2-7004ca6eb045fdc8ab5aa3ea84487b907aa07111.zip
Version bump.
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-apc/ChangeLog8
-rw-r--r--dev-php5/pecl-apc/files/digest-pecl-apc-3.0.12_p23
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.12_p2.ebuild75
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index f35e93c06f67..c14810ff7684 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.13 2006/09/05 03:59:51 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.14 2006/09/05 07:42:35 sebastian Exp $
+
+*pecl-apc-3.0.12_p2 (05 Sep 2006)
+
+ 05 Sep 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ -pecl-apc-3.0.12.ebuild, +pecl-apc-3.0.12_p2.ebuild:
+ Version bump.
*pecl-apc-3.0.12 (05 Sep 2006)
diff --git a/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.12_p2 b/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.12_p2
new file mode 100644
index 000000000000..9969f9ff348c
--- /dev/null
+++ b/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.12_p2
@@ -0,0 +1,3 @@
+MD5 e7f1762ee95cdaaf90cf16345c6228a3 APC-3.0.12p2.tgz 94809
+RMD160 d88c75a348a51b0f0e379704dee5e1edc9fbf8ae APC-3.0.12p2.tgz 94809
+SHA256 a663f65a8207c930efbd8a1dda9e90bf4cd76166d8534771824f80e98081b297 APC-3.0.12p2.tgz 94809
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.12_p2.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.12_p2.ebuild
new file mode 100644
index 000000000000..fda592a2ee21
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.0.12_p2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.12_p2.ebuild,v 1.1 2006/09/05 07:42:35 sebastian Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1 confutils
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP intermediate code."
+LICENSE="PHP"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="${DEPEND} >=dev-lang/php-5.1.1"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ require_php_sapi_from cgi apache apache2
+}
+
+src_compile() {
+ has_php
+
+ # PECL-APC does not work with Zend Thread Safety (ZTS)
+ # so abort if we are using PHP compiled with ZTS.
+ if has_zts ; then
+ eerror "PECL-APC doesn't work with a ZTS enabled PHP."
+ eerror "Please disable ZTS by turning the 'threads'"
+ eerror "USE flag off when you compile dev-lang/php."
+ die "PECL-APC does not support ZTS"
+ fi
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs2 /usr/sbin/apxs2 "optimisation for apache2"
+ enable_extension_with_built_with =${PHP_PKG} apache apxs /usr/sbin/apxs "optimisation for apache1"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+ dodoc-php CHANGELOG INSTALL LICENSE NOTICE
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1000"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.filters" '""'
+ php-ext-base-r1_addtoinifiles "apc.mmap_file_mask" '""'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.include_once_override" '"0"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ einfo "The apc.php file shipped with this release of PECL-APC was"
+ einfo "installed into /usr/share/php5/apc/."
+}