summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-27 21:47:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-27 21:47:02 +0000
commit9b17353e8b15eff545b7e2e874e6a968ce0be891 (patch)
tree9122a9f1e4f29dc2d4026d874772ba0c9d23a9f4 /dev-perl/Net-IRC/Net-IRC-0.79.ebuild
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-9b17353e8b15eff545b7e2e874e6a968ce0be891.tar.gz
gentoo-2-9b17353e8b15eff545b7e2e874e6a968ce0be891.tar.bz2
gentoo-2-9b17353e8b15eff545b7e2e874e6a968ce0be891.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Net-IRC/Net-IRC-0.79.ebuild')
-rw-r--r--dev-perl/Net-IRC/Net-IRC-0.79.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Net-IRC/Net-IRC-0.79.ebuild b/dev-perl/Net-IRC/Net-IRC-0.79.ebuild
new file mode 100644
index 000000000000..e5c6bc1e6f0a
--- /dev/null
+++ b/dev-perl/Net-IRC/Net-IRC-0.79.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-IRC/Net-IRC-0.79.ebuild,v 1.1 2010/03/27 21:47:02 robbat2 Exp $
+
+MODULE_AUTHOR="APEIRON"
+EAPI=2
+inherit perl-module
+
+DESCRIPTION="Perl IRC module"
+
+SLOT="0"
+LICENSE="Artistic"
+# upstream is missing some files from the tarball that are needed.
+# Entry.pm, EventQueue.pm
+# this is being added to the tree just so we can track it.
+KEYWORDS="-*"
+#KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+mydoc="TODO"
+
+DEPEND="dev-lang/perl"
+
+src_prepare() {
+ # Remove the stdin and warning input required re deprecated.
+ sed -i \
+ -e '/or die $warning/d' \
+ -e '/my $acceptance/,/$acceptance eq $ok/d' \
+ "${S}"/Makefile.PL
+ perl-module_src_prepare
+}