summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-21 12:35:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-21 12:35:21 +0000
commit191e6c5cf52b3807e6f02ffdb2c3fc550d1acf8d (patch)
tree172270f3c18c11976eb3ad6db13befe09aeb19c7 /dev-ml
parentRevision bump. Adding desktop entry. (diff)
downloadgentoo-2-191e6c5cf52b3807e6f02ffdb2c3fc550d1acf8d.tar.gz
gentoo-2-191e6c5cf52b3807e6f02ffdb2c3fc550d1acf8d.tar.bz2
gentoo-2-191e6c5cf52b3807e6f02ffdb2c3fc550d1acf8d.zip
define eapi before inherit and assign rdepend explicitly
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlzip/ChangeLog7
-rw-r--r--dev-ml/camlzip/camlzip-1.03-r1.ebuild11
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
index 5815347be589..78b5e4455f53 100644
--- a/dev-ml/camlzip/ChangeLog
+++ b/dev-ml/camlzip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/camlzip
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.14 2008/09/25 12:36:29 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.15 2009/06/21 12:35:21 aballier Exp $
+
+ 21 Jun 2009; Alexis Ballier <aballier@gentoo.org> camlzip-1.03-r1.ebuild:
+ define eapi before inherit and assign rdepend explicitly
25 Sep 2008; Alexis Ballier <aballier@gentoo.org> camlzip-1.03-r1.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ml/camlzip/camlzip-1.03-r1.ebuild b/dev-ml/camlzip/camlzip-1.03-r1.ebuild
index 02a67ad4cc2e..858d65a770fc 100644
--- a/dev-ml/camlzip/camlzip-1.03-r1.ebuild
+++ b/dev-ml/camlzip/camlzip-1.03-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.03-r1.ebuild,v 1.5 2008/09/25 12:36:29 aballier Exp $
-
-inherit findlib eutils
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.03-r1.ebuild,v 1.6 2009/06/21 12:35:21 aballier Exp $
EAPI="1"
+inherit findlib eutils
+
IUSE="+ocamlopt"
DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
@@ -16,8 +16,9 @@ SLOT="1"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
-DEPEND=">=dev-lang/ocaml-3.04 \
+RDEPEND=">=dev-lang/ocaml-3.04
>=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
pkg_setup() {
if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then