summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-09-07 14:32:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-09-07 14:32:46 +0000
commitb13355065b604a9595021627cd556bbd2c52da8a (patch)
tree10502cb2c728de4a61f04490b8191fbe5f9ed68f /dev-lisp/cl-common-idioms
parentStable on amd64 (diff)
downloadgentoo-2-b13355065b604a9595021627cd556bbd2c52da8a.tar.gz
gentoo-2-b13355065b604a9595021627cd556bbd2c52da8a.tar.bz2
gentoo-2-b13355065b604a9595021627cd556bbd2c52da8a.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lisp/cl-common-idioms')
-rw-r--r--dev-lisp/cl-common-idioms/ChangeLog10
-rw-r--r--dev-lisp/cl-common-idioms/Manifest3
-rw-r--r--dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild30
-rw-r--r--dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-31
-rw-r--r--dev-lisp/cl-common-idioms/metadata.xml5
5 files changed, 49 insertions, 0 deletions
diff --git a/dev-lisp/cl-common-idioms/ChangeLog b/dev-lisp/cl-common-idioms/ChangeLog
new file mode 100644
index 000000000000..a1bc2de5d3e1
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-common-idioms
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-common-idioms/ChangeLog,v 1.1 2005/09/07 14:32:46 mkennedy Exp $
+
+*cl-common-idioms-3 (07 Sep 2005)
+
+ 07 Sep 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-common-idioms-3.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-common-idioms/Manifest b/dev-lisp/cl-common-idioms/Manifest
new file mode 100644
index 000000000000..b2b6652e93f0
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/Manifest
@@ -0,0 +1,3 @@
+MD5 0b87d7d86e2ef44c6619acb0004eea33 cl-common-idioms-3.ebuild 753
+MD5 406b468caca69a1e7c3670831594f9f2 metadata.xml 496
+MD5 48cc7c24542420a5efc1684128555023 files/digest-cl-common-idioms-3 66
diff --git a/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild b/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild
new file mode 100644
index 000000000000..b365b025fe51
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild,v 1.1 2005/09/07 14:32:46 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A small Common Lisp library implementing various Common Lisp idioms."
+HOMEPAGE="http://www.unmutual.info/software/common-idioms/"
+SRC_URI="mirror://gentoo/common-idioms-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+CLPACKAGE=common-idioms
+
+S=${WORKDIR}/common-idioms-${PV}
+
+src_unpack() {
+ unpack ${A}
+ rm ${S}/Makefile
+}
+
+src_install() {
+ common-lisp-install *.{asd,lisp}
+ common-lisp-system-symlink
+ dodoc LICENSE README
+ dohtml docs/*.{html,css}
+ dohtml -r docs/icons
+}
diff --git a/dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-3 b/dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-3
new file mode 100644
index 000000000000..8d648969fb4d
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-3
@@ -0,0 +1 @@
+MD5 292c806ac3781ed164f8bdb7805b4d7a common-idioms-3.tar.gz 19283
diff --git a/dev-lisp/cl-common-idioms/metadata.xml b/dev-lisp/cl-common-idioms/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>