summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2007-03-21 10:10:23 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2007-03-21 10:10:23 +0000
commitf98caee8b35013d9317038d8f9f935e4b7bc5701 (patch)
tree067012ed448c34206ca96358bfe4078c12eb1369 /dev-libs
parentNew upstream release. (diff)
downloadgentoo-2-f98caee8b35013d9317038d8f9f935e4b7bc5701.tar.gz
gentoo-2-f98caee8b35013d9317038d8f9f935e4b7bc5701.tar.bz2
gentoo-2-f98caee8b35013d9317038d8f9f935e4b7bc5701.zip
Handling -fPIC for x86_64. Fixed bug #167628.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/hashit/ChangeLog7
-rw-r--r--dev-libs/hashit/hashit-0.9.4.ebuild22
2 files changed, 20 insertions, 9 deletions
diff --git a/dev-libs/hashit/ChangeLog b/dev-libs/hashit/ChangeLog
index 2419be3d26a9..765d68a1b8b7 100644
--- a/dev-libs/hashit/ChangeLog
+++ b/dev-libs/hashit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/hashit
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/ChangeLog,v 1.8 2006/11/16 11:22:03 pyrania Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/ChangeLog,v 1.9 2007/03/21 10:10:23 pyrania Exp $
+
+ 21 Mar 2007; Markus Nigbur <pyrania@gentoo.org> hashit-0.9.4.ebuild:
+ Handling -fPIC for x86_64. Fixed bug #167628.
*hashit-0.9.4 (16 Nov 2006)
diff --git a/dev-libs/hashit/hashit-0.9.4.ebuild b/dev-libs/hashit/hashit-0.9.4.ebuild
index 77c028c608aa..ff3c0e2734f5 100644
--- a/dev-libs/hashit/hashit-0.9.4.ebuild
+++ b/dev-libs/hashit/hashit-0.9.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/hashit-0.9.4.ebuild,v 1.1 2006/11/16 11:22:03 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/hashit-0.9.4.ebuild,v 1.2 2007/03/21 10:10:23 pyrania Exp $
+
+inherit flag-o-matic toolchain-funcs multilib
DESCRIPTION="Hashit is a library of generic hash tables that supports different collision handling methods with one common interface. Both data and keys can be of any type. It is small and easy to use."
HOMEPAGE="http://www.pleyades.net/david/projects/"
@@ -9,19 +11,25 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
- ./0 --prefix=${D}/usr --infodir=${D}/usr/share/info:${D}/usr/X11R6/info
+ cd "${S}"
+
+ use amd64 && append-flags -fPIC
}
src_compile() {
- emake || die "emake failed"
+ ./0 --prefix="${D}"/usr \
+ --infodir="${D}"/usr/share/info:"${D}"/usr/X11R6/info \
+ --libdir="${D}/usr/$(get_libdir)"
+ emake GCC="$(tc-getCC)" LD="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
einstall || die "einstall failed"
- dosym libhashit.so /usr/lib/libhashit.so.0
+ rm "${D}/usr/$(get_libdir)/libhashit.so"
+ dosym libhashit.so.1.0 /usr/"$(get_libdir)"/libhashit.so
+ dosym libhashit.so /usr/"$(get_libdir)"/libhashit.so.0
}