summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-07-26 20:17:56 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-07-26 20:17:56 +0000
commit668c9328aa0894779dc9fdecbf3f56bf10f25b08 (patch)
treebd48d3e1680ac73ba199fc76fcbaedb0842b5024 /dev-libs
parentRemove gst-plugins-opengl from tree since it disappeared from upstream package. (diff)
downloadgentoo-2-668c9328aa0894779dc9fdecbf3f56bf10f25b08.tar.gz
gentoo-2-668c9328aa0894779dc9fdecbf3f56bf10f25b08.tar.bz2
gentoo-2-668c9328aa0894779dc9fdecbf3f56bf10f25b08.zip
Add patch from upstream svn to prevent a crash in Python expat bindings (bug #197043)
(Portage version: 2.2_rc3/cvs/Linux 2.6.26 i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/expat/ChangeLog9
-rw-r--r--dev-libs/expat/expat-2.0.1-r1.ebuild40
-rw-r--r--dev-libs/expat/files/expat-2.0.1-check_stopped_parser.patch11
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index 2a291871872e..6222082fd0c1 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/expat
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.70 2008/03/10 01:39:03 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.71 2008/07/26 20:17:56 ford_prefect Exp $
+
+*expat-2.0.1-r1 (26 Jul 2008)
+
+ 26 Jul 2008; Arun Raghavan <ford_prefect@gentoo.org>
+ +files/expat-2.0.1-check_stopped_parser.patch, +expat-2.0.1-r1.ebuild:
+ Add patch from upstream svn to prevent a crash in Python expat bindings
+ (bug #197043)
10 Mar 2008; <ricmm@gentoo.org> expat-1.95.8.ebuild:
Drop to ~mips due to unstable deps
diff --git a/dev-libs/expat/expat-2.0.1-r1.ebuild b/dev-libs/expat/expat-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..2289f7db429f
--- /dev/null
+++ b/dev-libs/expat/expat-2.0.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.1-r1.ebuild,v 1.1 2008/07/26 20:17:56 ford_prefect Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="XML parsing libraries"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix segmentation fault in python tests (bug #197043)
+ epatch "${FILESDIR}/${P}-check_stopped_parser.patch"
+
+ elibtoolize
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc Changes README
+ dohtml doc/*
+}
+
+pkg_postinst() {
+ ewarn "Please note that the soname of the library changed!"
+ ewarn "If you are upgrading from a previous version you need"
+ ewarn "to fix dynamic linking inconsistencies by executing:"
+ ewarn "revdep-rebuild -X --library libexpat.so.0"
+}
diff --git a/dev-libs/expat/files/expat-2.0.1-check_stopped_parser.patch b/dev-libs/expat/files/expat-2.0.1-check_stopped_parser.patch
new file mode 100644
index 000000000000..23cebfdc43a5
--- /dev/null
+++ b/dev-libs/expat/files/expat-2.0.1-check_stopped_parser.patch
@@ -0,0 +1,11 @@
+--- lib/xmlparse.c 2007-05-08 05:25:35.000000000 +0300
++++ lib/xmlparse.c 2008-01-08 13:17:07.000000000 +0200
+@@ -2563,6 +2563,8 @@
+ (int)(dataPtr - (ICHAR *)dataBuf));
+ if (s == next)
+ break;
++ if (ps_parsing == XML_FINISHED || ps_parsing == XML_SUSPENDED)
++ break;
+ *eventPP = s;
+ }
+ }