summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 02:18:13 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 02:18:13 +0000
commit64bf72907497c8f505d5cefdf2139e8b0bff304d (patch)
treeacf281f3f16e459167394d99e57441e47ac34e97 /dev-libs
parentcleanup old portage styles (diff)
downloadgentoo-2-64bf72907497c8f505d5cefdf2139e8b0bff304d.tar.gz
gentoo-2-64bf72907497c8f505d5cefdf2139e8b0bff304d.tar.bz2
gentoo-2-64bf72907497c8f505d5cefdf2139e8b0bff304d.zip
DEBUG -> use debug
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild20
-rw-r--r--dev-libs/libsigc++/libsigc++-1.2.2.ebuild25
-rw-r--r--dev-libs/libsigc++/libsigc++-1.2.3.ebuild25
-rw-r--r--dev-libs/libsigc++/libsigc++-1.2.5.ebuild10
4 files changed, 32 insertions, 48 deletions
diff --git a/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild b/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
index a04e7660a3c4..a7de8afa7661 100644
--- a/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
@@ -1,29 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild,v 1.10 2003/07/11 20:13:59 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild,v 1.11 2003/08/03 02:18:13 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="The GLib library of C routines"
-SRC_URI="http://download.sourceforge.net/libsigc/${P}.tar.gz"
HOMEPAGE="http://libsigc.sourceforge.net/"
+SRC_URI="http://download.sourceforge.net/libsigc/${P}.tar.gz"
-SLOT="1.0"
LICENSE="GPL-2 LGPL-2.1"
+SLOT="1.0"
KEYWORDS="x86 ppc sparc hppa"
+IUSE="debug"
DEPEND="virtual/glibc"
src_compile() {
-
local myconf=""
-
- if [ "${DEBUG}" ]
- then
- myconf="--enable-debug=yes"
- else
- myconf="--enable-debug=no"
- fi
-
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
econf ${myconf} || die
# Fix sandbox violation when old libsig++ is already installed,
diff --git a/dev-libs/libsigc++/libsigc++-1.2.2.ebuild b/dev-libs/libsigc++/libsigc++-1.2.2.ebuild
index 74463964f74e..8f5ecbd2a45a 100644
--- a/dev-libs/libsigc++/libsigc++-1.2.2.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.2.2.ebuild
@@ -1,28 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.2.ebuild,v 1.5 2003/02/13 10:45:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.2.ebuild,v 1.6 2003/08/03 02:18:13 vapier Exp $
-S=${WORKDIR}/${P}
-IUSE=""
DESCRIPTION="The GLib library of C routines"
-SRC_URI="mirror://sourceforge/libsigc/${P}.tar.gz"
HOMEPAGE="http://libsigc.sourceforge.net/"
-SLOT="1.2"
+SRC_URI="mirror://sourceforge/libsigc/${P}.tar.gz"
+
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="x86 ~ppc ~sparc "
+SLOT="1.2"
+KEYWORDS="x86 ~ppc ~sparc"
+IUSE="debug"
DEPEND="virtual/glibc"
src_compile() {
- local myconf
-
- if [ "${DEBUG}" ]
- then
- myconf="--enable-debug=yes"
- else
- myconf="--enable-debug=no"
- fi
-
+ local myconf=""
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
econf ${myconf} --enable-threads || die
emake || die "emake failure"
}
diff --git a/dev-libs/libsigc++/libsigc++-1.2.3.ebuild b/dev-libs/libsigc++/libsigc++-1.2.3.ebuild
index 5d8c775c7b8b..302ba3d77cc4 100644
--- a/dev-libs/libsigc++/libsigc++-1.2.3.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.2.3.ebuild
@@ -1,28 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.3.ebuild,v 1.3 2003/05/16 12:57:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.3.ebuild,v 1.4 2003/08/03 02:18:13 vapier Exp $
-S=${WORKDIR}/${P}
-IUSE=""
DESCRIPTION="The GLib library of C routines"
-SRC_URI="mirror://sourceforge/libsigc/${P}.tar.gz"
HOMEPAGE="http://libsigc.sourceforge.net/"
-SLOT="1.2"
+SRC_URI="mirror://sourceforge/libsigc/${P}.tar.gz"
+
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="x86 ~ppc ~sparc "
+SLOT="1.2"
+KEYWORDS="x86 ~ppc ~sparc"
+IUSE="debug"
DEPEND="virtual/glibc"
src_compile() {
- local myconf
-
- if [ "${DEBUG}" ]
- then
- myconf="--enable-debug=yes"
- else
- myconf="--enable-debug=no"
- fi
-
+ local myconf=""
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
econf ${myconf} --enable-threads || die
emake || die "emake failure"
}
diff --git a/dev-libs/libsigc++/libsigc++-1.2.5.ebuild b/dev-libs/libsigc++/libsigc++-1.2.5.ebuild
index d63546059bc5..8b43b04ac6b3 100644
--- a/dev-libs/libsigc++/libsigc++-1.2.5.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.2.5.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.5.ebuild,v 1.4 2003/07/23 19:09:21 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.5.ebuild,v 1.5 2003/08/03 02:18:13 vapier Exp $
-IUSE="debug"
DESCRIPTION="The GLib library of C routines"
-SRC_URI="mirror://sourceforge/libsigc/${P}.tar.gz"
HOMEPAGE="http://libsigc.sourceforge.net/"
-SLOT="1.2"
+SRC_URI="mirror://sourceforge/libsigc/${P}.tar.gz"
+
LICENSE="GPL-2 LGPL-2.1"
+SLOT="1.2"
KEYWORDS="x86 ~ppc ~sparc hppa"
+IUSE="debug"
DEPEND="virtual/glibc"
src_compile() {
local myconf
-
use debug \
&& myconf="--enable-debug=yes" \
|| myconf="--enable-debug=no"