summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-01-23 22:02:13 +0000
committerMike Auty <ikelos@gentoo.org>2010-01-23 22:02:13 +0000
commit0719cf09a2676871a00b82253bbad3c67264527c (patch)
treebc4e76b25ba19808eea5e058789816d753a531ee /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-0719cf09a2676871a00b82253bbad3c67264527c.tar.gz
gentoo-2-0719cf09a2676871a00b82253bbad3c67264527c.tar.bz2
gentoo-2-0719cf09a2676871a00b82253bbad3c67264527c.zip
Version bump libnfc.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnfc/ChangeLog9
-rw-r--r--dev-libs/libnfc/libnfc-1.3.1.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-libs/libnfc/ChangeLog b/dev-libs/libnfc/ChangeLog
index ee50badf7d59..ff6a09c3d047 100644
--- a/dev-libs/libnfc/ChangeLog
+++ b/dev-libs/libnfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnfc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.1 2009/08/16 14:18:29 ikelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.2 2010/01/23 22:02:13 ikelos Exp $
+
+*libnfc-1.3.1 (23 Jan 2010)
+
+ 23 Jan 2010; Mike Auty <ikelos@gentoo.org> +libnfc-1.3.1.ebuild:
+ Version bump libnfc.
*libnfc-1.2.1 (16 Aug 2009)
diff --git a/dev-libs/libnfc/libnfc-1.3.1.ebuild b/dev-libs/libnfc/libnfc-1.3.1.ebuild
new file mode 100644
index 000000000000..ddee072bd120
--- /dev/null
+++ b/dev-libs/libnfc/libnfc-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/libnfc-1.3.1.ebuild,v 1.1 2010/01/23 22:02:13 ikelos Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Near Field Communications (NFC) library"
+HOMEPAGE="http://www.libnfc.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+CDEPEND="sys-apps/pcsc-lite
+ dev-libs/libusb"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+src_compile() {
+ emake || die "Failed to compile."
+ use doc && doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install properly."
+ use doc && dohtml "${S}"/doc/html/*
+}