summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2006-08-28 14:14:01 +0000
committerHarald van Dijk <truedfx@gentoo.org>2006-08-28 14:14:01 +0000
commit09e8e5e6927b7ad5d7a95699132047a8684d592a (patch)
tree1e2490916cd52998968db859457aee37a4743859 /dev-libs/tvision
parentNew upstream version. (diff)
downloadgentoo-2-09e8e5e6927b7ad5d7a95699132047a8684d592a.tar.gz
gentoo-2-09e8e5e6927b7ad5d7a95699132047a8684d592a.tar.bz2
gentoo-2-09e8e5e6927b7ad5d7a95699132047a8684d592a.zip
Version bump plus gcc41 compatibility for #130223
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'dev-libs/tvision')
-rw-r--r--dev-libs/tvision/ChangeLog8
-rw-r--r--dev-libs/tvision/files/digest-tvision-2.1.0_pre13
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre1-gcc41.patch26
-rw-r--r--dev-libs/tvision/tvision-2.1.0_pre1.ebuild37
4 files changed, 73 insertions, 1 deletions
diff --git a/dev-libs/tvision/ChangeLog b/dev-libs/tvision/ChangeLog
index 94e84119f51d..d993bc8dd257 100644
--- a/dev-libs/tvision/ChangeLog
+++ b/dev-libs/tvision/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/tvision
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/tvision/ChangeLog,v 1.10 2006/07/30 19:53:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tvision/ChangeLog,v 1.11 2006/08/28 14:14:01 truedfx Exp $
+
+*tvision-2.1.0_pre1 (28 Aug 2006)
+
+ 28 Aug 2006; Harald van Dijk <truedfx@gentoo.org>
+ +files/tvision-2.1.0_pre1-gcc41.patch, +tvision-2.1.0_pre1.ebuild:
+ Add 2.1.0_pre1 with a gcc41 compatibility patch for #130223
30 Jul 2006; Mike Frysinger <vapier@gentoo.org>
+files/tvision-2.0.3-gcc4.patch, tvision-2.0.3.ebuild:
diff --git a/dev-libs/tvision/files/digest-tvision-2.1.0_pre1 b/dev-libs/tvision/files/digest-tvision-2.1.0_pre1
new file mode 100644
index 000000000000..424005515ba5
--- /dev/null
+++ b/dev-libs/tvision/files/digest-tvision-2.1.0_pre1
@@ -0,0 +1,3 @@
+MD5 7628fce4ab7592e10714976ec74323df rhtvision_2.1.0-1.tar.gz 1088801
+RMD160 f1bf444f9471c028feeffedb41b06174d25570ee rhtvision_2.1.0-1.tar.gz 1088801
+SHA256 e479fa8bd3a4a600ad4f3b3d9785f834f888d45d61c1e34722bf1a41420aaf1a rhtvision_2.1.0-1.tar.gz 1088801
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre1-gcc41.patch b/dev-libs/tvision/files/tvision-2.1.0_pre1-gcc41.patch
new file mode 100644
index 000000000000..832ff189d395
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre1-gcc41.patch
@@ -0,0 +1,26 @@
+diff -ur tvision.orig/include/compatlayer.h tvision/include/compatlayer.h
+--- tvision.orig/include/compatlayer.h 2006-08-28 15:21:46.000000000 +0200
++++ tvision/include/compatlayer.h 2006-08-28 15:22:06.000000000 +0200
+@@ -812,10 +812,6 @@
+ #define _GNU_SOURCE
+ #define CLY_getline getline
+ #endif
+- // Avoid including libintl.h, we have the prototypes
+- // This is a temporal workaround.
+- #undef _LIBINTL_H
+- #define _LIBINTL_H 1
+ #endif
+
+ /* Solaris using gcc but not glibc */
+diff -ur tvision.orig/include/tv/inputln.h tvision/include/tv/inputln.h
+--- tvision.orig/include/tv/inputln.h 2006-08-28 15:21:46.000000000 +0200
++++ tvision/include/tv/inputln.h 2006-08-28 15:23:07.000000000 +0200
+@@ -201,7 +201,7 @@
+ { return name; }
+
+ protected:
+- TInputLine::TInputLine(StreamableInit) :
++ TInputLine(StreamableInit) :
+ TInputLineBaseT<char,TDrawBuffer>(streamableInit) {}
+
+ public:
diff --git a/dev-libs/tvision/tvision-2.1.0_pre1.ebuild b/dev-libs/tvision/tvision-2.1.0_pre1.ebuild
new file mode 100644
index 000000000000..fc6fc06ce385
--- /dev/null
+++ b/dev-libs/tvision/tvision-2.1.0_pre1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tvision/tvision-2.1.0_pre1.ebuild,v 1.1 2006/08/28 14:14:01 truedfx Exp $
+
+inherit eutils
+
+DESCRIPTION="Text User Interface that implements the well known CUA widgets"
+HOMEPAGE="http://tvision.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tvision/rhtvision_${PV/_pre/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --fhs \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dosym rhtvision /usr/include/tvision
+ dodoc readme.txt THANKS TODO
+ dohtml -r www-site
+}