summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-10-21 14:07:00 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-10-21 14:07:00 +0000
commit340b91632854e4e56190a1241247b269d2b3b71c (patch)
treeaeb745af9c5627673a0015fb3f6fbd4981230cff /dev-libs/phlib
parentRemoved myself as maintainer. See bug #232233 (diff)
downloadgentoo-2-340b91632854e4e56190a1241247b269d2b3b71c.tar.gz
gentoo-2-340b91632854e4e56190a1241247b269d2b3b71c.tar.bz2
gentoo-2-340b91632854e4e56190a1241247b269d2b3b71c.zip
Fix bug 240213 with patches imported from PLD linux. Make phlib not break the sandbox, now that it compiles.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-rc8 x86_64)
Diffstat (limited to 'dev-libs/phlib')
-rw-r--r--dev-libs/phlib/ChangeLog9
-rw-r--r--dev-libs/phlib/files/phlib-soname.patch34
-rw-r--r--dev-libs/phlib/files/phlib-types.patch11
-rw-r--r--dev-libs/phlib/phlib-1.20.ebuild16
4 files changed, 63 insertions, 7 deletions
diff --git a/dev-libs/phlib/ChangeLog b/dev-libs/phlib/ChangeLog
index 9b645b524d44..03e39e92fd9c 100644
--- a/dev-libs/phlib/ChangeLog
+++ b/dev-libs/phlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/phlib
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/phlib/ChangeLog,v 1.4 2007/02/09 02:35:53 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/phlib/ChangeLog,v 1.5 2008/10/21 14:07:00 loki_val Exp $
+
+ 21 Oct 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/phlib-soname.patch, +files/phlib-types.patch, phlib-1.20.ebuild:
+ Fix bug 240213 with patches imported from PLD linux. Make phlib not break
+ the sandbox, now that it compiles.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-libs/phlib/files/phlib-soname.patch b/dev-libs/phlib/files/phlib-soname.patch
new file mode 100644
index 000000000000..9c11cd95285f
--- /dev/null
+++ b/dev-libs/phlib/files/phlib-soname.patch
@@ -0,0 +1,34 @@
+--- phlib-1.20/Makefile.in~ Mon Oct 20 21:08:46 2003
++++ phlib-1.20/Makefile.in Fri Dec 5 18:02:38 2003
+@@ -108,7 +108,9 @@
+ $(OURLIBSO): $(OBJS) $(HEAD)
+ @echo Creating shared library $(OURLIBSO)
+ @rm -f $@
+- $(SHLD) -o $@ $(OBJS)
++ $(CC) -shared -o$@.$(VER_MAJOR).$(VER_MINOR) -Wl,-soname=$@.$(VER_MAJOR) $(OBJS)
++ ln -sf $@.$(VER_MAJOR).$(VER_MINOR) $@.$(VER_MAJOR)
++ ln -sf $@.$(VER_MAJOR).$(VER_MINOR) $@
+
+ $(OURLIBDB): $(OBJS) $(MDBOBJS) $(HEAD)
+ @echo Creating library $@
+@@ -118,15 +120,17 @@
+ $(OURLIBDBSO): $(OBJS) $(MDBOBJS) $(HEAD)
+ @echo Creating shared library $@
+ @rm -f $@
+- $(SHLD) -o $@ $(OBJS) $(MDBOBJS)
++ $(CC) -shared -o$@.$(VER_MAJOR).$(VER_MINOR) -Wl,-soname=$@.$(VER_MAJOR) $(OBJS)
++ ln -sf $@.$(VER_MAJOR).$(VER_MINOR) $@.$(VER_MAJOR)
++ ln -sf $@.$(VER_MAJOR).$(VER_MINOR) $@
+
+ $(OBJ)/%.o: %.c $(HEAD)
+ $(CC) $(CFLAGS) -D_XL_LIB_BUILD -o $@ $<
+
+ install: $(OURLIB)
+ @./mkinstalldirs $(i_libdir) $(MINC)
+- @./install-lib $(OURLIB) $(OURLIB) $(i_libdir) $(VER_MAJOR) $(VER_MINOR)
+- @./install-lib $(OURLIBSO) $(OURLIBSO) $(i_libdir) $(VER_MAJOR) $(VER_MINOR)
++ @install $(OURLIB) $(i_libdir)/$(OURLIB)
++ @./install-lib $(OURLIBSO).$(VER_MAJOR).$(VER_MINOR) $(OURLIBSO) $(i_libdir) $(VER_MAJOR) $(VER_MINOR)
+ @./install-head $(SINC) $(MINC) $(HEADF)
+
+ clean:
diff --git a/dev-libs/phlib/files/phlib-types.patch b/dev-libs/phlib/files/phlib-types.patch
new file mode 100644
index 000000000000..7cca8acf461a
--- /dev/null
+++ b/dev-libs/phlib/files/phlib-types.patch
@@ -0,0 +1,11 @@
+--- phlib-1.20/include/phlib/xl_ufile.h~ 2003-01-11 13:40:09.000000000 +0100
++++ phlib-1.20/include/phlib/xl_ufile.h 2007-09-05 18:30:40.000000000 +0200
+@@ -32,7 +32,7 @@
+ extern "C" {
+ #endif
+
+-Boolean xl_unique_filename(char*,const char*,size_t);
++RetValue xl_unique_filename(char*,const char*,size_t);
+
+ #ifdef __cplusplus
+ } /* extern "C" */
diff --git a/dev-libs/phlib/phlib-1.20.ebuild b/dev-libs/phlib/phlib-1.20.ebuild
index 1b151f6b43d7..6502dbac90db 100644
--- a/dev-libs/phlib/phlib-1.20.ebuild
+++ b/dev-libs/phlib/phlib-1.20.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/phlib/phlib-1.20.ebuild,v 1.4 2004/07/02 04:53:46 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/phlib/phlib-1.20.ebuild,v 1.5 2008/10/21 14:07:00 loki_val Exp $
+
+inherit eutils
DESCRIPTION="phlib is a collection of support functions and classes used by Goldwater and the DGEE"
HOMEPAGE="http://www.nfluid.com/"
@@ -16,14 +18,18 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
- sed -i s/cflags/CFLAGS/ ${S}/configure
+ cd "${S}"
+ sed -i s/cflags/CFLAGS/ configure
+ epatch "${FILESDIR}/${PN}-types.patch"
+ epatch "${FILESDIR}/${PN}-soname.patch"
}
src_compile() {
+ CFLAGS="${CFLAGS} -fPIC -Wall"
econf || die "econf failed"
- emake || die "emake failed"
+ emake -j1 || die "emake failed"
}
src_install() {
- einstall || die "einstall failed"
+ emake -j1 DESTDIR="${D}" install || die "install failed"
}