summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-07-13 01:26:06 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-07-13 01:26:06 +0000
commitba15bece04d11b27c0472af3b1e49333bd22b89a (patch)
treeaeedcd09f7cda7df6c9b829bf0fc688d589260fc /dev-libs/libxml2
parentVersion bumped to fix critical bug in new postconf code. (diff)
downloadgentoo-2-ba15bece04d11b27c0472af3b1e49333bd22b89a.tar.gz
gentoo-2-ba15bece04d11b27c0472af3b1e49333bd22b89a.tar.bz2
gentoo-2-ba15bece04d11b27c0472af3b1e49333bd22b89a.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/Manifest4
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.6.201
-rw-r--r--dev-libs/libxml2/libxml2-2.6.20.ebuild81
4 files changed, 91 insertions, 2 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 07469a5106cf..e5bb6884f67f 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.124 2005/07/11 23:23:06 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.125 2005/07/13 01:26:06 ka0ttic Exp $
+
+*libxml2-2.6.20 (13 Jul 2005)
+
+ 13 Jul 2005; Aaron Walker <ka0ttic@gentoo.org> +libxml2-2.6.20.ebuild:
+ Version bump.
11 Jul 2005; Stephen P. Becker <geoman@gentoo.org> libxml2-2.6.19.ebuild:
stable on mips
diff --git a/dev-libs/libxml2/Manifest b/dev-libs/libxml2/Manifest
index f107620c5076..2e71debfc143 100644
--- a/dev-libs/libxml2/Manifest
+++ b/dev-libs/libxml2/Manifest
@@ -1,9 +1,11 @@
MD5 47e51f2596c69d2b8ee7c34a39f2a647 libxml2-2.6.17.ebuild 1704
MD5 13deda47a793ca743ac38a331389a276 libxml2-2.6.19.ebuild 2036
+MD5 5941171587febb69c9b262c8b5f64e79 libxml2-2.6.20.ebuild 2049
MD5 2c997a3eeb8cebea6c43aeeb58d08e2c libxml2-2.6.16.ebuild 1775
-MD5 da71b710bd496c3f9311e4fc83afdf63 ChangeLog 14548
+MD5 9a42fd6e42dad171a284625df3893e9a ChangeLog 14669
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 3451360f628f1e2dc20813a52fbaa404 files/libxml2-2.6.16-xlattable.patch 537
MD5 ff7efcdcc2a364b0eeca271ef52566f8 files/digest-libxml2-2.6.16 68
MD5 8409491d7d4c895c3a509a3c1c121e02 files/digest-libxml2-2.6.17 68
MD5 761d617849c91c951713a1411f3c1cff files/digest-libxml2-2.6.19 68
+MD5 4afb7240de6f033dc7cd147c38d2b06f files/digest-libxml2-2.6.20 68
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.6.20 b/dev-libs/libxml2/files/digest-libxml2-2.6.20
new file mode 100644
index 000000000000..cc6731987dbf
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.6.20
@@ -0,0 +1 @@
+MD5 342f722d1770071be19253f229fef677 libxml2-2.6.20.tar.bz2 3115868
diff --git a/dev-libs/libxml2/libxml2-2.6.20.ebuild b/dev-libs/libxml2/libxml2-2.6.20.ebuild
new file mode 100644
index 000000000000..9f5eae3cd1e9
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.6.20.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.20.ebuild,v 1.1 2005/07/13 01:26:06 ka0ttic Exp $
+
+inherit libtool gnome.org flag-o-matic eutils
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python readline ipv6"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+
+ unpack ${A}
+ epunt_cxx
+
+}
+
+src_compile() {
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ econf --with-zlib \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_enable ipv6) || die
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86766, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find ${S} -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+}
+
+pkg_postinst() {
+
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG=/etc/xml/catalog
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d /etc/xml ] || mkdir /etc/xml
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+
+}