summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-06-18 19:38:10 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-06-18 19:38:10 +0000
commit090f1f7d69247b7199e76c977eca7be0c2d3fb88 (patch)
tree8c6f51ed0ff47da3a4fa02ec1f145df88d2ff1f6 /dev-libs/libisofs
parentmostly to remove odd whitespace in KEYWORDS to be friendly with our search tools (diff)
downloadgentoo-2-090f1f7d69247b7199e76c977eca7be0c2d3fb88.tar.gz
gentoo-2-090f1f7d69247b7199e76c977eca7be0c2d3fb88.tar.bz2
gentoo-2-090f1f7d69247b7199e76c977eca7be0c2d3fb88.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libisofs')
-rw-r--r--dev-libs/libisofs/ChangeLog7
-rw-r--r--dev-libs/libisofs/libisofs-0.6.20.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-libs/libisofs/ChangeLog b/dev-libs/libisofs/ChangeLog
index 5ccc9a8d5f44..b847b0956a60 100644
--- a/dev-libs/libisofs/ChangeLog
+++ b/dev-libs/libisofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libisofs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.32 2009/05/07 20:23:19 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.33 2009/06/18 19:38:10 billie Exp $
+
+*libisofs-0.6.20 (18 Jun 2009)
+
+ 18 Jun 2009; Pielmeier Daniel <billie@gentoo.org> +libisofs-0.6.20.ebuild:
+ Version bump.
07 May 2009; Tobias Klausmann <klausman@gentoo.org>
libisofs-0.6.18.ebuild:
diff --git a/dev-libs/libisofs/libisofs-0.6.20.ebuild b/dev-libs/libisofs/libisofs-0.6.20.ebuild
new file mode 100644
index 000000000000..72d95d01b896
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-0.6.20.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/libisofs-0.6.20.ebuild,v 1.1 2009/06/18 19:38:10 billie Exp $
+
+EAPI=2
+
+DESCRIPTION="libisofs is an open-source library for reading, mastering and writing optical discs."
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+#IUSE="test"
+
+# http://libburnia-project.org/ticket/147#comment:4
+# Currently the tests are outdated. The time needed to repair the problematic code
+# in test_rockridge.c would be better invested in re-arranging the test suit
+# around the official libisofs API. Everybody seems busy with other things,
+# though.
+#
+# So it is best to disable test/test until its fate is decided.
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+# test? ( >=dev-util/cunit-2.1 )"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_test() {
+ emake check || die "building tests failed"
+ test/test || die "running tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS Roadmap TODO
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}