summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2006-11-05 16:24:57 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2006-11-05 16:24:57 +0000
commita90c428a34570bf8b4b8719ed8ca8a0755f9d1c7 (patch)
tree84ea1205a8a099ab996b4e58115bd5cb07f7ae16 /dev-lang
parentPass -j1 to emake; bug #134415. (diff)
downloadgentoo-2-a90c428a34570bf8b4b8719ed8ca8a0755f9d1c7.tar.gz
gentoo-2-a90c428a34570bf8b4b8719ed8ca8a0755f9d1c7.tar.bz2
gentoo-2-a90c428a34570bf8b4b8719ed8ca8a0755f9d1c7.zip
Fixing bug #150313
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog10
-rw-r--r--dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.22
-rw-r--r--dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2-r13
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild80
4 files changed, 93 insertions, 2 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 5785d401d2e1..7e4a75b62963 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gnu-smalltalk
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.16 2005/12/16 08:12:48 halcy0n Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.17 2006/11/05 16:24:57 araujo Exp $
+
+*gnu-smalltalk-2.2-r1 (05 Nov 2006)
+
+ 05 Nov 2006; Luis F. Araujo <araujo@gentoo.org>
+ +gnu-smalltalk-2.2-r1.ebuild:
+ Fixing bug #150313
16 Dec 2005; Mark Loeser <halcy0n@gentoo.org> gnu-smalltalk-2.1.12.ebuild:
Stable on x86; bug #115378
diff --git a/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2 b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2
index 637e3ca1f401..4f49abbe9b72 100644
--- a/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2
+++ b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2
@@ -1 +1,3 @@
MD5 f092bb42f6cf52b429dba8640f8bf810 smalltalk-2.2.tar.gz 4187113
+RMD160 ed517e0cf3ba4cbedfdfc7f9e59e9bf8dc59b790 smalltalk-2.2.tar.gz 4187113
+SHA256 ca134253f45bf5e3f34113c8d2a677f7733c464e2c3d75316f05e1d1437541b0 smalltalk-2.2.tar.gz 4187113
diff --git a/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2-r1 b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2-r1
new file mode 100644
index 000000000000..4f49abbe9b72
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-2.2-r1
@@ -0,0 +1,3 @@
+MD5 f092bb42f6cf52b429dba8640f8bf810 smalltalk-2.2.tar.gz 4187113
+RMD160 ed517e0cf3ba4cbedfdfc7f9e59e9bf8dc59b790 smalltalk-2.2.tar.gz 4187113
+SHA256 ca134253f45bf5e3f34113c8d2a677f7733c464e2c3d75316f05e1d1437541b0 smalltalk-2.2.tar.gz 4187113
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild
new file mode 100644
index 000000000000..87357e0705b4
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.2-r1.ebuild,v 1.1 2006/11/05 16:24:57 araujo Exp $
+
+inherit elisp-common flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://www.gnu.org/software/smalltalk/smalltalk.html"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~sparc ~x86 ~amd64"
+IUSE="tcltk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S=${WORKDIR}/smalltalk-${PV}
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ sed -i "s:\$(DESTDIR)\$(bindir)/gst \$\$srcdir/Finish.st \-VisqS \-a \"\$(DESTDIR)\" \$(MODULES): :" ${S}/Makefile.am
+ sed -i "s:\$(DESTDIR)\$(bindir)/gst \$\$srcdir/Finish.st \-VisqS \-a \"\$(DESTDIR)\" \$(MODULES): :" ${S}/Makefile.in
+ # Fix gst-{load, sunit, reload} script paths.
+ sed -i "s: @bindir@:/usr/bin:" ${S}/scripts/Reload.st ${S}/scripts/Load.st ${S}/scripts/Test.st
+}
+
+src_compile() {
+ local myconf=""
+ if use tcltk; then
+ myconf="
+ `use_with tcltk tcl=/usr/lib` \
+ `use_with tcltk tk=/usr/lib`"
+ fi
+ replace-flags '-O3' '-O2'
+ ./configure --prefix=/usr \
+ `use_with emacs emacs` \
+ `use_with readline readline` \
+ `use_with gmp gmp` \
+ `use_enable gtk gtk` \
+ ${myconf} \
+ || die
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info \
+ lispdir=${D}/usr/share/emacs/site-lisp/gnu-smalltalk install \
+ || die
+ rm -rf ${D}/usr/include/sigsegv.h \
+ ${D}/usr/include/snprintfv \
+ ${D}/usr/share/aclocal/snprintfv.m4
+ dodoc AUTHORS COPYING* ChangeLog NEWS PATCHES README THANKS TODO
+ rm -rf ${D}/var
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ einfo "We generate a GNU SmallTalk Image with the right image kernel path."
+ cd /usr/share/smalltalk/
+ /usr/bin/gst -iQ /dev/null
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}