summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-05-09 11:12:00 +0000
committerTorsten Veller <tove@gentoo.org>2008-05-09 11:12:00 +0000
commit5b41cc8ee40afc524eed4bf10204b933e943508b (patch)
tree117a56eb0018396014e720df61e60aaaa3b696cd /dev-lang/perl
parent#219203 - Version bump. Added patch from bug #198196. Apply lib64.patch for p... (diff)
downloadgentoo-2-5b41cc8ee40afc524eed4bf10204b933e943508b.tar.gz
gentoo-2-5b41cc8ee40afc524eed4bf10204b933e943508b.tar.bz2
gentoo-2-5b41cc8ee40afc524eed4bf10204b933e943508b.zip
#219203 - Fix for CVE-2008-1927
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'dev-lang/perl')
-rw-r--r--dev-lang/perl/ChangeLog10
-rw-r--r--dev-lang/perl/files/perl-5.8.8-CVE-2008-1927.patch256
-rw-r--r--dev-lang/perl/perl-5.8.8-r5.ebuild654
3 files changed, 918 insertions, 2 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 862694e139ba..203f7b2dd895 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/perl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.262 2007/11/19 09:55:56 ian Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.263 2008/05/09 11:11:59 tove Exp $
+
+*perl-5.8.8-r5 (09 May 2008)
+
+ 09 May 2008; Torsten Veller <tove@gentoo.org>
+ +files/perl-5.8.8-CVE-2008-1927.patch, +perl-5.8.8-r5.ebuild:
+ #219203 - Fix for CVE-2008-1927
*perl-5.8.8-r4 (19 Nov 2007)
diff --git a/dev-lang/perl/files/perl-5.8.8-CVE-2008-1927.patch b/dev-lang/perl/files/perl-5.8.8-CVE-2008-1927.patch
new file mode 100644
index 000000000000..470005804f57
--- /dev/null
+++ b/dev-lang/perl/files/perl-5.8.8-CVE-2008-1927.patch
@@ -0,0 +1,256 @@
+Fix a double free / segfault with utf8 regexps
+Debian #454792
+[rt.cpan.org #48156]
+[rt.cpan.org #40641]
+upstream change 29204
+
+UTF8_ALLOW_DEFAULT definition in utf8.h picked from upstream change 27688
+
+diff --git a/embed.fnc b/embed.fnc
+index edfbc0e..26524c7 100644
+--- a/embed.fnc
++++ b/embed.fnc
+@@ -1168,6 +1168,7 @@ Es |void |reguni |NN const struct RExC_state_t *state|UV uv|NN char *s|NN STRLE
+ Es |regnode*|regclass |NN struct RExC_state_t *state
+ ERs |I32 |regcurly |NN const char *
+ Es |regnode*|reg_node |NN struct RExC_state_t *state|U8 op
++Es |UV |reg_recode |const char value|NULLOK SV **encp
+ Es |regnode*|regpiece |NN struct RExC_state_t *state|NN I32 *flagp
+ Es |void |reginsert |NN struct RExC_state_t *state|U8 op|NN regnode *opnd
+ Es |void |regoptail |NN struct RExC_state_t *state|NN regnode *p|NN regnode *val
+diff --git a/embed.h b/embed.h
+index 2b38fd5..372b04f 100644
+--- a/embed.h
++++ b/embed.h
+@@ -1234,6 +1234,7 @@
+ #define regclass S_regclass
+ #define regcurly S_regcurly
+ #define reg_node S_reg_node
++#define reg_recode S_reg_recode
+ #define regpiece S_regpiece
+ #define reginsert S_reginsert
+ #define regoptail S_regoptail
+@@ -3277,6 +3278,7 @@
+ #define regclass(a) S_regclass(aTHX_ a)
+ #define regcurly(a) S_regcurly(aTHX_ a)
+ #define reg_node(a,b) S_reg_node(aTHX_ a,b)
++#define reg_recode(a,b) S_reg_recode(aTHX_ a,b)
+ #define regpiece(a,b) S_regpiece(aTHX_ a,b)
+ #define reginsert(a,b,c) S_reginsert(aTHX_ a,b,c)
+ #define regoptail(a,b,c) S_regoptail(aTHX_ a,b,c)
+diff --git a/pod/perldiag.pod b/pod/perldiag.pod
+index 9b3134c..7d95216 100644
+--- a/pod/perldiag.pod
++++ b/pod/perldiag.pod
+@@ -1900,6 +1900,15 @@ recognized by Perl or by a user-supplied handler. See L<attributes>.
+ (W printf) Perl does not understand the given format conversion. See
+ L<perlfunc/sprintf>.
+
++=item Invalid escape in the specified encoding in regex; marked by <-- HERE in m/%s/
++
++(W regexp) The numeric escape (for example C<\xHH>) of value < 256
++didn't correspond to a single character through the conversion
++from the encoding specified by the encoding pragma.
++The escape was replaced with REPLACEMENT CHARACTER (U+FFFD) instead.
++The <-- HERE shows in the regular expression about where the
++escape was discovered.
++
+ =item Invalid [] range "%s" in regex; marked by <-- HERE in m/%s/
+
+ (F) The range specified in a character class had a minimum character
+diff --git a/proto.h b/proto.h
+index 6d185dd..ef6c0cf 100644
+--- a/proto.h
++++ b/proto.h
+@@ -1748,6 +1748,7 @@ STATIC I32 S_regcurly(pTHX_ const char *)
+ __attribute__warn_unused_result__;
+
+ STATIC regnode* S_reg_node(pTHX_ struct RExC_state_t *state, U8 op);
++STATIC UV S_reg_recode(pTHX_ const char value, SV **encp);
+ STATIC regnode* S_regpiece(pTHX_ struct RExC_state_t *state, I32 *flagp);
+ STATIC void S_reginsert(pTHX_ struct RExC_state_t *state, U8 op, regnode *opnd);
+ STATIC void S_regoptail(pTHX_ struct RExC_state_t *state, regnode *p, regnode *val);
+diff --git a/regcomp.c b/regcomp.c
+index 928cf39..98d48dd 100644
+--- a/regcomp.c
++++ b/regcomp.c
+@@ -2791,6 +2791,39 @@ S_regpiece(pTHX_ RExC_state_t *pRExC_state, I32 *flagp)
+ }
+
+ /*
++ * reg_recode
++ *
++ * It returns the code point in utf8 for the value in *encp.
++ * value: a code value in the source encoding
++ * encp: a pointer to an Encode object
++ *
++ * If the result from Encode is not a single character,
++ * it returns U+FFFD (Replacement character) and sets *encp to NULL.
++ */
++STATIC UV
++S_reg_recode(pTHX_ const char value, SV **encp)
++{
++ STRLEN numlen = 1;
++ SV * const sv = sv_2mortal(newSVpvn(&value, numlen));
++ const char * const s = encp && *encp ? sv_recode_to_utf8(sv, *encp)
++ : SvPVX(sv);
++ const STRLEN newlen = SvCUR(sv);
++ UV uv = UNICODE_REPLACEMENT;
++
++ if (newlen)
++ uv = SvUTF8(sv)
++ ? utf8n_to_uvchr((U8*)s, newlen, &numlen, UTF8_ALLOW_DEFAULT)
++ : *(U8*)s;
++
++ if (!newlen || numlen != newlen) {
++ uv = UNICODE_REPLACEMENT;
++ if (encp)
++ *encp = NULL;
++ }
++ return uv;
++}
++
++/*
+ - regatom - the lowest level
+ *
+ * Optimization: gobbles an entire sequence of ordinary characters so that
+@@ -3182,6 +3215,8 @@ tryagain:
+ ender = grok_hex(p, &numlen, &flags, NULL);
+ p += numlen;
+ }
++ if (PL_encoding && ender < 0x100)
++ goto recode_encoding;
+ break;
+ case 'c':
+ p++;
+@@ -3201,6 +3236,17 @@ tryagain:
+ --p;
+ goto loopdone;
+ }
++ if (PL_encoding && ender < 0x100)
++ goto recode_encoding;
++ break;
++ recode_encoding:
++ {
++ SV* enc = PL_encoding;
++ ender = reg_recode((const char)(U8)ender, &enc);
++ if (!enc && SIZE_ONLY && ckWARN(WARN_REGEXP))
++ vWARN(p, "Invalid escape in the specified encoding");
++ RExC_utf8 = 1;
++ }
+ break;
+ case '\0':
+ if (p >= RExC_end)
+@@ -3331,32 +3377,6 @@ tryagain:
+ break;
+ }
+
+- /* If the encoding pragma is in effect recode the text of
+- * any EXACT-kind nodes. */
+- if (PL_encoding && PL_regkind[(U8)OP(ret)] == EXACT) {
+- STRLEN oldlen = STR_LEN(ret);
+- SV *sv = sv_2mortal(newSVpvn(STRING(ret), oldlen));
+-
+- if (RExC_utf8)
+- SvUTF8_on(sv);
+- if (sv_utf8_downgrade(sv, TRUE)) {
+- const char * const s = sv_recode_to_utf8(sv, PL_encoding);
+- const STRLEN newlen = SvCUR(sv);
+-
+- if (SvUTF8(sv))
+- RExC_utf8 = 1;
+- if (!SIZE_ONLY) {
+- DEBUG_r(PerlIO_printf(Perl_debug_log, "recode %*s to %*s\n",
+- (int)oldlen, STRING(ret),
+- (int)newlen, s));
+- Copy(s, STRING(ret), newlen, char);
+- STR_LEN(ret) += newlen - oldlen;
+- RExC_emit += STR_SZ(newlen) - STR_SZ(oldlen);
+- } else
+- RExC_size += STR_SZ(newlen) - STR_SZ(oldlen);
+- }
+- }
+-
+ return(ret);
+ }
+
+@@ -3734,6 +3754,8 @@ S_regclass(pTHX_ RExC_state_t *pRExC_state)
+ value = grok_hex(RExC_parse, &numlen, &flags, NULL);
+ RExC_parse += numlen;
+ }
++ if (PL_encoding && value < 0x100)
++ goto recode_encoding;
+ break;
+ case 'c':
+ value = UCHARAT(RExC_parse++);
+@@ -3741,13 +3763,24 @@ S_regclass(pTHX_ RExC_state_t *pRExC_state)
+ break;
+ case '0': case '1': case '2': case '3': case '4':
+ case '5': case '6': case '7': case '8': case '9':
+- {
+- I32 flags = 0;
+- numlen = 3;
+- value = grok_oct(--RExC_parse, &numlen, &flags, NULL);
+- RExC_parse += numlen;
+- break;
+- }
++ {
++ I32 flags = 0;
++ numlen = 3;
++ value = grok_oct(--RExC_parse, &numlen, &flags, NULL);
++ RExC_parse += numlen;
++ if (PL_encoding && value < 0x100)
++ goto recode_encoding;
++ break;
++ }
++ recode_encoding:
++ {
++ SV* enc = PL_encoding;
++ value = reg_recode((const char)(U8)value, &enc);
++ if (!enc && SIZE_ONLY && ckWARN(WARN_REGEXP))
++ vWARN(RExC_parse,
++ "Invalid escape in the specified encoding");
++ break;
++ }
+ default:
+ if (!SIZE_ONLY && isALPHA(value) && ckWARN(WARN_REGEXP))
+ vWARN2(RExC_parse,
+diff --git a/t/uni/tr_utf8.t b/t/uni/tr_utf8.t
+index 606a84a..354156a 100755
+--- a/t/uni/tr_utf8.t
++++ b/t/uni/tr_utf8.t
+@@ -31,7 +31,7 @@ BEGIN {
+ }
+
+ use strict;
+-use Test::More tests => 7;
++use Test::More tests => 8;
+
+ use encoding 'utf8';
+
+@@ -67,4 +67,12 @@ is($str, $hiragana, "s/// # hiragana -> katakana");
+ $line =~ tr/bcdeghijklmnprstvwxyz$02578/בצדעגהיײקלמנפּרסטװשכיזשױתײחא/;
+ is($line, "aבצדעfגהיײקלמנoפqּרסuטװשכיזש1ױ34ת6ײח9", "[perl #16843]");
+ }
++
++{
++ # [perl #40641]
++ my $str = qq/Gebääääääääääääääääääääude/;
++ my $reg = qr/Gebääääääääääääääääääääude/;
++ ok($str =~ /$reg/, "[perl #40641]");
++}
++
+ __END__
+diff --git a/utf8.h b/utf8.h
+index 6d63897..3800866 100644
+--- a/utf8.h
++++ b/utf8.h
+@@ -198,6 +198,8 @@ encoded character.
+ UTF8_ALLOW_SURROGATE|UTF8_ALLOW_FFFF)
+ #define UTF8_ALLOW_ANY 0x00FF
+ #define UTF8_CHECK_ONLY 0x0200
++#define UTF8_ALLOW_DEFAULT (ckWARN(WARN_UTF8) ? 0 : \
++ UTF8_ALLOW_ANYUV)
+
+ #define UNICODE_SURROGATE_FIRST 0xD800
+ #define UNICODE_SURROGATE_LAST 0xDFFF
diff --git a/dev-lang/perl/perl-5.8.8-r5.ebuild b/dev-lang/perl/perl-5.8.8-r5.ebuild
new file mode 100644
index 000000000000..7d022308a201
--- /dev/null
+++ b/dev-lang/perl/perl-5.8.8-r5.ebuild
@@ -0,0 +1,654 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r5.ebuild,v 1.1 2008/05/09 11:11:59 tove Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+# The slot of this binary compat version of libperl.so
+PERLSLOT="1"
+
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
+MY_PV="${PV%_rc*}"
+DESCRIPTION="Larry Wall's Practical Extraction and Report Language"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://cpan/src/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.perl.org/"
+LIBPERL="libperl$(get_libname ${PERLSLOT}.${SHORT_PV})"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb debug doc gdbm ithreads perlsuid build elibc_FreeBSD"
+PERL_OLDVERSEN="5.8.0 5.8.2 5.8.4 5.8.5 5.8.6 5.8.7"
+
+DEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
+ >=sys-devel/libperl-${PV}-r1
+ elibc_FreeBSD? ( sys-freebsd/freebsd-mk-defs )
+ <sys-devel/libperl-5.9
+ !<perl-core/File-Spec-0.87
+ !<perl-core/Test-Simple-0.47-r1"
+
+RDEPEND="~sys-devel/libperl-${PV}
+ berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
+ build? (
+ !perl-core/Test-Harness
+ !perl-core/PodParser
+ !dev-perl/Locale-gettext
+ )"
+
+PDEPEND=">=app-admin/perl-cleaner-1.03
+ !build? (
+ >=perl-core/PodParser-1.32
+ >=perl-core/Test-Harness-2.56
+ )"
+
+pkg_setup() {
+ # I think this should rather be displayed if you *have* 'ithreads'
+ # in USE if it could break things ...
+ if use ithreads
+ then
+ ewarn "PLEASE NOTE: You are compiling ${MY_P} with"
+ ewarn "interpreter-level threading enabled."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ epause 5
+ fi
+
+ if [[ ! -f "${ROOT}/usr/$(get_libdir)/${LIBPERL}" ]]
+ then
+ # Make sure we have libperl installed ...
+ eerror "Cannot find ${ROOT}/usr/$(get_libdir)/${LIBPERL}! Make sure that you"
+ eerror "have sys-libs/libperl installed properly ..."
+ die "Cannot find ${ROOT}/usr/$(get_libdir)/${LIBPERL}!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Get -lpthread linked before -lc. This is needed
+ # when using glibc >= 2.3, or else runtime signal
+ # handling breaks. Fixes bug #14380.
+ # <rac@gentoo.org> (14 Feb 2003)
+ # reinstated to try to avoid sdl segfaults 03.10.02
+ cd "${S}"; epatch "${FILESDIR}"/${PN}-prelink-lpthread.patch
+
+ # Patch perldoc to not abort when it attempts to search
+ # nonexistent directories; fixes bug #16589.
+ # <rac@gentoo.org> (28 Feb 2003)
+
+ cd "${S}"; epatch "${FILESDIR}"/${PN}-perldoc-emptydirs.patch
+
+ # this lays the groundwork for solving the issue of what happens
+ # when people (or ebuilds) install different versiosn of modules
+ # that are in the core, by rearranging the @INC directory to look
+ # site -> vendor -> core.
+ cd "${S}"; epatch "${FILESDIR}"/${P}-reorder-INC.patch
+
+ # some well-intentioned stuff in http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&selm=Pine.SOL.4.10.10205231231200.5399-100000%40maxwell.phys.lafayette.edu
+ # attempts to avoid bringing cccdlflags to bear on static
+ # extensions (like DynaLoader). i believe this is
+ # counterproductive on a Gentoo system which has both a shared
+ # and static libperl, so effectively revert this here.
+ cd "${S}"; epatch "${FILESDIR}"/${PN}-picdl.patch
+
+ # Configure makes an unwarranted assumption that /bin/ksh is a
+ # good shell. This patch makes it revert to using /bin/sh unless
+ # /bin/ksh really is executable. Should fix bug 42665.
+ # rac 2004.06.09
+ cd "${S}"; epatch "${FILESDIR}"/${PN}-noksh.patch
+
+ # makedepend.SH contains a syntax error which is ignored by bash but causes
+ # dash to abort
+ epatch "${FILESDIR}"/${P}-makedepend-syntax.patch
+
+ # We do not want the build root in the linked perl module's RUNPATH, so
+ # strip paths containing PORTAGE_TMPDIR if its set. This is for the
+ # MakeMaker module, bug #105054.
+ epatch "${FILESDIR}"/${PN}-5.8.7-MakeMaker-RUNPATH.patch
+
+ # Starting and hopefully ending with 5.8.7 we observe stack
+ # corruption with the regexp handling in perls DynaLoader code
+ # with ssp enabled. This become fatal during compile time so we
+ # temporally disable ssp on two regexp files till upstream has a
+ # chance to work it out. Bug #97452
+ [[ -n $(test-flags -fno-stack-protector) ]] && \
+ epatch "${FILESDIR}"/${PN}-regexp-nossp.patch
+
+ # On PA7200, uname -a contains a single quote and we need to
+ # filter it otherwise configure fails. See #125535.
+ epatch "${FILESDIR}"/perl-hppa-pa7200-configure.patch
+
+ #[[ ${get_libdir} == lib64 ]] && cd ${S} && epatch ${FILESDIR}/${P}-lib64.patch
+ use amd64 || use ppc64 && cd "${S}" && epatch "${FILESDIR}"/${P}-lib64.patch
+
+ [[ ${CHOST} == *-dragonfly* ]] && cd "${S}" && epatch "${FILESDIR}"/${P}-dragonfly-clean.patch
+ [[ ${CHOST} == *-freebsd* ]] && cd "${S}" && epatch "${FILESDIR}"/${P}-fbsdhints.patch
+ cd "${S}"; epatch "${FILESDIR}"/${P}-USE_MM_LD_RUN_PATH.patch
+ cd "${S}"; epatch "${FILESDIR}"/${P}-links.patch
+ # c++ patch - should address swig related items
+ cd "${S}"; epatch "${FILESDIR}"/${P}-cplusplus.patch
+
+ epatch "${FILESDIR}"/${P}-gcc42-command-line.patch
+
+ # Newer linux-headers don't include asm/page.h. Fix this.
+ # Patch from bug 168312, thanks Peter!
+ has_version '>sys-kernel/linux-headers-2.6.20' && epatch "${FILESDIR}"/${P}-asm-page-h-compile-failure.patch
+
+ # perlcc fix patch - bug #181229
+ epatch "${FILESDIR}"/${P}-perlcc.patch
+
+ # patch to fix bug #198196
+ # UTF/Regular expressions boundary error (CVE-2007-5116)
+ epatch "${FILESDIR}"/${P}-utf8-boundary.patch
+
+ # patch to fix bug #219203
+ epatch "${FILESDIR}"/${P}-CVE-2008-1927.patch
+}
+
+myconf() {
+ # the myconf array is declared in src_configure
+ myconf=( "${myconf[@]}" "$@" )
+}
+
+src_configure() {
+ declare -a myconf
+
+ # some arches and -O do not mix :)
+ use arm && replace-flags -O? -O1
+ use ppc && replace-flags -O? -O1
+ use ia64 && replace-flags -O? -O1
+ # Perl has problems compiling with -Os in your flags with glibc
+ use elibc_uclibc || replace-flags "-Os" "-O2"
+ ( gcc-specs-ssp && use ia64 ) && append-flags -fno-stack-protector
+ # This flag makes compiling crash in interesting ways
+ filter-flags -malign-double
+ # Fixes bug #97645
+ use ppc && filter-flags -mpowerpc-gpopt
+ # Fixes bug #143895 on gcc-4.1.1
+ filter-flags "-fsched2-use-superblocks"
+
+ export LC_ALL="C"
+
+ case ${CHOST} in
+ *-freebsd*) osname="freebsd" ;;
+ *-dragonfly*) osname="dragonfly" ;;
+ *-netbsd*) osname="netbsd" ;;
+ *-openbsd*) osname="openbsd" ;;
+ *-darwin*) osname="darwin" ;;
+
+ *) osname="linux" ;;
+ esac
+
+ if use ithreads
+ then
+ einfo "using ithreads"
+ mythreading="-multi"
+ myconf -Dusethreads
+ myarch=${CHOST}
+ myarch="${myarch%%-*}-${osname}-thread"
+ else
+ myarch=${CHOST}
+ myarch="${myarch%%-*}-${osname}"
+ fi
+
+ local inclist=$(for v in $PERL_OLDVERSEN; do echo -n "$v $v/$myarch$mythreading "; done)
+
+ # allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1
+
+ myndbm='U'
+ mygdbm='U'
+ mydb='U'
+
+ if use gdbm
+ then
+ mygdbm='D'
+ myndbm='D'
+ fi
+ if use berkdb
+ then
+ mydb='D'
+ has_version '=sys-libs/db-1*' && myndbm='D'
+ fi
+
+ myconf "-${myndbm}i_ndbm" "-${mygdbm}i_gdbm" "-${mydb}i_db"
+
+ if use mips
+ then
+ # this is needed because gcc 3.3-compiled kernels will hang
+ # the machine trying to run this test - check with `Kumba
+ # <rac@gentoo.org> 2003.06.26
+ myconf -Dd_u32align
+ fi
+
+ if use perlsuid
+ then
+ myconf -Dd_dosuid
+ ewarn "You have enabled Perl's suid compile. Please"
+ ewarn "read http://perldoc.com/perl5.8.2/INSTALL.html#suidperl"
+ epause 3
+ fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ myconf -DDEBUGGING
+ fi
+
+ if use sparc
+ then
+ myconf -Ud_longdbl
+ fi
+
+ if use alpha && "$(tc-getCC)" == "ccc"
+ then
+ ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
+ myconf -Ui_db -Ui_ndbm
+ fi
+
+ [[ -n "${ABI}" ]] && myconf "-Dusrinc=$(get_ml_incdir)"
+
+ [[ ${ELIBC} == "FreeBSD" ]] && myconf "-Dlibc=/usr/$(get_libdir)/libc.a"
+
+ if [[ $(get_libdir) != "lib" ]] ; then
+ # We need to use " and not ', as the written config.sh use ' ...
+ myconf "-Dlibpth=/usr/local/$(get_libdir) /$(get_libdir) /usr/$(get_libdir)"
+ fi
+
+ sh Configure -des \
+ -Darchname="${myarch}" \
+ -Dcccdlflags='-fPIC' \
+ -Dccdlflags='-rdynamic' \
+ -Dcc="$(tc-getCC)" \
+ -Dprefix='/usr' \
+ -Dvendorprefix='/usr' \
+ -Dsiteprefix='/usr' \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Dd_semctl_semun \
+ -Dscriptdir=/usr/bin \
+ -Dman1dir=/usr/share/man/man1 \
+ -Dman3dir=/usr/share/man/man3 \
+ -Dinstallman1dir=/usr/share/man/man1 \
+ -Dinstallman3dir=/usr/share/man/man3 \
+ -Dman1ext='1' \
+ -Dman3ext='3pm' \
+ -Dinc_version_list="$inclist" \
+ -Dcf_by='Gentoo' \
+ -Ud_csh \
+ -Dusenm \
+ "${myconf[@]}" || die "Unable to configure"
+}
+
+src_compile() {
+
+ # would like to bracket this with a test for the existence of a
+ # dotfile, but can't clean it automatically now.
+
+ src_configure
+
+ emake -j1 || die "Unable to make"
+}
+
+src_test() {
+ use elibc_uclibc && export MAKEOPTS="${MAKEOPTS} -j1"
+ emake -i test CCDLFLAGS= || die "test failed"
+}
+
+src_install() {
+
+ export LC_ALL="C"
+
+ # Need to do this, else apps do not link to dynamic version of
+ # the library ...
+ local coredir="/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading}/CORE"
+ dodir ${coredir}
+ dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/${LIBPERL}
+ dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/libperl$(get_libname ${PERLSLOT})
+ dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/libperl$(get_libname)
+
+ # Fix for "stupid" modules and programs
+ dodir /usr/$(get_libdir)/perl5/site_perl/${MY_PV}/${myarch}${mythreading}
+
+ local installtarget=install
+ if use build ; then
+ installtarget=install.perl
+ fi
+ make DESTDIR="${D}" ${installtarget} || die "Unable to make ${installtarget}"
+
+ rm "${D}"/usr/bin/perl
+ ln -s perl${MY_PV} "${D}"/usr/bin/perl
+
+ cp -f utils/h2ph utils/h2ph_patched
+ epatch "${FILESDIR}"/${PN}-h2ph-ansi-header.patch
+
+ LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
+ -a -d "${D}"/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading} <<EOF
+asm/termios.h
+syscall.h
+syslimits.h
+syslog.h
+sys/ioctl.h
+sys/socket.h
+sys/time.h
+wait.h
+EOF
+
+ # This is to fix a missing c flag for backwards compat
+ for i in `find "${D}"/usr/$(get_libdir)/perl5 -iname "Config.pm"`;do
+ sed -e "s:ccflags=':ccflags='-DPERL5 :" \
+ -e "s:cppflags=':cppflags='-DPERL5 :" \
+ ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ # A poor fix for the miniperl issues
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/$(get_libdir)/perl5/${MY_PV}/ExtUtils/xsubpp
+ fperms 0444 /usr/$(get_libdir)/perl5/${MY_PV}/ExtUtils/xsubpp
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
+ fperms 0755 /usr/bin/xsubpp
+
+ # This removes ${D} from Config.pm and .packlist
+ for i in `find "${D}" -iname "Config.pm"` `find "${D}" -iname ".packlist"`;do
+ einfo "Removing ${D} from ${i}..."
+ sed -e "s:${D}::" ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ # Note: find out from psm why we would need/want this.
+ # ( use berkdb && has_version '=sys-libs/db-1*' ) ||
+ # find ${D} -name "*NDBM*" | xargs rm -f
+
+ dodoc Changes* Artistic Copying README Todo* AUTHORS
+
+ if use doc
+ then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${D}/usr/share/doc/${PF}/html" \
+ --libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
+ fi
+ cd `find "${D}" -name Path.pm|sed -e 's/Path.pm//'`
+ # CAN patch in bug 79685
+ epatch "${FILESDIR}"/${P}-CAN-2005-0448-rmtree.patch
+
+ # Remove those items we PDPEND on
+ rm -f "${D}"/usr/bin/pod2usage
+ rm -f "${D}"/usr/bin/podchecker
+ rm -f "${D}"/usr/bin/podselect
+ rm -f "${D}"/usr/bin/prove
+ rm -f "${D}"/usr/share/man/man1/pod2usage*
+ rm -f "${D}"/usr/share/man/man1/podchecker*
+ rm -f "${D}"/usr/share/man/man1/podselect*
+ rm -f "${D}"/usr/share/man/man1/prove*
+ if use build ; then
+ src_remove_extra_files
+ fi
+
+}
+
+src_remove_extra_files()
+{
+ local prefix="./usr" # ./ is important
+ local bindir="${prefix}/bin"
+ local perlroot="${prefix}/$(get_libdir)/perl5" # perl installs per-arch dirs
+ local prV="${perlroot}/${MY_PV}"
+ # myarch and mythreading are defined inside src_configure()
+ local prVA="${prV}/${myarch}${mythreading}"
+
+ # I made this list from the Mandr*, Debian and ex-Connectiva perl-base list
+ # Then, I added several files to get GNU autotools running
+ # FIXME: should this be in a separated file to be sourced?
+ local MINIMAL_PERL_INSTALL="
+ ${bindir}/h2ph
+ ${bindir}/perl
+ ${bindir}/perl${MY_PV}
+ ${bindir}/pod2man
+ ${prV}/attributes.pm
+ ${prV}/AutoLoader.pm
+ ${prV}/autouse.pm
+ ${prV}/base.pm
+ ${prV}/bigint.pm
+ ${prV}/bignum.pm
+ ${prV}/bigrat.pm
+ ${prV}/blib.pm
+ ${prV}/bytes_heavy.pl
+ ${prV}/bytes.pm
+ ${prV}/Carp/Heavy.pm
+ ${prV}/Carp.pm
+ ${prV}/charnames.pm
+ ${prV}/Class/Struct.pm
+ ${prV}/constant.pm
+ ${prV}/diagnostics.pm
+ ${prV}/DirHandle.pm
+ ${prV}/Exporter/Heavy.pm
+ ${prV}/Exporter.pm
+ ${prV}/ExtUtils/Command.pm
+ ${prV}/ExtUtils/Constant.pm
+ ${prV}/ExtUtils/Embed.pm
+ ${prV}/ExtUtils/Installed.pm
+ ${prV}/ExtUtils/Install.pm
+ ${prV}/ExtUtils/Liblist.pm
+ ${prV}/ExtUtils/MakeMaker.pm
+ ${prV}/ExtUtils/Manifest.pm
+ ${prV}/ExtUtils/Mkbootstrap.pm
+ ${prV}/ExtUtils/Mksymlists.pm
+ ${prV}/ExtUtils/MM_Any.pm
+ ${prV}/ExtUtils/MM_MacOS.pm
+ ${prV}/ExtUtils/MM.pm
+ ${prV}/ExtUtils/MM_Unix.pm
+ ${prV}/ExtUtils/MY.pm
+ ${prV}/ExtUtils/Packlist.pm
+ ${prV}/ExtUtils/testlib.pm
+ ${prV}/ExtUtils/Miniperl.pm
+ ${prV}/ExtUtils/Command/MM.pm
+ ${prV}/ExtUtils/Constant/Base.pm
+ ${prV}/ExtUtils/Constant/Utils.pm
+ ${prV}/ExtUtils/Constant/XS.pm
+ ${prV}/ExtUtils/Liblist/Kid.pm
+ ${prV}/ExtUtils/MakeMaker/bytes.pm
+ ${prV}/ExtUtils/MakeMaker/vmsish.pm
+ ${prV}/fields.pm
+ ${prV}/File/Basename.pm
+ ${prV}/File/Compare.pm
+ ${prV}/File/Copy.pm
+ ${prV}/File/Find.pm
+ ${prV}/FileHandle.pm
+ ${prV}/File/Path.pm
+ ${prV}/File/Spec.pm
+ ${prV}/File/Spec/Unix.pm
+ ${prV}/File/stat.pm
+ ${prV}/filetest.pm
+ ${prVA}/attrs.pm
+ ${prVA}/auto/attrs
+ ${prVA}/auto/Cwd/Cwd$(get_libname)
+ ${prVA}/auto/Data/Dumper/Dumper$(get_libname)
+ ${prVA}/auto/DynaLoader/dl_findfile.al
+ ${prVA}/auto/Fcntl/Fcntl$(get_libname)
+ ${prVA}/auto/File/Glob/Glob$(get_libname)
+ ${prVA}/auto/IO/IO$(get_libname)
+ ${prVA}/auto/POSIX/autosplit.ix
+ ${prVA}/auto/POSIX/fstat.al
+ ${prVA}/auto/POSIX/load_imports.al
+ ${prVA}/auto/POSIX/POSIX.bs
+ ${prVA}/auto/POSIX/POSIX$(get_libname)
+ ${prVA}/auto/POSIX/assert.al
+ ${prVA}/auto/POSIX/stat.al
+ ${prVA}/auto/POSIX/tmpfile.al
+ ${prVA}/auto/re/re$(get_libname)
+ ${prVA}/auto/Socket/Socket$(get_libname)
+ ${prVA}/auto/Storable/autosplit.ix
+ ${prVA}/auto/Storable/_retrieve.al
+ ${prVA}/auto/Storable/retrieve.al
+ ${prVA}/auto/Storable/Storable$(get_libname)
+ ${prVA}/auto/Storable/_store.al
+ ${prVA}/auto/Storable/store.al
+ ${prVA}/B/Deparse.pm
+ ${prVA}/B.pm
+ ${prVA}/Config.pm
+ ${prVA}/Config_heavy.pl
+ ${prVA}/CORE/libperl$(get_libname)
+ ${prVA}/Cwd.pm
+ ${prVA}/Data/Dumper.pm
+ ${prVA}/DynaLoader.pm
+ ${prVA}/encoding.pm
+ ${prVA}/Errno.pm
+ ${prVA}/Fcntl.pm
+ ${prVA}/File/Glob.pm
+ ${prVA}/_h2ph_pre.ph
+ ${prVA}/IO/File.pm
+ ${prVA}/IO/Handle.pm
+ ${prVA}/IO/Pipe.pm
+ ${prVA}/IO.pm
+ ${prVA}/IO/Seekable.pm
+ ${prVA}/IO/Select.pm
+ ${prVA}/IO/Socket.pm
+ ${prVA}/lib.pm
+ ${prVA}/NDBM_File.pm
+ ${prVA}/ops.pm
+ ${prVA}/POSIX.pm
+ ${prVA}/re.pm
+ ${prVA}/Socket.pm
+ ${prVA}/Storable.pm
+ ${prVA}/threads
+ ${prVA}/threads.pm
+ ${prVA}/XSLoader.pm
+ ${prV}/Getopt/Long.pm
+ ${prV}/Getopt/Std.pm
+ ${prV}/if.pm
+ ${prV}/integer.pm
+ ${prV}/IO/Socket/INET.pm
+ ${prV}/IO/Socket/UNIX.pm
+ ${prV}/IPC/Open2.pm
+ ${prV}/IPC/Open3.pm
+ ${prV}/less.pm
+ ${prV}/List/Util.pm
+ ${prV}/locale.pm
+ ${prV}/open.pm
+ ${prV}/overload.pm
+ ${prV}/Pod/InputObjects.pm
+ ${prV}/Pod/Man.pm
+ ${prV}/Pod/ParseLink.pm
+ ${prV}/Pod/Parser.pm
+ ${prV}/Pod/Select.pm
+ ${prV}/Pod/Text.pm
+ ${prV}/Pod/Usage.pm
+ ${prV}/PerlIO.pm
+ ${prV}/Scalar/Util.pm
+ ${prV}/SelectSaver.pm
+ ${prV}/sigtrap.pm
+ ${prV}/sort.pm
+ ${prV}/stat.pl
+ ${prV}/strict.pm
+ ${prV}/subs.pm
+ ${prV}/Symbol.pm
+ ${prV}/Text/ParseWords.pm
+ ${prV}/Text/Tabs.pm
+ ${prV}/Text/Wrap.pm
+ ${prV}/Time/Local.pm
+ ${prV}/unicore/Canonical.pl
+ ${prV}/unicore/Exact.pl
+ ${prV}/unicore/lib/gc_sc/Digit.pl
+ ${prV}/unicore/lib/gc_sc/Word.pl
+ ${prV}/unicore/PVA.pl
+ ${prV}/unicore/To/Fold.pl
+ ${prV}/unicore/To/Lower.pl
+ ${prV}/unicore/To/Upper.pl
+ ${prV}/utf8_heavy.pl
+ ${prV}/utf8.pm
+ ${prV}/vars.pm
+ ${prV}/vmsish.pm
+ ${prV}/warnings
+ ${prV}/warnings.pm
+ ${prV}/warnings/register.pm"
+
+ if use perlsuid ; then
+ MINIMAL_PERL_INSTALL="${MINIMAL_PERL_INSTALL}
+ ${bindir}/suidperl
+ ${bindir}/sperl${MY_PV}"
+ fi
+
+ pushd "${D}" > /dev/null
+ # Remove cruft
+ einfo "Removing files that are not in the minimal install"
+ echo "${MINIMAL_PERL_INSTALL}"
+ for f in $(find . -type f); do
+ has ${f} ${MINIMAL_PERL_INSTALL} || rm -f ${f}
+ done
+ # Remove empty directories
+ find . -depth -type d | xargs -r rmdir &> /dev/null
+ popd > /dev/null
+}
+
+pkg_postinst() {
+ INC=$(perl -e 'for $line (@INC) { next if $line eq "."; next if $line =~ m/'${MY_PV}'|etc|local|perl$/; print "$line\n" }')
+ if [[ "${ROOT}" = "/" ]]
+ then
+ ebegin "Removing old .ph files"
+ for DIR in $INC; do
+ if [[ -d "${ROOT}"/$DIR ]]; then
+ for file in $(find "${ROOT}"/$DIR -name "*.ph" -type f); do
+ rm "${ROOT}"/$file
+ einfo "<< $file"
+ done
+ fi
+ done
+ # Silently remove the now empty dirs
+ for DIR in $INC; do
+ if [[ -d "${ROOT}"/$DIR ]]; then
+ find "${ROOT}"/$DIR -depth -type d | xargs -r rmdir &> /dev/null
+ fi
+ done
+ ebegin "Generating ConfigLocal.pm (ignore any error)"
+ enc2xs -C
+ ebegin "Converting C header files to the corresponding Perl format"
+ cd /usr/include;
+ h2ph *
+ h2ph -r sys/* arpa/* netinet/* bits/* security/* asm/* gnu/* linux/* gentoo*
+ cd /usr/include/linux
+ h2ph *
+ fi
+
+# This has been moved into a function because rumor has it that a future release
+# of portage will allow us to check what version was just removed - which means
+# we will be able to invoke this only as needed :)
+ # Tried doing this via -z, but $INC is too big...
+ if [[ "${INC}x" != "x" ]]; then
+ cleaner_msg
+ epause 5
+ fi
+}
+
+cleaner_msg() {
+ eerror "You have had multiple versions of perl. It is recommended"
+ eerror "that you run perl-cleaner now. perl-cleaner will"
+ eerror "assist with this transition. This script is capable"
+ eerror "of cleaning out old .ph files, rebuilding modules for "
+ eerror "your new version of perl, as well as re-emerging"
+ eerror "applications that compiled against your old libperl$(get_libname)"
+ eerror
+ eerror "PLEASE DO NOT INTERRUPT THE RUNNING OF THIS SCRIPT."
+ eerror "Part of the rebuilding of applications compiled against "
+ eerror "your old libperl involves temporarily unmerging"
+ eerror "them - interruptions could leave you with unmerged"
+ eerror "packages before they can be remerged."
+ eerror ""
+ eerror "If you have run perl-cleaner and a package still gives"
+ eerror "you trouble, and re-emerging it fails to correct"
+ eerror "the problem, please check http://bugs.gentoo.org/"
+ eerror "for more information or to report a bug."
+ eerror ""
+ eerror ""
+
+}