summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-12-29 18:21:31 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-12-29 18:21:31 +0000
commit2db6be292726c6b1bafd7b304fd18acdca3237b4 (patch)
treea1d3845af8be1484a5d8271f8466655ed76bb92f /dev-lang/erlang
parentia64/sparc stable wrt #290343 (diff)
downloadgentoo-2-2db6be292726c6b1bafd7b304fd18acdca3237b4.tar.gz
gentoo-2-2db6be292726c6b1bafd7b304fd18acdca3237b4.tar.bz2
gentoo-2-2db6be292726c6b1bafd7b304fd18acdca3237b4.zip
clean up
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog8
-rw-r--r--dev-lang/erlang/erlang-12.2.5-r1.ebuild156
-rw-r--r--dev-lang/erlang/erlang-13.2.1.ebuild167
-rw-r--r--dev-lang/erlang/files/erlang-12.2.5-amd64_segfault.patch139
-rw-r--r--dev-lang/erlang/files/erlang-12.2.5-remove_execstack.patch100
-rw-r--r--dev-lang/erlang/files/erlang-13.1-LDFLAGS.patch99
6 files changed, 7 insertions, 662 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 32c971b78827..0bf46d6225ab 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.177 2009/12/29 17:48:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.178 2009/12/29 18:21:30 fauli Exp $
+
+ 29 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
+ -erlang-12.2.5-r1.ebuild, -files/erlang-12.2.5-amd64_segfault.patch,
+ -files/erlang-12.2.5-remove_execstack.patch,
+ -files/erlang-13.1-LDFLAGS.patch, -erlang-13.2.1.ebuild:
+ clean up
29 Dec 2009; Raúl Porcel <armin76@gentoo.org> erlang-13.2.2.ebuild:
sparc stable wrt #291742
diff --git a/dev-lang/erlang/erlang-12.2.5-r1.ebuild b/dev-lang/erlang/erlang-12.2.5-r1.ebuild
deleted file mode 100644
index 71c6cfaf2449..000000000000
--- a/dev-lang/erlang/erlang-12.2.5-r1.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.5-r1.ebuild,v 1.6 2009/03/18 18:24:59 ranger Exp $
-
-inherit autotools elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- sctp? ( net-misc/lksctp-tools )
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50${PN}-gentoo.el
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # Both patches are taken from upstream and will be included in R13
- epatch "${FILESDIR}"/${P}-amd64_segfault.patch
- epatch "${FILESDIR}"/${P}-remove_execstack.patch
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it! If you have a fix, tell us though on Bugzilla."
- ewarn
- fi
- eautoreconf
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable sctp) \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable ssl dynamic-ssl-lib) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el || die
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header, has been reported upstream, should be fixed in R12
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of Erlang's binaries,"
- elog "please open a bug on http://bugs.gentoo.org/"
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/erlang-13.2.1.ebuild b/dev-lang/erlang/erlang-13.2.1.ebuild
deleted file mode 100644
index ad58e2d414c7..000000000000
--- a/dev-lang/erlang/erlang-13.2.1.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-13.2.1.ebuild,v 1.5 2009/11/05 16:25:39 armin76 Exp $
-
-EAPI=2
-WX_GTK_VER="2.8"
-
-inherit autotools elisp-common eutils multilib versionator wxwidgets
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-ERL_VER=($(get_version_components))
-MY_PV="R$(get_major_version)B0${ERL_VER[2]}"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk wxwindows"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- wxwindows? ( x11-libs/wxGTK:2.8[opengl] )
- sctp? ( net-misc/lksctp-tools )
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
- use wxwindows && wxwidgets_pkg_setup
-}
-
-src_prepare() {
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- if ! use wxwindows; then
- sed -i 's: wx : :' lib/Makefile
- rm -rf lib/wx
- fi
-
- epatch "${FILESDIR}"/${PN}-13.1-LDFLAGS.patch # bug 263129
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it! If you have a fix, tell us though on Bugzilla."
- ewarn
- fi
- eautoreconf
-}
-
-src_configure() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable sctp) \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable ssl dynamic-ssl-lib) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- || die
-}
-
-src_compile() {
- use java || export JAVAC=false
- emake -j1 || die
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el || die
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
- use smp && dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam.smp" /usr/bin/beam.smp
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of Erlang's binaries,"
- elog "please open a bug on http://bugs.gentoo.org/"
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/files/erlang-12.2.5-amd64_segfault.patch b/dev-lang/erlang/files/erlang-12.2.5-amd64_segfault.patch
deleted file mode 100644
index 49c420261500..000000000000
--- a/dev-lang/erlang/files/erlang-12.2.5-amd64_segfault.patch
+++ /dev/null
@@ -1,139 +0,0 @@
---- otp_src_R12B-5/lib/hipe/amd64/hipe_amd64_registers.erl.~1~ 2007-11-26 19:59:44.000000000 +0100
-+++ otp_src_R12B-5/lib/hipe/amd64/hipe_amd64_registers.erl 2009-01-21 14:54:23.000000000 +0100
-@@ -268,8 +268,7 @@ tailcall_clobbered() -> % tailcall crap
- | fp_call_clobbered()].
-
- live_at_return() ->
-- [{?RAX,tagged}
-- ,{?RSP,untagged}
-+ [{?RSP,untagged}
- ,{?PROC_POINTER,untagged}
- ,{?FCALLS,untagged}
- ,{?HEAP_LIMIT,untagged}
---- otp_src_R12B-5/lib/hipe/rtl/hipe_rtl.erl.~1~ 2008-11-04 11:51:39.000000000 +0100
-+++ otp_src_R12B-5/lib/hipe/rtl/hipe_rtl.erl 2009-01-21 14:54:36.000000000 +0100
-@@ -882,15 +882,17 @@ args(I) ->
- #alub{} -> [alub_src1(I), alub_src2(I)];
- #branch{} -> [branch_src1(I), branch_src2(I)];
- #call{} ->
-+ Args = call_arglist(I) ++ hipe_rtl_arch:call_used(),
- case call_is_known(I) of
-- false -> [call_fun(I)|call_arglist(I)];
-- true -> call_arglist(I)
-+ false -> [call_fun(I) | Args];
-+ true -> Args
- end;
- #comment{} -> [];
- #enter{} ->
-+ Args = enter_arglist(I) ++ hipe_rtl_arch:tailcall_used(),
- case enter_is_known(I) of
-- false -> hipe_rtl_arch:add_ra_reg([enter_fun(I)|enter_arglist(I)]);
-- true -> hipe_rtl_arch:add_ra_reg(enter_arglist(I))
-+ false -> [enter_fun(I) | Args];
-+ true -> Args
- end;
- #fconv{} -> [fconv_src(I)];
- #fixnumop{} -> [fixnumop_src(I)];
-@@ -910,7 +912,7 @@ args(I) ->
- #move{} -> [move_src(I)];
- #multimove{} -> multimove_srclist(I);
- #phi{} -> phi_args(I);
-- #return{} -> hipe_rtl_arch:add_ra_reg(return_varlist(I));
-+ #return{} -> return_varlist(I) ++ hipe_rtl_arch:return_used();
- #store{} -> [store_base(I), store_offset(I), store_src(I)];
- #switch{} -> [switch_src(I)]
- end.
-@@ -924,7 +926,7 @@ defines(Instr) ->
- #alu{} -> [alu_dst(Instr)];
- #alub{} -> [alub_dst(Instr)];
- #branch{} -> [];
-- #call{} -> call_dstlist(Instr);
-+ #call{} -> call_dstlist(Instr) ++ hipe_rtl_arch:call_defined();
- #comment{} -> [];
- #enter{} -> [];
- #fconv{} -> [fconv_dst(Instr)];
-@@ -990,7 +992,7 @@ subst_uses(Subst, I) ->
- end;
- #comment{} ->
- I;
-- #enter{} -> %% XXX: Check why ra_reg is added in uses() but not updated here
-+ #enter{} ->
- case enter_is_known(I) of
- false ->
- I0 = enter_fun_update(I, subst1(Subst, enter_fun(I))),
---- otp_src_R12B-5/lib/hipe/rtl/hipe_rtl_arch.erl.~1~ 2008-06-10 14:47:41.000000000 +0200
-+++ otp_src_R12B-5/lib/hipe/rtl/hipe_rtl_arch.erl 2009-01-21 14:56:26.000000000 +0100
-@@ -22,9 +22,12 @@
- heap_pointer/0,
- heap_limit/0,
- fcalls/0,
-- add_ra_reg/1,
- reg_name/1,
- is_precoloured/1,
-+ call_defined/0,
-+ call_used/0,
-+ tailcall_used/0,
-+ return_used/0,
- live_at_return/0,
- endianess/0,
- load_big_2/4,
-@@ -164,22 +167,6 @@ fcalls_from_pcb() ->
- Reg = hipe_rtl:mk_new_reg(),
- {pcb_load(Reg, ?P_FCALLS), Reg, pcb_store(?P_FCALLS, Reg)}.
-
---spec(add_ra_reg/1 :: ([X]) -> [X]).
--
--add_ra_reg(Rest) ->
-- case get(hipe_target_arch) of
-- ultrasparc ->
-- [hipe_rtl:mk_reg(hipe_sparc_registers:return_address()) | Rest];
-- powerpc ->
-- Rest; % do not include LR: it's not a normal register
-- arm ->
-- [hipe_rtl:mk_reg(hipe_arm_registers:lr()) | Rest];
-- x86 ->
-- Rest;
-- amd64 ->
-- Rest
-- end.
--
- reg_name(Reg) ->
- case get(hipe_target_arch) of
- ultrasparc ->
-@@ -225,6 +212,18 @@ is_precolored_regnum(RegNum) ->
- hipe_amd64_registers:is_precoloured(RegNum)
- end.
-
-+call_defined() ->
-+ call_used().
-+
-+call_used() ->
-+ live_at_return().
-+
-+tailcall_used() ->
-+ call_used().
-+
-+return_used() ->
-+ tailcall_used().
-+
- live_at_return() ->
- case get(hipe_target_arch) of
- ultrasparc ->
---- otp_src_R12B-5/lib/hipe/x86/hipe_x86_registers.erl.~1~ 2007-11-26 19:58:49.000000000 +0100
-+++ otp_src_R12B-5/lib/hipe/x86/hipe_x86_registers.erl 2009-01-21 14:53:33.000000000 +0100
-@@ -224,14 +224,8 @@ all_x87_pseudos() ->
- {4,double}, {5,double}, {6,double}].
-
- live_at_return() ->
-- [{?EAX,tagged}
-- %% XXX: should the following (fixed) regs be included or not?
-- ,{?ESP,untagged}
-+ [{?ESP,untagged}
- ,{?PROC_POINTER,untagged}
-- %% Lets try not!
-- %% If these are included they will interfere with other
-- %% temps during regalloc, but regs FCALLS and HEAP_LIMIT
-- %% don't even exist at regalloc.
- ,{?FCALLS,untagged}
- ,{?HEAP_LIMIT,untagged}
- | ?LIST_HP_LIVE_AT_RETURN
diff --git a/dev-lang/erlang/files/erlang-12.2.5-remove_execstack.patch b/dev-lang/erlang/files/erlang-12.2.5-remove_execstack.patch
deleted file mode 100644
index d0957fb60952..000000000000
--- a/dev-lang/erlang/files/erlang-12.2.5-remove_execstack.patch
+++ /dev/null
@@ -1,100 +0,0 @@
---- otp-0125/erts/emulator/hipe/hipe_amd64_bifs.m4.~1~ 2008-10-27 20:07:08.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_amd64_bifs.m4 2009-02-01 11:36:47.000000000 +0100
-@@ -531,3 +531,7 @@ define(gc_bif_interface_2,`standard_bif_
- define(gc_nofail_primop_interface_1,`nofail_primop_interface_1($1, $2)')
-
- include(`hipe/hipe_bif_list.m4')
-+
-+`#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif'
---- otp-0125/erts/emulator/hipe/hipe_amd64_glue.S.~1~ 2008-11-07 23:44:11.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_amd64_glue.S 2009-02-01 11:36:47.000000000 +0100
-@@ -418,3 +418,7 @@ nbif_inc_stack_0:
- LOAD_ARG_REGS
- SWITCH_C_TO_ERLANG_QUICK
- NSP_RET0
-+
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
---- otp-0125/erts/emulator/hipe/hipe_arm_bifs.m4.~1~ 2008-10-27 20:07:08.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_arm_bifs.m4 2009-02-01 11:37:21.000000000 +0100
-@@ -525,3 +525,7 @@ $1:
- #endif')
-
- include(`hipe/hipe_bif_list.m4')
-+
-+`#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif'
---- otp-0125/erts/emulator/hipe/hipe_arm_glue.S.~1~ 2008-11-07 23:44:11.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_arm_glue.S 2009-02-01 11:38:25.000000000 +0100
-@@ -392,3 +392,7 @@ hipe_arm_inc_stack:
- LOAD_ARG_REGS
- # this relies on LOAD_ARG_REGS not clobbering TEMP_ARG0
- mov pc, TEMP_ARG0
-+
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
---- otp-0125/erts/emulator/hipe/hipe_ppc_bifs.m4.~1~ 2008-10-27 20:07:09.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_ppc_bifs.m4 2009-02-01 11:36:47.000000000 +0100
-@@ -544,3 +544,7 @@ ASYM($1):
- #endif')
-
- include(`hipe/hipe_bif_list.m4')
-+
-+`#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif'
---- otp-0125/erts/emulator/hipe/hipe_ppc_glue.S.~1~ 2008-11-07 23:44:12.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_ppc_glue.S 2009-02-01 11:36:47.000000000 +0100
-@@ -557,3 +557,7 @@ ASYM(hipe_ppc_inc_stack):
- LOAD NSP, P_NSP(P)
- LOAD_ARG_REGS
- blr
-+
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
---- otp-0125/erts/emulator/hipe/hipe_sparc_bifs.m4.~1~ 2008-10-27 20:07:09.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_sparc_bifs.m4 2009-02-01 11:36:47.000000000 +0100
-@@ -554,3 +554,7 @@ $1:
- #endif')
-
- include(`hipe/hipe_bif_list.m4')
-+
-+`#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif'
---- otp-0125/erts/emulator/hipe/hipe_sparc_glue.S.~1~ 2008-11-07 23:44:12.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_sparc_glue.S 2009-02-01 11:36:47.000000000 +0100
-@@ -423,3 +423,7 @@ hipe_sparc_inc_stack:
- /* this relies on LOAD_ARG_REGS not clobbering TEMP_ARG0 */
- jmp TEMP_ARG0+8
- ld [P+P_NSP], NSP /* delay slot */
-+
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
---- otp-0125/erts/emulator/hipe/hipe_x86_bifs.m4.~1~ 2008-10-27 20:07:09.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_x86_bifs.m4 2009-02-01 11:36:47.000000000 +0100
-@@ -611,3 +611,7 @@ define(gc_bif_interface_2,`standard_bif_
- define(gc_nofail_primop_interface_1,`nofail_primop_interface_1($1, $2)')
-
- include(`hipe/hipe_bif_list.m4')
-+
-+`#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif'
---- otp-0125/erts/emulator/hipe/hipe_x86_glue.S.~1~ 2008-11-07 23:44:12.000000000 +0100
-+++ otp-0125/erts/emulator/hipe/hipe_x86_glue.S 2009-02-01 11:36:47.000000000 +0100
-@@ -395,3 +395,7 @@ ASYM(nbif_inc_stack_0):
- LOAD_CALLER_SAVE
- SWITCH_C_TO_ERLANG_QUICK
- NSP_RET0
-+
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
diff --git a/dev-lang/erlang/files/erlang-13.1-LDFLAGS.patch b/dev-lang/erlang/files/erlang-13.1-LDFLAGS.patch
deleted file mode 100644
index b3e537e4650e..000000000000
--- a/dev-lang/erlang/files/erlang-13.1-LDFLAGS.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-diff -Naur otp_src_R13A~orig/erts/emulator/Makefile.in otp_src_R13A/erts/emulator/Makefile.in
---- otp_src_R13A~orig/erts/emulator/Makefile.in 2009-04-04 14:25:34.000000000 +0200
-+++ otp_src_R13A/erts/emulator/Makefile.in 2009-04-04 16:53:23.000000000 +0200
-@@ -256,6 +256,7 @@
- else
- CS_CFLAGS = $(CS_CFLAGS_)
- endif
-+CS_LDFLAGS = $(LDFLAGS)
- CS_LIBS = -L../lib/internal/$(TARGET) -lerts_internal @ERTS_INTERNAL_X_LIBS@
-
- LIBS += @TERMCAP_LIB@ -L../lib/internal/$(TARGET) @ERTS_INTERNAL_X_LIBS@
-@@ -654,8 +655,8 @@
- CS_SRC = sys/$(ERLANG_OSTYPE)/erl_child_setup.c
-
- $(BINDIR)/$(CS_EXECUTABLE): $(CS_SRC)
-- $(CS_PURIFY) $(CC) -o $(BINDIR)/$(CS_EXECUTABLE) \
-- $(CS_CFLAGS) $(COMMON_INCLUDES) $(CS_SRC) $(CS_LIBS)
-+ $(CS_PURIFY) $(CC) $(CS_LDFLAGS) -o $(BINDIR)/$(CS_EXECUTABLE) \
-+ $(CS_CFLAGS) $(COMMON_INCLUDES) $(CS_SRC) $(CS_LIBS)
-
- $(OBJDIR)/%.elib.o: beam/%.c
- $(CC) $(ELIB_FLAGS) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) $(INCLUDES) -c $< -o $@
-diff -Naur otp_src_R13A~orig/lib/asn1/c_src/Makefile.in otp_src_R13A/lib/asn1/c_src/Makefile.in
---- otp_src_R13A~orig/lib/asn1/c_src/Makefile.in 2009-04-04 14:25:15.000000000 +0200
-+++ otp_src_R13A/lib/asn1/c_src/Makefile.in 2009-04-04 17:48:14.000000000 +0200
-@@ -60,7 +60,7 @@
- DRIVER_INCLUDES = -I$(ERL_TOP)/erts/emulator/beam \
- -I$(ERL_TOP)/erts/emulator/sys/$(ERLANG_OSTYPE)
- CFLAGS = $(DRIVER_INCLUDES) $(EI_INCLUDES) @DED_CFLAGS@
--LDFLAGS = @DED_LDFLAGS@
-+LDFLAGS += @DED_LDFLAGS@
-
- LD_INCL_EI = -L$(EI_LIBDIR)
-
-diff -Naur otp_src_R13A~orig/lib/crypto/c_src/Makefile.in otp_src_R13A/lib/crypto/c_src/Makefile.in
---- otp_src_R13A~orig/lib/crypto/c_src/Makefile.in 2009-04-04 14:25:16.000000000 +0200
-+++ otp_src_R13A/lib/crypto/c_src/Makefile.in 2009-04-04 17:48:32.000000000 +0200
-@@ -33,7 +33,7 @@
- LD = @DED_LD@
- SHELL = /bin/sh
- LIBS = @LIBS@
--LDFLAGS = @DED_LDFLAGS@
-+LDFLAGS += @DED_LDFLAGS@
- CFLAGS = @DED_CFLAGS@
- ERLANG_OSTYPE = @ERLANG_OSTYPE@
- TARGET = @host@
-diff -Naur otp_src_R13A~orig/lib/erl_interface/src/Makefile.in otp_src_R13A/lib/erl_interface/src/Makefile.in
---- otp_src_R13A~orig/lib/erl_interface/src/Makefile.in 2009-04-04 14:25:16.000000000 +0200
-+++ otp_src_R13A/lib/erl_interface/src/Makefile.in 2009-04-04 16:41:46.000000000 +0200
-@@ -715,11 +715,11 @@
- else
- ifdef THR_DEFS
- $(ERL_CALL): $(ERLCALL) ../include/ei.h $(MT_EILIB)
-- $(PURIFY) $(CC) $(PROG_CFLAGS) $(THR_DEFS) -o $@ $(ERLCALL) \
-+ $(PURIFY) $(CC) $(PROG_CFLAGS) $(THR_DEFS) $(LDFLAGS) -o $@ $(ERLCALL) \
- -L$(OBJDIR) -lei $(THR_LIBS) $(LIBS)
- else
- $(ERL_CALL): $(ERLCALL) ../include/ei.h $(ST_EILIB)
-- $(PURIFY) $(CC) $(PROG_CFLAGS) -o $@ $(ERLCALL) \
-+ $(PURIFY) $(CC) $(PROG_CFLAGS) $(LDFLAGS) -o $@ $(ERLCALL) \
- -L$(OBJDIR) -lei $(LIBS)
- endif
- endif
-diff -Naur otp_src_R13A~orig/lib/megaco/src/flex/Makefile.in otp_src_R13A/lib/megaco/src/flex/Makefile.in
---- otp_src_R13A~orig/lib/megaco/src/flex/Makefile.in 2009-04-04 14:25:16.000000000 +0200
-+++ otp_src_R13A/lib/megaco/src/flex/Makefile.in 2009-04-04 17:57:24.000000000 +0200
-@@ -48,7 +48,7 @@
- CC = @CC@
- CFLAGS_MT = $(CFLAGS) -D_THREAD_SAFE -D_REENTRANT
- LD = @DED_LD@
--LDFLAGS = @DED_LDFLAGS@
-+LDFLAGS += @DED_LDFLAGS@
- LEX = @LEX@
- LEXLIB = @LEXLIB@
- PERL = @PERL@
-diff -Naur otp_src_R13A~orig/lib/runtime_tools/c_src/Makefile.in otp_src_R13A/lib/runtime_tools/c_src/Makefile.in
---- otp_src_R13A~orig/lib/runtime_tools/c_src/Makefile.in 2009-04-04 14:25:34.000000000 +0200
-+++ otp_src_R13A/lib/runtime_tools/c_src/Makefile.in 2009-04-04 16:23:59.000000000 +0200
-@@ -35,7 +35,7 @@
- LD = @DED_LD@
- SHELL = /bin/sh
- LIBS = @LIBS@
--LDFLAGS = @DED_LDFLAGS@
-+LDFLAGS += @DED_LDFLAGS@
- ERLANG_OSTYPE = @ERLANG_OSTYPE@
-
- SYSINCLUDE = -I$(ERL_TOP)/erts/emulator/beam \
-diff -Naur otp_src_R13A~orig/lib/ssl/c_src/Makefile.in otp_src_R13A/lib/ssl/c_src/Makefile.in
---- otp_src_R13A~orig/lib/ssl/c_src/Makefile.in 2009-04-04 14:25:15.000000000 +0200
-+++ otp_src_R13A/lib/ssl/c_src/Makefile.in 2009-04-04 16:33:37.000000000 +0200
-@@ -163,7 +163,7 @@
-
- # Unix
- $(BINDIR)/ssl_esock: $(OBJS)
-- $(CC) $(CC_R_OPT) $(PLAIN_CFLAGS) -o $@ $^ $(LIBS) $(SSL_LINK_LIB)
-+ $(CC) $(CC_R_OPT) $(PLAIN_CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(SSL_LINK_LIB)
-
- # Win32/Cygwin
- $(BINDIR)/ssl_esock.exe: $(OBJS)