summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-10-17 12:31:30 +0000
committerVlastimil Babka <caster@gentoo.org>2010-10-17 12:31:30 +0000
commit250fe8ff14e3d54e9231a956b36179d0fefd0e6b (patch)
treebbd67cb4e5799bd992baa53e17a8c9c078c9cc53 /dev-java
parentRemove old. (diff)
downloadgentoo-2-250fe8ff14e3d54e9231a956b36179d0fefd0e6b.tar.gz
gentoo-2-250fe8ff14e3d54e9231a956b36179d0fefd0e6b.tar.bz2
gentoo-2-250fe8ff14e3d54e9231a956b36179d0fefd0e6b.zip
Remove old.
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/groovy/ChangeLog6
-rw-r--r--dev-java/groovy/groovy-1.6.5.ebuild119
-rw-r--r--dev-java/groovy/groovy-1.6.7.ebuild119
3 files changed, 5 insertions, 239 deletions
diff --git a/dev-java/groovy/ChangeLog b/dev-java/groovy/ChangeLog
index 3e2212b35e7e..fd210fdb4690 100644
--- a/dev-java/groovy/ChangeLog
+++ b/dev-java/groovy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/groovy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/ChangeLog,v 1.43 2010/10/15 17:40:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/ChangeLog,v 1.44 2010/10/17 12:31:30 caster Exp $
+
+ 17 Oct 2010; Vlastimil Babka <caster@gentoo.org> -groovy-1.6.5.ebuild,
+ -groovy-1.6.7.ebuild:
+ Remove old.
15 Oct 2010; Brent Baude <ranger@gentoo.org> groovy-1.6.8.ebuild:
Marking groovy-1.6.8 ppc for bug 321355
diff --git a/dev-java/groovy/groovy-1.6.5.ebuild b/dev-java/groovy/groovy-1.6.5.ebuild
deleted file mode 100644
index d383d38ce80f..000000000000
--- a/dev-java/groovy/groovy-1.6.5.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/groovy-1.6.5.ebuild,v 1.3 2010/01/07 20:35:06 ranger Exp $
-
-# Groovy's build system is Ant based, but they use Maven for fetching the dependencies.
-# We just have to remove the fetch dependencies target, and then we can use Ant for this ebuild.
-
-# We currently do not build the embeddable jar (which is created using JarJar).
-# We could provide that via an USE flag.
-# We also don't use automatic build rewriting as there seems to be already some level of support
-# in the upstream build system
-
-# TODO: Install all 3 documentation packages. Currently only the Groovy GDK documentation is installed
-# as our java-pkg_dojavadoc function does not support multiple Javadoc installations.
-# There is also a bug (visible when loading groovyConsole for instance) where asm-1.5 is put on the cp,
-# this conflicts with the 2.2 version needed by Groovy.
-
-EAPI="2"
-WANT_ANT_TASKS="ant-antlr"
-JAVA_PKG_IUSE="doc source"
-
-inherit versionator java-pkg-2 java-ant-2
-
-MY_PV=${PV/_rc/-RC-}
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Groovy is a high-level dynamic language for the JVM"
-HOMEPAGE="http://groovy.codehaus.org/"
-
-SRC_URI="http://dist.groovy.codehaus.org/distributions/${PN}-src-${PV}.zip"
-LICENSE="codehaus-groovy"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="test"
-RESTRICT="test"
-
-CDEPEND="
- dev-java/asm:2.2
- dev-java/antlr:0
- >=dev-java/xstream-1.3
- >=dev-java/junit-3.8.2:0
- >=dev-java/jline-0.9.91
- >=dev-java/ant-core-1.7.0
- >=dev-java/commons-cli-1.2
- dev-java/servletapi:2.4
- >=dev-java/bsf-2.4
- java-virtuals/jmx"
-
-RDEPEND=">=virtual/jre-1.5
- !<dev-java/groovy-1.6.3
- ${CDEPEND}"
-
-DEPEND=">=virtual/jdk-1.5
- dev-java/ant-ivy:2
- doc? (
- dev-java/qdox
- )
- test? (
- dev-java/jmock
- dev-java/xmlunit
- dev-db/hsqldb
- dev-java/commons-logging
- dev-java/ant-junit
- dev-java/ant-trax
- )
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_PKG_BSFIX=""
-
-src_prepare() {
- rm -rf bootstrap
- # security directory is needed for tests, but they currently don't pass
- #rm -rf security
- mkdir -p target/lib && cd target/lib
- mkdir compile && mkdir runtime && mkdir tools
- cd compile
-
- java-pkg_jar-from commons-cli-1,ant-core,antlr,asm-2.2,xstream
- java-pkg_jar-from jline,junit,servletapi-2.4,bsf-2.3
- java-pkg_jar-from --virtual jmx
- java-pkg_jar-from --build-only ant-ivy:2
- use doc && java-pkg_jar-from --build-only qdox-1.6
-}
-
-src_compile() {
- eant -DskipTests="true" -DruntimeLibDirectory="target/lib/compile" \
- -DtoolsLibDirectory="target/lib/compile" -DskipFetch="true" -DskipEmbeddable="true"
-
- use doc && ANT_OPTS="-Duser.home=${T}" eant -Dno.grammars="true" -DruntimeLibDirectory="target/lib/compile" \
- -DtoolsLibDirectory="target/lib/compile" -DtestLibDirectory="target/lib/compile" -DskipFetch="true" doc
-}
-
-src_test() {
- cd "${S}/target/lib" && mkdir test && mkdir extras && cd compile
-
- java-pkg_jar-from --build-only ant-junit,jmock-1.0,xmlunit-1,hsqldb,commons-logging,cglib-2.1
-
- cd "${S}"
- ANT_TASKS="ant-junit ant-antlr ant-trax" ANT_OPTS="-Duser.home=${T}" eant \
- -DruntimeLibDirectory="target/lib/compile" -DtestLibDirectory="target/lib/compile" -DskipFetch="true" test
-}
-
-src_install() {
- java-pkg_newjar "target/dist/${PN}.jar"
- use doc && java-pkg_dojavadoc "target/html/groovy-jdk/"
-
- # FIXME: install those two later
- #
- #use doc && java-pkg_dojavadoc "target/html/api/"
- #use doc && java-pkg_dojavadoc "target/html/gapi/"
-
- use source && java-pkg_dosrc "src/main/groovy" "src/main/org"
- java-pkg_dolauncher "groovyc" --main org.codehaus.groovy.tools.FileSystemCompiler
- java-pkg_dolauncher "groovy" --main groovy.ui.GroovyMain
- java-pkg_dolauncher "groovysh" --main groovy.ui.InteractiveShell
- java-pkg_dolauncher "groovyConsole" --main groovy.ui.Console
-}
diff --git a/dev-java/groovy/groovy-1.6.7.ebuild b/dev-java/groovy/groovy-1.6.7.ebuild
deleted file mode 100644
index 5463814dc8cc..000000000000
--- a/dev-java/groovy/groovy-1.6.7.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/groovy-1.6.7.ebuild,v 1.2 2010/01/15 20:27:39 abcd Exp $
-
-# Groovy's build system is Ant based, but they use Maven for fetching the dependencies.
-# We just have to remove the fetch dependencies target, and then we can use Ant for this ebuild.
-
-# We currently do not build the embeddable jar (which is created using JarJar).
-# We could provide that via an USE flag.
-# We also don't use automatic build rewriting as there seems to be already some level of support
-# in the upstream build system
-
-# TODO: Install all 3 documentation packages. Currently only the Groovy GDK documentation is installed
-# as our java-pkg_dojavadoc function does not support multiple Javadoc installations.
-# There is also a bug (visible when loading groovyConsole for instance) where asm-1.5 is put on the cp,
-# this conflicts with the 2.2 version needed by Groovy.
-
-EAPI="2"
-WANT_ANT_TASKS="ant-antlr"
-JAVA_PKG_IUSE="doc source"
-
-inherit versionator java-pkg-2 java-ant-2
-
-MY_PV=${PV/_rc/-RC-}
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Groovy is a high-level dynamic language for the JVM"
-HOMEPAGE="http://groovy.codehaus.org/"
-
-SRC_URI="http://dist.groovy.codehaus.org/distributions/${PN}-src-${PV}.zip"
-LICENSE="codehaus-groovy"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="test"
-RESTRICT="test"
-
-CDEPEND="
- dev-java/asm:2.2
- dev-java/antlr:0
- >=dev-java/xstream-1.3
- >=dev-java/junit-3.8.2:0
- >=dev-java/jline-0.9.91
- >=dev-java/ant-core-1.7.0
- >=dev-java/commons-cli-1.2
- dev-java/servletapi:2.4
- >=dev-java/bsf-2.4
- java-virtuals/jmx"
-
-RDEPEND=">=virtual/jre-1.5
- !<dev-java/groovy-1.6.3
- ${CDEPEND}"
-
-DEPEND=">=virtual/jdk-1.5
- dev-java/ant-ivy:2
- doc? (
- dev-java/qdox
- )
- test? (
- dev-java/jmock
- dev-java/xmlunit
- dev-db/hsqldb
- dev-java/commons-logging
- dev-java/ant-junit
- dev-java/ant-trax
- )
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_PKG_BSFIX=""
-
-src_prepare() {
- rm -rf bootstrap
- # security directory is needed for tests, but they currently don't pass
- #rm -rf security
- mkdir -p target/lib && cd target/lib
- mkdir compile && mkdir runtime && mkdir tools
- cd compile
-
- java-pkg_jar-from commons-cli-1,ant-core,antlr,asm-2.2,xstream
- java-pkg_jar-from jline,junit,servletapi-2.4,bsf-2.3
- java-pkg_jar-from --virtual jmx
- java-pkg_jar-from --build-only ant-ivy:2
- use doc && java-pkg_jar-from --build-only qdox-1.6
-}
-
-src_compile() {
- eant -DskipTests="true" -DruntimeLibDirectory="target/lib/compile" \
- -DtoolsLibDirectory="target/lib/compile" -DskipFetch="true" -DskipEmbeddable="true"
-
- use doc && ANT_OPTS="-Duser.home=${T}" eant -Dno.grammars="true" -DruntimeLibDirectory="target/lib/compile" \
- -DtoolsLibDirectory="target/lib/compile" -DtestLibDirectory="target/lib/compile" -DskipFetch="true" doc
-}
-
-src_test() {
- cd "${S}/target/lib" && mkdir test && mkdir extras && cd compile
-
- java-pkg_jar-from --build-only ant-junit,jmock-1.0,xmlunit-1,hsqldb,commons-logging,cglib-2.1
-
- cd "${S}"
- ANT_TASKS="ant-junit ant-antlr ant-trax" ANT_OPTS="-Duser.home=${T}" eant \
- -DruntimeLibDirectory="target/lib/compile" -DtestLibDirectory="target/lib/compile" -DskipFetch="true" test
-}
-
-src_install() {
- java-pkg_newjar "target/dist/${PN}.jar"
- use doc && java-pkg_dojavadoc "target/html/groovy-jdk/"
-
- # FIXME: install those two later
- #
- #use doc && java-pkg_dojavadoc "target/html/api/"
- #use doc && java-pkg_dojavadoc "target/html/gapi/"
-
- use source && java-pkg_dosrc "src/main/groovy" "src/main/org"
- java-pkg_dolauncher "groovyc" --main org.codehaus.groovy.tools.FileSystemCompiler
- java-pkg_dolauncher "groovy" --main groovy.ui.GroovyMain
- java-pkg_dolauncher "groovysh" --main groovy.ui.InteractiveShell
- java-pkg_dolauncher "groovyConsole" --main groovy.ui.Console
-}