summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-05-01 18:55:34 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-05-01 18:55:34 +0000
commit3447ee8df58a185f756a3710a7ada21fc65e8d4f (patch)
treeb2acd62f3b0d451bb0b9cf947075d3a7e24dc11f /dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1.ebuild
parentInitial commit of stax-ex. (diff)
downloadgentoo-2-3447ee8df58a185f756a3710a7ada21fc65e8d4f.tar.gz
gentoo-2-3447ee8df58a185f756a3710a7ada21fc65e8d4f.tar.bz2
gentoo-2-3447ee8df58a185f756a3710a7ada21fc65e8d4f.zip
Initial commit of sun-httpserver-bin.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1.ebuild')
-rw-r--r--dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1.ebuild b/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1.ebuild
new file mode 100644
index 000000000000..6c3cf042a626
--- /dev/null
+++ b/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1.ebuild,v 1.1 2007/05/01 18:55:34 nelchael Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="Sun sun.net.httpserver classes"
+HOMEPAGE="http://jax-ws.dev.java.net/"
+DATE="20060817"
+MY_P="JAXWS${PV}m1_source_${DATE}.jar"
+SRC_URI="https://jax-ws.dev.java.net/jax-ws-201-m1/${MY_P}"
+
+LICENSE="CDDL"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/jaxws-si"
+
+src_unpack() {
+
+ echo "A" | java -jar "${DISTDIR}/${A}" -console > /dev/null || die "unpack failed"
+
+ unpack ./jaxws-src.zip || die "unzip failed"
+
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+
+ java-pkg_dojar lib/http.jar
+
+}