summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2006-10-19 21:39:35 +0000
committerVlastimil Babka <caster@gentoo.org>2006-10-19 21:39:35 +0000
commitf058b884a486408493bc45283f5274bd0e1ed2bb (patch)
treea6990d756f74ea35c0509e595097f556c526aed7 /dev-java/jdbc-jaybird
parentadd ~amd64, thx to Pierre Cassimans on IRC #gentoo-vdr for reporting this (diff)
downloadgentoo-2-f058b884a486408493bc45283f5274bd0e1ed2bb.tar.gz
gentoo-2-f058b884a486408493bc45283f5274bd0e1ed2bb.tar.bz2
gentoo-2-f058b884a486408493bc45283f5274bd0e1ed2bb.zip
Cleaned up dependencies, make tests actually not compile when not needed, remove jdk version autodetection and force -source 1.4 -target 1.4 everywhere, until somebody needs the 1.5 features.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'dev-java/jdbc-jaybird')
-rw-r--r--dev-java/jdbc-jaybird/ChangeLog9
-rw-r--r--dev-java/jdbc-jaybird/files/archive-xml-2.0.1.patch11
-rw-r--r--dev-java/jdbc-jaybird/files/compile-xml-2.0.1.patch92
-rw-r--r--dev-java/jdbc-jaybird/files/dist-xml-2.0.1.patch10
-rw-r--r--dev-java/jdbc-jaybird/jdbc-jaybird-2.0.1.ebuild52
-rw-r--r--dev-java/jdbc-jaybird/metadata.xml4
6 files changed, 154 insertions, 24 deletions
diff --git a/dev-java/jdbc-jaybird/ChangeLog b/dev-java/jdbc-jaybird/ChangeLog
index af22c54269e3..501fe8a8b28c 100644
--- a/dev-java/jdbc-jaybird/ChangeLog
+++ b/dev-java/jdbc-jaybird/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jdbc-jaybird
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/ChangeLog,v 1.6 2006/10/19 20:11:13 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/ChangeLog,v 1.7 2006/10/19 21:39:35 caster Exp $
+
+ 19 Oct 2006; Vlastimil Babka <caster@gentoo.org>
+ +files/archive-xml-2.0.1.patch, +files/compile-xml-2.0.1.patch,
+ +files/dist-xml-2.0.1.patch, metadata.xml, jdbc-jaybird-2.0.1.ebuild:
+ Cleaned up dependencies, make tests actually not compile when not needed,
+ remove jdk version autodetection and force -source 1.4 -target 1.4
+ everywhere, until somebody needs the 1.5 features.
19 Oct 2006; William L. Thomson Jr. <wltjr@gentoo.org>
jdbc-jaybird-2.0.1.ebuild, jdbc-jaybird-2.1.0.ebuild:
diff --git a/dev-java/jdbc-jaybird/files/archive-xml-2.0.1.patch b/dev-java/jdbc-jaybird/files/archive-xml-2.0.1.patch
new file mode 100644
index 000000000000..10a3055ca14a
--- /dev/null
+++ b/dev-java/jdbc-jaybird/files/archive-xml-2.0.1.patch
@@ -0,0 +1,11 @@
+--- build/archive.xml 2005-06-25 18:26:26.000000000 +0200
++++ build/archive.xml 2006-10-19 16:39:56.000000000 +0200
+@@ -57,7 +57,7 @@
+
+ </target>
+
+- <target name="jar-test" depends="compile">
++ <target name="jar-test" depends="compile" if="tests">
+
+ <mkdir dir="${build.lib}"/>
+ <jar jarfile="${build.lib}/${archive.name.test}" manifest="${build.etc}/default.mf">
diff --git a/dev-java/jdbc-jaybird/files/compile-xml-2.0.1.patch b/dev-java/jdbc-jaybird/files/compile-xml-2.0.1.patch
new file mode 100644
index 000000000000..2edd340e7502
--- /dev/null
+++ b/dev-java/jdbc-jaybird/files/compile-xml-2.0.1.patch
@@ -0,0 +1,92 @@
+--- build/compile.xml 2006-10-19 18:07:58.000000000 +0200
++++ build/compile.xml 2006-10-19 18:17:17.000000000 +0200
+@@ -13,11 +13,12 @@
+ <ant antfile="build_native.xml"/>
+ </target>
+
+- <target name="compile-examples">
++ <target name="compile-examples" if="examples">
+ <mkdir dir="${build.examples}"/>
+ <javac srcdir="${source.examples}"
+ destdir="${build.examples}"
+- target="${ant.java.version}"
++ source="1.4"
++ target="1.4"
+ debug="on"
+ deprecation="on"
+ optimize="on"
+@@ -40,25 +41,25 @@
+ </path>
+ </target>
+
+- <target name="set-wire1.3-src" if="jdk1.3">
++ <target name="set-wire1.3-src" if="never">
+ <path id="source.java.wire">
+ <pathelement path="${source.wire1.3}"/>
+ </path>
+ </target>
+
+- <target name="set-wire1.4-src" unless="jdk1.3">
++ <target name="set-wire1.4-src">
+ <path id="source.java.wire">
+ <pathelement path="${source.wire1.4}"/>
+ </path>
+ </target>
+
+- <target name="set-pool1.4-src" unless="jdk1.5">
++ <target name="set-pool1.4-src">
+ <path id="source.java.pool">
+ <pathelement path="${source.pool1.4}"/>
+ </path>
+ </target>
+
+- <target name="set-pool1.5-src" if="jdk1.5">
++ <target name="set-pool1.5-src" if="never">
+ <path id="source.java.pool">
+ <pathelement path="${source.pool1.5}"/>
+ </path>
+@@ -67,7 +68,8 @@
+ <target name="compile-driver" depends="set-jdbc-20-src,set-jdbc-30-src,set-wire1.3-src,set-wire1.4-src">
+ <mkdir dir="${build.classes}"/>
+ <javac destdir="${build.classes}"
+- target="${ant.java.version}"
++ source="1.4"
++ target="1.4"
+ debug="on"
+ deprecation="on"
+ optimize="on"
+@@ -85,7 +87,8 @@
+ <mkdir dir="${build.pool}"/>
+ <javac srcdir="${source.pool}"
+ destdir="${build.pool}"
+- target="${ant.java.version}"
++ source="1.4"
++ target="1.4"
+ debug="on"
+ deprecation="on"
+ optimize="on"
+@@ -101,7 +104,8 @@
+ <mkdir dir="${build.compatibility}"/>
+ <javac srcdir="${source.compatibility}"
+ destdir="${build.compatibility}"
+- target="${ant.java.version}"
++ source="1.4"
++ target="1.4"
+ debug="on"
+ deprecation="on"
+ optimize="on"
+@@ -121,11 +125,12 @@
+ </path>
+ </target>
+
+- <target name="compile-tests" depends="compile-pool,set-jdbc-20-test,set-jdbc-30-test">
++ <target name="compile-tests" depends="compile-pool,set-jdbc-20-test,set-jdbc-30-test" if="tests">
+ <mkdir dir="${build.test}"/>
+ <javac srcdir="${source.test}"
+ destdir="${build.test}"
+- target="${ant.java.version}"
++ source="1.4"
++ target="1.4"
+ debug="on"
+ deprecation="on"
+ optimize="on"
diff --git a/dev-java/jdbc-jaybird/files/dist-xml-2.0.1.patch b/dev-java/jdbc-jaybird/files/dist-xml-2.0.1.patch
new file mode 100644
index 000000000000..fd4c3c35afa6
--- /dev/null
+++ b/dev-java/jdbc-jaybird/files/dist-xml-2.0.1.patch
@@ -0,0 +1,10 @@
+--- build/dist.xml 2006-10-19 18:07:20.000000000 +0200
++++ build/dist.xml 2006-10-19 18:10:11.000000000 +0200
+@@ -5,6 +5,7 @@
+ <mkdir dir="${build.docs}"/>
+ <javadoc packagenames="${packages}"
+ sourcepath="${source.java};${source.pool}"
++ source="1.4"
+ destdir="${build.docs}"
+ author="true"
+ version="true"
diff --git a/dev-java/jdbc-jaybird/jdbc-jaybird-2.0.1.ebuild b/dev-java/jdbc-jaybird/jdbc-jaybird-2.0.1.ebuild
index 420961223317..63dffdd4e2e2 100644
--- a/dev-java/jdbc-jaybird/jdbc-jaybird-2.0.1.ebuild
+++ b/dev-java/jdbc-jaybird/jdbc-jaybird-2.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/jdbc-jaybird-2.0.1.ebuild,v 1.6 2006/10/19 20:11:13 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/jdbc-jaybird-2.0.1.ebuild,v 1.7 2006/10/19 21:39:35 caster Exp $
-inherit java-pkg-2
+inherit eutils java-pkg-2
At="JayBird-${PV}-src"
DESCRIPTION="JDBC Type 2 and 4 drivers for Firebird SQL server"
@@ -13,45 +13,55 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples source test"
+COMMON_DEPEND="dev-java/log4j"
RDEPEND="|| ( =virtual/jre-1.4* =virtual/jre-1.5* )
- dev-java/log4j"
+ ${COMMON_DEPEND}"
DEPEND="|| ( =virtual/jdk-1.4* =virtual/jdk-1.5* )
app-arch/unzip
- dev-java/ant-core
dev-java/cpptasks
- ${RDEPEND}
- test? ( dev-java/junit )
- source? ( app-arch/zip )"
+ test? (
+ dev-java/junit
+ dev-java/ant
+ )
+ !test? ( dev-java/ant-core )
+ source? ( app-arch/zip )
+ ${COMMON_DEPEND}"
S="${WORKDIR}/client-java"
MY_PN="jaybird"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
+ cd "${S}"
+
+ # make compiling of tests and examples optional, fix source/target
+ # disable checking for jdk version - default all to 1.4
+ # note that java-ant-2.eclass xml rewriting breaks here
+ epatch "${FILESDIR}/archive-xml-${PV}.patch"
+ epatch "${FILESDIR}/compile-xml-${PV}.patch"
+ epatch "${FILESDIR}/dist-xml-${PV}.patch"
- cd "${S}"/lib/
- rm *.jar
- use test && java-pkg_jar-from junit junit.jar
+ cd "${S}/lib/"
+ rm -v *.jar
+ use test && java-pkg_jar-from --build-only junit junit.jar
cd "${S}/src/lib/"
# the build.xml unpacks this and uses stuff
mv mini-j2ee.jar ${T} || die "Failed to move mini-j2ee.jar to ${T}"
- rm *.jar
+ rm -v *.jar *.zip
mv ${T}/mini-j2ee.jar . || die "Failed to move mini-j2ee.jar back from ${T}"
java-pkg_jar-from log4j log4j.jar log4j-core.jar
}
src_compile() {
- local antflags="jars compile-native"
- use doc && antflags="${antflags} javadocs"
- use test && antflags="${antflags} -Dtests=true"
- eant ${antflags}
+ eant $(use test && echo "-Dtests=true") jars compile-native \
+ $(use_doc javadocs)
}
src_install() {
- cd "${S}"/output/lib/
+ cd "${S}/output/lib/"
java-pkg_newjar ${MY_PN}-${PV}.jar ${PN}.jar
for jar in full pool; do
@@ -61,7 +71,7 @@ src_install() {
java-pkg_newjar ${MY_PN}-test-${PV}.jar ${MY_PN}-${jar}.jar || die "java-pkg_newjar ${MY_PN}-${jar}.jar failed"
fi
- cd "${S}"/output/native
+ cd "${S}/output/native"
sodest="/usr/lib/"
java-pkg_doso libjaybird2.so || die "java-pkg_doso ${sodest}libjaybird2.so failed"
@@ -75,8 +85,8 @@ src_install() {
use source && java-pkg_dosrc "${S}"/src/*/org
cd "${S}/output"
- use doc && java-pkg_dohtml -r docs/
- dodoc etc/{*.txt,default.mf}
+ use doc && java-pkg_dojavadoc docs
+ dodoc etc/FAQ.txt
dohtml etc/*.html
}
@@ -88,5 +98,5 @@ src_test() {
ewarn "without Firebird installed and running locally. The tests will"
ewarn "complete without Firebird, but network timeouts prolong the"
ewarn "testing phase considerably."
- ant all-tests-pure-java || die "JUnit testing failed."
+ eant all-tests-pure-java
}
diff --git a/dev-java/jdbc-jaybird/metadata.xml b/dev-java/jdbc-jaybird/metadata.xml
index b02d7d2b4bcc..e0e17cc4950e 100644
--- a/dev-java/jdbc-jaybird/metadata.xml
+++ b/dev-java/jdbc-jaybird/metadata.xml
@@ -5,13 +5,13 @@
<herd>java</herd>
<maintainer>
- <email>wltjr@gentoo.org</email>
+ <email>wltjr@gentoo.org</email>
<name>William L. Thomson Jr.</name>
</maintainer>
<longdescription>
Jaybird is a JCA/JDBC driver suite for the Firebird database server.
- This package includes both a type 2 and 4 JDBC driver.
+ This package includes both a type 2 and 4 JDBC driver.
</longdescription>
</pkgmetadata>