summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2008-12-16 21:26:49 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2008-12-16 21:26:49 +0000
commitc7ec6018254e41148f97b155d70f24cbd9b7e725 (patch)
treeac0d30e7ef65668be6a9f01f77da0522243a31c2 /dev-haskell
parentMarking xmpppy-0.4.1 ~ppc and ~ppc64 for bug 249837 (diff)
downloadgentoo-2-c7ec6018254e41148f97b155d70f24cbd9b7e725.tar.gz
gentoo-2-c7ec6018254e41148f97b155d70f24cbd9b7e725.tar.bz2
gentoo-2-c7ec6018254e41148f97b155d70f24cbd9b7e725.zip
Bump dev-haskell/happy to 1.18.2
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/happy/ChangeLog7
-rw-r--r--dev-haskell/happy/happy-1.18.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index 9790db7b31d4..15ceaae53d18 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/happy
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.37 2008/10/04 01:16:11 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.38 2008/12/16 21:26:49 kolmodin Exp $
+
+*happy-1.18.2 (16 Dec 2008)
+
+ 16 Dec 2008; Lennart Kolmodin <kolmodin@gentoo.org> +happy-1.18.2.ebuild:
+ Version bump
04 Oct 2008; Ferris McCormick <fmccor@gentoo.org> happy-1.17.ebuild:
Sparc stable --- Bug #230919 and Bug #239368.
diff --git a/dev-haskell/happy/happy-1.18.2.ebuild b/dev-haskell/happy/happy-1.18.2.ebuild
new file mode 100644
index 000000000000..1677d270611b
--- /dev/null
+++ b/dev-haskell/happy/happy-1.18.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.18.2.ebuild,v 1.1 2008/12/16 21:26:49 kolmodin Exp $
+
+CABAL_FEATURES="bin"
+CABAL_MIN_VERSION=1.2
+inherit haskell-cabal autotools
+
+DESCRIPTION="A yacc-like parser generator for Haskell"
+HOMEPAGE="http://haskell.org/happy/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.4
+ dev-haskell/mtl
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/doc" && eautoconf
+}
+
+src_compile() {
+ cabal_src_compile
+ if use doc; then
+ cd doc
+ econf || die "econf failed in /doc"
+ emake -j1 || die "emake failed in /doc"
+ fi
+}
+
+src_install() {
+ cabal_src_install
+ use doc && cd doc && dohtml -r happy/*
+}