summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-03 05:29:37 +0000
committerMark Wright <gienah@gentoo.org>2013-04-03 05:29:37 +0000
commit86736a09744f18861b992ac343850e1708f1213b (patch)
treec8f096736d3e7a6b6d4ff80b6646acabb632736d /dev-haskell
parentMove gtk2hs to slot 2 fix bug 464260. (diff)
downloadgentoo-2-86736a09744f18861b992ac343850e1708f1213b.tar.gz
gentoo-2-86736a09744f18861b992ac343850e1708f1213b.tar.bz2
gentoo-2-86736a09744f18861b992ac343850e1708f1213b.zip
Move gtk2hs to slot 2 fix bug 464260. Patch gtk-0.12.0 to fix bugs 464266 - dev-haskell/gtk-0.12.0: build fails with >=ghc-7.4.1 Ambiguous module name and 455012 - dev-haskell/gtk-0.12.0: fails to build with glib-2.32
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/gtk/ChangeLog11
-rw-r--r--dev-haskell/gtk/files/gtk-0.12.0-ghc-7.2.patch23
-rw-r--r--dev-haskell/gtk/gtk-0.12.0.ebuild21
-rw-r--r--dev-haskell/gtk/gtk-0.12.3.1.ebuild50
-rw-r--r--dev-haskell/gtk/gtk-0.12.3.ebuild40
-rw-r--r--dev-haskell/gtk/gtk-0.12.4-r1.ebuild60
-rw-r--r--dev-haskell/gtk/gtk-0.12.4.ebuild35
7 files changed, 105 insertions, 135 deletions
diff --git a/dev-haskell/gtk/ChangeLog b/dev-haskell/gtk/ChangeLog
index f0c65e55aa78..938f4b42c893 100644
--- a/dev-haskell/gtk/ChangeLog
+++ b/dev-haskell/gtk/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-haskell/gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.12 2013/01/06 09:19:10 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.13 2013/04/03 05:29:37 gienah Exp $
+
+*gtk-0.12.4-r1 (03 Apr 2013)
+
+ 03 Apr 2013; Mark Wright <gienah@gentoo.org> +files/gtk-0.12.0-ghc-7.2.patch,
+ +gtk-0.12.4-r1.ebuild, -gtk-0.12.3.1.ebuild, -gtk-0.12.3.ebuild,
+ -gtk-0.12.4.ebuild, gtk-0.12.0.ebuild:
+ Move gtk2hs to slot 2 fix bug 464260. Patch gtk-0.12.0 to fix bugs 464266 -
+ dev-haskell/gtk-0.12.0: build fails with >=ghc-7.4.1 Ambiguous module name and
+ 455012 - dev-haskell/gtk-0.12.0: fails to build with glib-2.32
06 Jan 2013; Agostino Sarubbo <ago@gentoo.org> gtk-0.12.4.ebuild:
Add ~sparc, wrt bug #449220
diff --git a/dev-haskell/gtk/files/gtk-0.12.0-ghc-7.2.patch b/dev-haskell/gtk/files/gtk-0.12.0-ghc-7.2.patch
new file mode 100644
index 000000000000..1d454c5f06ea
--- /dev/null
+++ b/dev-haskell/gtk/files/gtk-0.12.0-ghc-7.2.patch
@@ -0,0 +1,23 @@
+diff --git a/Graphics/UI/Gtk/General/Structs.hsc b/Graphics/UI/Gtk/General/Structs.hsc
+index 2df0385..c1b8452 100644
+--- a/Graphics/UI/Gtk/General/Structs.hsc
++++ b/Graphics/UI/Gtk/General/Structs.hsc
+@@ -1,4 +1,5 @@
+ {-# LANGUAGE ScopedTypeVariables, TypeSynonymInstances #-}
++{-# LANGUAGE FlexibleInstances #-}
+ {-# OPTIONS_HADDOCK hide #-}
+ -- -*-haskell-*-
+
+diff --git a/gtk.cabal b/gtk.cabal
+index bd97975..aa7165f 100644
+--- a/gtk.cabal
++++ b/gtk.cabal
+@@ -126,7 +126,7 @@ Flag have-gio
+
+ Library
+ build-depends: base >= 4 && < 5,
+- array, containers, haskell98, mtl, bytestring,
++ array, containers, mtl, bytestring,
+ glib >= 0.12.0 && < 0.13,
+ pango >= 0.12.0 && < 0.13,
+ cairo >= 0.12.0 && < 0.13
diff --git a/dev-haskell/gtk/gtk-0.12.0.ebuild b/dev-haskell/gtk/gtk-0.12.0.ebuild
index 3b09694333b8..f675aa90f6b0 100644
--- a/dev-haskell/gtk/gtk-0.12.0.ebuild
+++ b/dev-haskell/gtk/gtk-0.12.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.0.ebuild,v 1.4 2012/09/12 14:39:44 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.0.ebuild,v 1.5 2013/04/03 05:29:37 gienah Exp $
# ebuild generated by hackport 0.2.13
@@ -8,27 +8,30 @@ EAPI="3"
#nocabaldep is for the fancy cabal-detection feature at build-time
CABAL_FEATURES="lib profile haddock hscolour nocabaldep"
-inherit haskell-cabal
+inherit base haskell-cabal
DESCRIPTION="Haskell bindings to the Gtk+ graphical user interface library."
HOMEPAGE="http://www.haskell.org/gtk2hs/"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
-SLOT="0"
+SLOT="2"
KEYWORDS="amd64 x86"
IUSE="+gio"
-RDEPEND="=dev-haskell/cairo-0.12*
- =dev-haskell/glib-0.12*
+RDEPEND="=dev-haskell/cairo-0.12*:2
+ =dev-haskell/glib-0.12*:2
dev-haskell/mtl
- =dev-haskell/pango-0.12*
+ =dev-haskell/pango-0.12*:2
>=dev-lang/ghc-6.10.1
dev-libs/glib:2
x11-libs/gtk+:2
- gio? ( =dev-haskell/gio-0.12* )"
+ gio? ( =dev-haskell/gio-0.12*:2 )"
DEPEND="${RDEPEND}
- dev-haskell/gtk2hs-buildtools"
+ dev-haskell/gtk2hs-buildtools:2"
+
+PATCHES=("${FILESDIR}/${PN}-0.12.0-ghc-7.2.patch"
+ "${FILESDIR}/${PN}-0.12.3-glib-2.32.patch")
src_configure() {
# Upstream has this enabled, so we might as well force it enabled to be sure.
diff --git a/dev-haskell/gtk/gtk-0.12.3.1.ebuild b/dev-haskell/gtk/gtk-0.12.3.1.ebuild
deleted file mode 100644
index 564103daaeb8..000000000000
--- a/dev-haskell/gtk/gtk-0.12.3.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.3.1.ebuild,v 1.1 2012/11/25 06:04:14 gienah Exp $
-
-EAPI=4
-
-# ebuild generated by hackport 0.2.18.9999
-
-#nocabaldep is for the fancy cabal-detection feature at build-time
-CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
-inherit haskell-cabal
-
-DESCRIPTION="Binding to the Gtk+ graphical user interface library."
-HOMEPAGE="http://projects.haskell.org/gtk2hs/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+gio"
-
-RDEPEND=">=dev-haskell/cairo-0.12.0[profile?]
- <dev-haskell/cairo-0.13[profile?]
- >=dev-haskell/glib-0.12.0[profile?]
- <dev-haskell/glib-0.13[profile?]
- dev-haskell/mtl[profile?]
- >=dev-haskell/pango-0.12.0[profile?]
- <dev-haskell/pango-0.13[profile?]
- >=dev-lang/ghc-6.10.1
- dev-libs/glib:2
- x11-libs/gtk+:2
- gio? ( =dev-haskell/gio-0.12*[profile?] )"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- dev-haskell/gtk2hs-buildtools"
-
-src_prepare() {
- # c2hs ignores #if __GLASGOW_HASKELL__ >= 706
- # I do not know which earlier ghc versions the patch submitted upstream works with
- if has_version ">=dev-lang/ghc-7.6.1"; then
- epatch "${FILESDIR}/${PN}-0.12.3.1-ghc-7.6.patch"
- fi
-}
-
-src_configure() {
- # Upstream has this enabled, so we might as well force it enabled to be sure.
- cabal_src_configure \
- --flags=deprecated \
- $(cabal_flag gio have-gio)
-}
diff --git a/dev-haskell/gtk/gtk-0.12.3.ebuild b/dev-haskell/gtk/gtk-0.12.3.ebuild
deleted file mode 100644
index 3c2120c81788..000000000000
--- a/dev-haskell/gtk/gtk-0.12.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.3.ebuild,v 1.2 2012/09/12 14:39:44 qnikst Exp $
-
-# ebuild generated by hackport 0.2.13
-
-EAPI=4
-
-#nocabaldep is for the fancy cabal-detection feature at build-time
-CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
-inherit base haskell-cabal
-
-DESCRIPTION="Binding to the Gtk+ graphical user interface library."
-HOMEPAGE="http://projects.haskell.org/gtk2hs/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+gio"
-
-RDEPEND="=dev-haskell/cairo-0.12*[profile?]
- =dev-haskell/glib-0.12*[profile?]
- dev-haskell/mtl[profile?]
- =dev-haskell/pango-0.12*[profile?]
- >=dev-lang/ghc-6.10.1
- dev-libs/glib:2
- x11-libs/gtk+:2
- gio? ( =dev-haskell/gio-0.12*[profile?] )"
-DEPEND="${RDEPEND}
- dev-haskell/gtk2hs-buildtools"
-
-PATCHES=("${FILESDIR}"/${P}-glib-2.32.patch)
-
-src_configure() {
- # Upstream has this enabled, so we might as well force it enabled to be sure.
- cabal_src_configure \
- --flags=deprecated \
- $(cabal_flag gio have-gio)
-}
diff --git a/dev-haskell/gtk/gtk-0.12.4-r1.ebuild b/dev-haskell/gtk/gtk-0.12.4-r1.ebuild
new file mode 100644
index 000000000000..80a71a5f4e3f
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.12.4-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.4-r1.ebuild,v 1.1 2013/04/03 05:29:37 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+GTK_MAJ_VER="2"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library."
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="${GTK_MAJ_VER}/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gio"
+
+RDEPEND=">=dev-haskell/cairo-0.12.0:${GTK_MAJ_VER}=[profile?]
+ <dev-haskell/cairo-0.13:${GTK_MAJ_VER}=[profile?]
+ >=dev-haskell/gio-0.12.0:${GTK_MAJ_VER}=[profile?]
+ <dev-haskell/gio-0.13:${GTK_MAJ_VER}=[profile?]
+ >=dev-haskell/glib-0.12.0:${GTK_MAJ_VER}=[profile?]
+ <dev-haskell/glib-0.13:${GTK_MAJ_VER}=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.12.0:${GTK_MAJ_VER}=[profile?]
+ <dev-haskell/pango-0.13:${GTK_MAJ_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ dev-libs/glib:2
+ x11-libs/gtk+:${GTK_MAJ_VER}
+ gio? ( =dev-haskell/gio-0.12*:${GTK_MAJ_VER}[profile?] )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-haskell/gtk2hs-buildtools-0.12.4:${GTK_MAJ_VER}=
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -e "s@gtk2hsTypeGen@gtk2hsTypeGen${GTK_MAJ_VER}@" \
+ -e "s@gtk2hsHookGenerator@gtk2hsHookGenerator${GTK_MAJ_VER}@" \
+ -e "s@gtk2hsC2hs@gtk2hsC2hs${GTK_MAJ_VER}@" \
+ -i "${S}/Gtk2HsSetup.hs" \
+ || die "Could not change Gtk2HsSetup.hs for GTK+ slot ${GTK_MAJ_VER}"
+ sed -e "s@gtk2hsC2hs@gtk2hsC2hs${GTK_MAJ_VER}@" \
+ -e "s@gtk2hsTypeGen@gtk2hsTypeGen${GTK_MAJ_VER}@" \
+ -e "s@gtk2hsHookGenerator@gtk2hsHookGenerator${GTK_MAJ_VER}@" \
+ -i "${S}/${PN}.cabal" \
+ || die "Could not change ${PN}.cabal for GTK+ slot ${GTK_MAJ_VER}"
+}
+
+src_configure() {
+ # Upstream has this enabled, so we might as well force it enabled to be sure.
+ cabal_src_configure \
+ --flags=deprecated \
+ $(cabal_flag gio have-gio)
+}
diff --git a/dev-haskell/gtk/gtk-0.12.4.ebuild b/dev-haskell/gtk/gtk-0.12.4.ebuild
deleted file mode 100644
index 93cfb77bf8e5..000000000000
--- a/dev-haskell/gtk/gtk-0.12.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.4.ebuild,v 1.6 2013/01/06 09:19:10 ago Exp $
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Binding to the Gtk+ graphical user interface library."
-HOMEPAGE="http://projects.haskell.org/gtk2hs/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/cairo-0.12.0:=[profile?]
- <dev-haskell/cairo-0.13:=[profile?]
- >=dev-haskell/gio-0.12.0:=[profile?]
- <dev-haskell/gio-0.13:=[profile?]
- >=dev-haskell/glib-0.12.0:=[profile?]
- <dev-haskell/glib-0.13:=[profile?]
- dev-haskell/mtl:=[profile?]
- >=dev-haskell/pango-0.12.0:=[profile?]
- <dev-haskell/pango-0.13:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- dev-libs/glib:2
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- >=dev-haskell/gtk2hs-buildtools-0.12.4"