summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-29 20:27:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-29 20:27:27 +0000
commita7cd2d6b41f100bf100007498c17947985279785 (patch)
tree9ca8c496b07d6ee280e795e1d1fc53cc08a939ef /dev-games
parentVersion bump to 2.1.4 (diff)
downloadgentoo-2-a7cd2d6b41f100bf100007498c17947985279785.tar.gz
gentoo-2-a7cd2d6b41f100bf100007498c17947985279785.tar.bz2
gentoo-2-a7cd2d6b41f100bf100007498c17947985279785.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/files/ogre-1.4.6-cegui.patch19
-rw-r--r--dev-games/ogre/ogre-1.4.6.ebuild90
2 files changed, 0 insertions, 109 deletions
diff --git a/dev-games/ogre/files/ogre-1.4.6-cegui.patch b/dev-games/ogre/files/ogre-1.4.6-cegui.patch
deleted file mode 100644
index c089164af219..000000000000
--- a/dev-games/ogre/files/ogre-1.4.6-cegui.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- acinclude.m4
-+++ acinclude.m4
-@@ -411,6 +411,8 @@
- ])
-
- AC_DEFUN([OGRE_CHECK_CEGUI], [
-+ AC_ARG_ENABLE(cegui)
-+ if test x$enable_cegui != xno; then
- PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.5.0,
- [build_cegui_sample=true], [build_cegui_sample=false])
- if test x$build_cegui_sample = xtrue; then
-@@ -426,6 +428,7 @@
- else
- AC_MSG_RESULT([CEGUI not available, Gui and FacialAnimation samples will not be built])
- fi
-+ fi
- AM_CONDITIONAL([HAVE_CEGUI], [test x$build_cegui_sample = xtrue])
- ])
-
diff --git a/dev-games/ogre/ogre-1.4.6.ebuild b/dev-games/ogre/ogre-1.4.6.ebuild
deleted file mode 100644
index c187c598b254..000000000000
--- a/dev-games/ogre/ogre-1.4.6.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.4.6.ebuild,v 1.1 2008/01/16 11:39:13 nyhm Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="Object-oriented Graphics Rendering Engine"
-HOMEPAGE="http://www.ogre3d.org/"
-SRC_URI="mirror://sourceforge/ogre/ogre-linux_osx-v${PV//./-}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc cegui cg devil double-precision examples gtk openexr threads"
-RESTRICT="test" #139905
-
-RDEPEND="dev-libs/zziplib
- >=media-libs/freetype-2.1.10
- virtual/opengl
- virtual/glu
- x11-libs/libXt
- x11-libs/libXaw
- x11-libs/libXrandr
- x11-libs/libX11
- cegui? ( >=dev-games/cegui-0.5 )
- cg? ( media-gfx/nvidia-cg-toolkit )
- devil? ( media-libs/devil )
- gtk? ( >=x11-libs/gtk+-2 )
- openexr? ( >=media-libs/openexr-1.2 )
- threads? ( dev-libs/boost )"
-DEPEND="${RDEPEND}
- x11-proto/xf86vidmodeproto
- dev-util/pkgconfig"
-
-S=${WORKDIR}/ogrenew
-
-pkg_setup() {
- if use threads && has_version "<dev-libs/boost-1.34" && \
- ! built_with_use dev-libs/boost threads
- then
- die "Please emerge dev-libs/boost with USE=threads"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- find -name CVS -print0 | xargs -0 rm -rf
- if use examples ; then
- cp -r Samples install-examples || die
- find install-examples \
- '(' -name 'Makefile*' -o -name obj -o \
- -name bin -o -name '*.cbp' -o -name '*.vcproj*' ')' \
- -print0 | xargs -0 rm -rf
- fi
- sed -i '/CPPUNIT/d' configure.in || die "sed failed"
- epatch "${FILESDIR}"/${P}-cegui.patch
- eautoreconf
-}
-
-src_compile() {
- econf \
- --disable-dependency-tracking \
- --disable-freeimage \
- --disable-ogre-demos \
- --enable-static \
- --with-platform=GLX \
- --with-gui=$(usev gtk || echo Xt) \
- $(use_enable cegui) \
- $(use_enable cg) \
- $(use_enable devil) \
- $(use_enable double-precision double) \
- $(use_enable openexr) \
- $(use_enable threads threading) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- if use doc ; then
- insinto /usr/share/doc/${PF}/html
- doins -r Docs/* || die "doins Docs failed"
- fi
- if use examples ; then
- insinto /usr/share/doc/${PF}/Samples
- doins -r install-examples/* || die "doins Samples failed"
- fi
- dodoc AUTHORS BUGS LINUX.DEV README
-}