summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo Arrifano <miknix@gentoo.org>2012-09-03 21:07:09 +0000
committerAngelo Arrifano <miknix@gentoo.org>2012-09-03 21:07:09 +0000
commite6c35ecd4831e5affe0268aae4d4b6879f70ba4d (patch)
tree1b14014dc46de9c6b89e48d298ebcfa75beb6a44 /dev-embedded
parentVersion bump. (diff)
downloadgentoo-2-e6c35ecd4831e5affe0268aae4d4b6879f70ba4d.tar.gz
gentoo-2-e6c35ecd4831e5affe0268aae4d4b6879f70ba4d.tar.bz2
gentoo-2-e6c35ecd4831e5affe0268aae4d4b6879f70ba4d.zip
Version bump, cleaned up old cruft.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/arduino/ChangeLog12
-rw-r--r--dev-embedded/arduino/arduino-0015-r1.ebuild66
-rw-r--r--dev-embedded/arduino/arduino-0017.ebuild66
-rw-r--r--dev-embedded/arduino/arduino-1.0.1.ebuild82
-rw-r--r--dev-embedded/arduino/arduino-1.0.ebuild86
-rw-r--r--dev-embedded/arduino/files/Makefile-0011.patch38
-rw-r--r--dev-embedded/arduino/files/Makefile-0015.patch38
-rw-r--r--dev-embedded/arduino/files/Makefile-0017.patch38
-rwxr-xr-xdev-embedded/arduino/files/arduino3
-rw-r--r--dev-embedded/arduino/files/arduino-1.0-prog_char-fix.patch13
-rw-r--r--dev-embedded/arduino/files/arduino-1.0.1-build.xml.patch38
-rw-r--r--dev-embedded/arduino/files/arduino-1.0.1-script.patch (renamed from dev-embedded/arduino/files/arduino-1.0-script.patch)0
-rw-r--r--dev-embedded/arduino/files/arduino-script-0017.patch20
13 files changed, 131 insertions, 369 deletions
diff --git a/dev-embedded/arduino/ChangeLog b/dev-embedded/arduino/ChangeLog
index 47110ea5d252..c8a8e70f6753 100644
--- a/dev-embedded/arduino/ChangeLog
+++ b/dev-embedded/arduino/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-embedded/arduino
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/arduino/ChangeLog,v 1.8 2012/02/10 00:50:47 miknix Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/arduino/ChangeLog,v 1.9 2012/09/03 21:07:08 miknix Exp $
+
+*arduino-1.0.1 (03 Sep 2012)
+
+ 03 Sep 2012; Angelo Arrifano <miknix@gentoo.org> -arduino-1.0.ebuild,
+ +arduino-1.0.1.ebuild, +files/arduino-1.0.1-build.xml.patch,
+ +files/arduino-1.0.1-script.patch, -files/arduino-1.0-prog_char-fix.patch,
+ -files/arduino-1.0-script.patch, -files/Makefile-0011.patch,
+ -arduino-0015-r1.ebuild, -files/Makefile-0015.patch, -arduino-0017.ebuild,
+ -files/Makefile-0017.patch, -files/arduino-script-0017.patch, -files/arduino:
+ Version bump, cleaned up old cruft. Thanks mrueg and others, #420861
10 Feb 2012; Angelo Arrifano <miknix@gentoo.org> arduino-1.0.ebuild,
+files/arduino.desktop:
diff --git a/dev-embedded/arduino/arduino-0015-r1.ebuild b/dev-embedded/arduino/arduino-0015-r1.ebuild
deleted file mode 100644
index 0c195dc99c4e..000000000000
--- a/dev-embedded/arduino/arduino-0015-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2008-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/arduino/arduino-0015-r1.ebuild,v 1.2 2009/04/24 22:55:42 nixphoeni Exp $
-
-inherit eutils
-
-DESCRIPTION="Arduino is an open-source AVR electronics prototyping platform"
-HOMEPAGE="http://arduino.cc/"
-SRC_URI="http://www.arduino.cc/files/${P}-linux.tgz"
-LICENSE="GPL-2 LGPL-2 CCPL-Attribution-ShareAlike-3.0"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-RESTRICT="strip binchecks"
-IUSE="java"
-RDEPEND="dev-embedded/avrdude"
-DEPEND="${RDEPEND} sys-devel/crossdev java? ( virtual/jre dev-embedded/uisp dev-java/jikes dev-java/rxtx dev-java/antlr )"
-
-pkg_setup() {
- [ ! -x /usr/bin/avr-g++ ] && ewarn "Missing avr-g++; you need to crossdev -s4 avr"
-}
-
-pkg_postinst() {
- pkg_setup
- einfo "Copy /usr/share/${P}/hardware/cores/arduino/Makefile and edit it to suit the project"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/Makefile-${PV}.patch
- rm -rf hardware/tools/avrdude*
- if ! use java; then
- rm -rf lib
- rm -f arduino
- fi
-}
-
-src_install() {
- mkdir -p "${D}/usr/share/${P}/" "${D}/usr/bin"
- cp -a "${S}" "${D}/usr/share/"
- fowners -R root:uucp "/usr/share/${P}/hardware"
- if use java; then
- sed -e s@__PN__@${P}@g < "${FILESDIR}"/arduino > "${D}/usr/bin/arduino"
- chmod +x "${D}/usr/bin/arduino"
-
- # get rid of libraries provided by other packages
- rm -f "${D}/usr/share/${P}/lib/RXTXcomm.jar"
- rm -f "${D}/usr/share/${P}/lib/librxtxSerial.so"
- rm -f "${D}/usr/share/${P}/lib/antlr.jar"
-
- # fix the provided arduino script to call out the right libraries
- sed -i -e 's@lib/antlr\.jar@$(java-config -dp antlr)@g' \
- -e 's@lib/RXTXcomm\.jar@$(java-config -dp rxtx-2)@g' "${D}/usr/share/${P}/arduino"
- # and fix its reference to LD_LIBRARY_PATH (see bug #189249)
- sed -i -e 's@^LD_LIBRARY_PATH=.*@LD_LIBRARY_PATH=$(java-config -di rxtx-2)${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}@' "${D}/usr/share/${P}/arduino"
-
- # use system avrdude
- # patching class files is too hard
- dosym /usr/bin/avrdude "/usr/share/${P}/hardware/tools/avrdude"
- dosym /etc/avrdude.conf "/usr/share/${P}/hardware/tools/avrdude.conf"
-
- # IDE tries to compile these libs at first start up
- fperms -R g+w "/usr/share/${P}/hardware/libraries"
- fi
-
-}
diff --git a/dev-embedded/arduino/arduino-0017.ebuild b/dev-embedded/arduino/arduino-0017.ebuild
deleted file mode 100644
index ea736b390c1d..000000000000
--- a/dev-embedded/arduino/arduino-0017.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/arduino/arduino-0017.ebuild,v 1.1 2009/10/17 18:15:07 nixphoeni Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Arduino is an open-source AVR electronics prototyping platform"
-HOMEPAGE="http://arduino.cc/"
-SRC_URI="http://www.arduino.cc/files/${P}.tgz"
-LICENSE="GPL-2 LGPL-2 CCPL-Attribution-ShareAlike-3.0"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-RESTRICT="strip binchecks"
-IUSE="java"
-RDEPEND="dev-embedded/avrdude sys-devel/crossdev"
-DEPEND="${RDEPEND} java? ( virtual/jre dev-embedded/uisp dev-java/jikes dev-java/rxtx dev-java/antlr )"
-
-pkg_setup() {
- [ ! -x /usr/bin/avr-g++ ] && ewarn "Missing avr-g++; you need to crossdev -s4 avr"
-}
-
-pkg_postinst() {
- pkg_setup
- einfo "Copy /usr/share/${P}/hardware/cores/arduino/Makefile and edit it to suit the project"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/Makefile-${PV}.patch
- rm -rf hardware/tools/avrdude*
- if ! use java; then
- rm -rf lib
- rm -f arduino
- else
- # fix the provided arduino script to call out the right
- # libraries, remove resetting of $PATH, and fix its
- # reference to LD_LIBRARY_PATH (see bug #189249)
- epatch "${FILESDIR}"/arduino-script-${PV}.patch
- fi
-}
-
-src_install() {
- mkdir -p "${D}/usr/share/${P}/" "${D}/usr/bin"
- cp -a "${S}" "${D}/usr/share/"
- fowners -R root:uucp "/usr/share/${P}/hardware"
- if use java; then
- sed -e s@__PN__@${P}@g < "${FILESDIR}"/arduino > "${D}/usr/bin/arduino"
- chmod +x "${D}/usr/bin/arduino"
-
- # get rid of libraries provided by other packages
- rm -f "${D}/usr/share/${P}/lib/RXTXcomm.jar"
- rm -f "${D}/usr/share/${P}/lib/librxtxSerial.so"
- rm -f "${D}/usr/share/${P}/lib/antlr.jar"
- rm -f "${D}/usr/share/${P}/lib/ecj.jar"
-
- # use system avrdude
- # patching class files is too hard
- dosym /usr/bin/avrdude "/usr/share/${P}/hardware/tools/avrdude"
- dosym /etc/avrdude.conf "/usr/share/${P}/hardware/tools/avrdude.conf"
-
- # IDE tries to compile these libs at first start up
- fperms -R g+w "/usr/share/${P}/hardware/libraries"
- fi
-
- dodoc readme.txt
-}
diff --git a/dev-embedded/arduino/arduino-1.0.1.ebuild b/dev-embedded/arduino/arduino-1.0.1.ebuild
new file mode 100644
index 000000000000..e777386c1ca4
--- /dev/null
+++ b/dev-embedded/arduino/arduino-1.0.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/arduino/arduino-1.0.1.ebuild,v 1.1 2012/09/03 21:07:08 miknix Exp $
+
+EAPI=4
+JAVA_PKG_IUSE="doc examples"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="An open-source AVR electronics prototyping platform"
+HOMEPAGE="http://arduino.cc/ http://arduino.googlecode.com/"
+SRC_URI="http://arduino.googlecode.com/files/${P}-src.tar.gz"
+LICENSE="GPL-2 LGPL-2 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="strip binchecks"
+IUSE=""
+
+RDEPEND="dev-embedded/avrdude
+dev-embedded/uisp
+>dev-java/rxtx-2.1
+sys-devel/crossdev
+>=virtual/jre-1.5"
+
+DEPEND="dev-java/jna
+>=virtual/jdk-1.5"
+
+EANT_GENTOO_CLASSPATH="jna,rxtx-2"
+EANT_EXTRA_ARGS="-Dversion=${PV}"
+EANT_BUILD_TARGET="build"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+java_prepare() {
+ # Remove the libraries to ensure the system
+ # libraries are used
+ rm build/linux/dist/tools/avrdude* || die
+ rm build/linux/dist/lib/* || die
+ rm app/lib/* || die
+ rm app/pde.jar || die
+ # Patch build/build.xml - remove local jar files
+ # for rxtx and ecj (use system wide versions)
+ epatch "${FILESDIR}"/${P}-build.xml.patch
+
+ # Patch launcher script to include rxtx class/ld paths
+ epatch "${FILESDIR}"/${P}-script.patch
+}
+
+src_compile() {
+ eant -f core/build.xml
+ EANT_GENTOO_CLASSPATH_EXTRA="../core/core.jar"
+ eant -f app/build.xml
+ eant "${EANT_EXTRA_ARGS}" -f build/build.xml
+}
+
+src_install() {
+ cd "${S}"/build/linux/work || die
+ java-pkg_dojar lib/core.jar lib/pde.jar
+ java-pkg_dolauncher ${PN} --pwd /usr/share/${PN} --main processing.app.Base
+ use examples && java-pkg_doexamples examples
+
+ if use doc; then
+ dodoc revisions.txt "${S}"/readme.txt
+ dohtml -r reference
+ java-pkg_dojavadoc "${S}"/build/javadoc
+ fi
+
+ insinto "/usr/share/${PN}/"
+ doins -r hardware libraries
+ fowners -R root:uucp "/usr/share/${PN}/hardware"
+
+ insinto "/usr/share/${PN}/lib"
+ doins -r lib/*.txt lib/theme lib/*.jpg
+
+ # use system avrdude
+ # patching class files is too hard
+ dosym /usr/bin/avrdude "/usr/share/${PN}/hardware/tools/avrdude"
+ dosym /etc/avrdude.conf "/usr/share/${PN}/hardware/tools/avrdude.conf"
+}
+
+pkg_postinst() {
+ [ ! -x /usr/bin/avr-g++ ] && ewarn "Missing avr-g++; you need to crossdev -s4 avr"
+}
diff --git a/dev-embedded/arduino/arduino-1.0.ebuild b/dev-embedded/arduino/arduino-1.0.ebuild
deleted file mode 100644
index d2061a298510..000000000000
--- a/dev-embedded/arduino/arduino-1.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/arduino/arduino-1.0.ebuild,v 1.2 2012/02/10 00:50:47 miknix Exp $
-
-EAPI=3
-inherit eutils
-
-DESCRIPTION="Arduino is an open-source AVR electronics prototyping platform"
-HOMEPAGE="http://arduino.cc/"
-SRC_URI="x86? ( http://arduino.googlecode.com/files/${P}-linux.tgz )
- amd64? ( http://arduino.googlecode.com/files/${P}-linux64.tgz )"
-
-LICENSE="GPL-2 LGPL-2 CCPL-Attribution-ShareAlike-3.0"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-RESTRICT="strip binchecks"
-IUSE="+java"
-RDEPEND="dev-embedded/avrdude
- sys-devel/crossdev"
-DEPEND="${RDEPEND} java? (
- virtual/jre
- dev-embedded/uisp
- dev-java/jikes
- dev-java/jna
- >=dev-java/rxtx-2.2_pre2 )"
-
-pkg_postinst() {
- ewarn "PLEASE NOTICE:"
- if [ ! -x /usr/bin/avr-g++ ]; then
- ewarn "avr-g++ is missing, if you need a toolchain please see"
- ewarn "http://en.gentoo-wiki.com/wiki/Crossdev#AVR_Architecture"
- ewarn ""
- fi
- ewarn "You will need >=cross-avr/gcc-4.4.1 if you intend to use the new"
- ewarn "Arduino Mega 2560."
-}
-
-src_prepare() {
- # avrdude has it's own ebuild
- rm -rf hardware/tools/avrdude*
-
- # fix deprecated prog_char usage in Print.cpp (#303043)
- epatch "${FILESDIR}"/${P}-prog_char-fix.patch
-
- # -java don't build IDE
- if ! use java; then
- rm -rf lib
- rm -f arduino
- else
- # fix the provided arduino script to call out the right
- # libraries, remove resetting of $PATH, and fix its
- # reference to LD_LIBRARY_PATH (see bug #189249)
- epatch "${FILESDIR}"/${P}-script.patch
- fi
-}
-
-src_install() {
- mkdir -p "${D}/usr/share/${P}/" "${D}/usr/bin"
- cp -a "${S}" "${D}/usr/share/" || die "Copying failed"
-
- if use java; then
- sed -e s@__PN__@${P}@g < "${FILESDIR}"/arduino \
- > "${D}/usr/bin/arduino" && chmod +x "${D}/usr/bin/arduino" \
- || die "Creating run script failed"
-
- # get rid of libraries provided by other packages
- rm -f "${D}/usr/share/${P}/lib/RXTXcomm.jar"
- rm -f "${D}/usr/share/${P}/lib/jna.jar"
- rm -f "${D}/usr/share/${P}/lib/librxtxSerial.so"
- rm -f "${D}/usr/share/${P}/lib/librxtxSerial64.so"
- rm -f "${D}/usr/share/${P}/lib/ecj.jar"
-
- # use system avrdude
- # patching class files is too hard
- dosym /usr/bin/avrdude "/usr/share/${P}/hardware/tools/avrdude" \
- || die "Couldn't symlink system avrdude files"
- dosym /etc/avrdude.conf "/usr/share/${P}/hardware/tools/avrdude.conf" \
- || die "Couldn't symlink system avrdude files"
-
- # install desktop icon
- mkdir -p "${D}"/usr/share/applications
- sed -e s@__P__@${P}@ < "${FILESDIR}"/arduino.desktop \
- > "${D}"/usr/share/applications/arduino.desktop \
- || die "Failed to install desktop icon"
- fi
-}
diff --git a/dev-embedded/arduino/files/Makefile-0011.patch b/dev-embedded/arduino/files/Makefile-0011.patch
deleted file mode 100644
index b9790305025e..000000000000
--- a/dev-embedded/arduino/files/Makefile-0011.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- hardware/cores/arduino/Makefile 2008-09-20 20:15:27.000000000 -0700
-+++ hardware/cores/arduino/Makefile 2008-09-20 20:22:19.000000000 -0700
-@@ -37,8 +37,8 @@
- # $Id: Makefile-0011.patch,v 1.1 2008/09/21 05:03:07 solar Exp $
-
- TARGET = foo
--INSTALL_DIR = /Users/dmellis/Source/arduino/trunk/build/macosx/build/work
--PORT = /dev/tty.usb*
-+INSTALL_DIR = /usr/share/arduino-0011/
-+PORT = /dev/ttyUSB1
- UPLOAD_RATE = 19200
- AVRDUDE_PROGRAMMER = stk500v1
- MCU = atmega168
-@@ -48,7 +48,7 @@
- # Below here nothing should be changed...
-
- ARDUINO = $(INSTALL_DIR)/hardware/cores/arduino
--AVR_TOOLS_PATH = $(INSTALL_DIR)/hardware/tools/avr/bin
-+AVR_TOOLS_PATH = /usr/bin
- SRC = $(ARDUINO)/pins_arduino.c $(ARDUINO)/wiring.c \
- $(ARDUINO)/wiring_analog.c $(ARDUINO)/wiring_digital.c \
- $(ARDUINO)/wiring_pulse.c $(ARDUINO)/wiring_serial.c \
-@@ -89,13 +89,13 @@
- CFLAGS = $(CDEBUG) $(CDEFS) $(CINCS) -O$(OPT) $(CWARN) $(CSTANDARD) $(CEXTRA)
- CXXFLAGS = $(CDEFS) $(CINCS) -O$(OPT)
- #ASFLAGS = -Wa,-adhlns=$(<:.S=.lst),-gstabs
--LDFLAGS = -lm
-+LDFLAGS = -L/usr/avr/lib -lm
-
-
- # Programming support using avrdude. Settings and variables.
- AVRDUDE_PORT = $(PORT)
- AVRDUDE_WRITE_FLASH = -U flash:w:applet/$(TARGET).hex
--AVRDUDE_FLAGS = -V -F -C $(INSTALL_DIR)/hardware/tools/avr/etc/avrdude.conf \
-+AVRDUDE_FLAGS = -V -F -C /etc/avrdude.conf \
- -p $(MCU) -P $(AVRDUDE_PORT) -c $(AVRDUDE_PROGRAMMER) \
- -b $(UPLOAD_RATE)
-
diff --git a/dev-embedded/arduino/files/Makefile-0015.patch b/dev-embedded/arduino/files/Makefile-0015.patch
deleted file mode 100644
index c4f6e410e0de..000000000000
--- a/dev-embedded/arduino/files/Makefile-0015.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- hardware/cores/arduino/Makefile 2009-04-14 16:48:57.000000000 -0400
-+++ hardware/cores/arduino/Makefile 2009-04-14 16:51:56.000000000 -0400
-@@ -35,8 +35,8 @@
- # $Id: Makefile-0015.patch,v 1.1 2009/04/14 22:00:19 solar Exp $
-
- TARGET = $(notdir $(CURDIR))
--INSTALL_DIR = /Users/dmellis/Source/arduino/trunk/build/macosx/build/work
--PORT = /dev/tty.usb*
-+INSTALL_DIR = /usr/share/arduino-0015/
-+PORT = /dev/ttyUSB1
- UPLOAD_RATE = 19200
- AVRDUDE_PROGRAMMER = stk500v1
- MCU = atmega168
-@@ -46,7 +46,7 @@
- # Below here nothing should be changed...
-
- ARDUINO = $(INSTALL_DIR)/hardware/cores/arduino
--AVR_TOOLS_PATH = $(INSTALL_DIR)/hardware/tools/avr/bin
-+AVR_TOOLS_PATH = /usr/bin
- SRC = $(ARDUINO)/pins_arduino.c $(ARDUINO)/wiring.c \
- $(ARDUINO)/wiring_analog.c $(ARDUINO)/wiring_digital.c \
- $(ARDUINO)/wiring_pulse.c $(ARDUINO)/wiring_serial.c \
-@@ -88,13 +88,13 @@
- CFLAGS = $(CDEBUG) $(CDEFS) $(CINCS) -O$(OPT) $(CWARN) $(CSTANDARD) $(CEXTRA)
- CXXFLAGS = $(CDEFS) $(CINCS) -O$(OPT)
- #ASFLAGS = -Wa,-adhlns=$(<:.S=.lst),-gstabs
--LDFLAGS = -lm
-+LDFLAGS = -L/usr/avr/lib -lm
-
-
- # Programming support using avrdude. Settings and variables.
- AVRDUDE_PORT = $(PORT)
- AVRDUDE_WRITE_FLASH = -U flash:w:applet/$(TARGET).hex
--AVRDUDE_FLAGS = -V -F -C $(INSTALL_DIR)/hardware/tools/avr/etc/avrdude.conf \
-+AVRDUDE_FLAGS = -V -F -C /etc/avrdude.conf \
- -p $(MCU) -P $(AVRDUDE_PORT) -c $(AVRDUDE_PROGRAMMER) \
- -b $(UPLOAD_RATE)
-
diff --git a/dev-embedded/arduino/files/Makefile-0017.patch b/dev-embedded/arduino/files/Makefile-0017.patch
deleted file mode 100644
index cee474142192..000000000000
--- a/dev-embedded/arduino/files/Makefile-0017.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- hardware/cores/arduino/Makefile 2009-10-16 23:18:21.000000000 -0400
-+++ hardware/cores/arduino/Makefile 2009-10-16 23:20:02.000000000 -0400
-@@ -35,8 +35,8 @@
- # $Id: Makefile-0017.patch,v 1.1 2009/10/17 18:15:11 nixphoeni Exp $
-
- TARGET = $(notdir $(CURDIR))
--INSTALL_DIR = ../../..
--PORT = /dev/tty.usb*
-+INSTALL_DIR = /usr/share/arduino-0017
-+PORT = /dev/ttyUSB1
- UPLOAD_RATE = 19200
- AVRDUDE_PROGRAMMER = stk500v1
- MCU = atmega168
-@@ -46,7 +46,7 @@
- # Below here nothing should be changed...
-
- ARDUINO = $(INSTALL_DIR)/hardware/cores/arduino
--AVR_TOOLS_PATH = $(INSTALL_DIR)/hardware/tools/avr/bin
-+AVR_TOOLS_PATH = /usr/bin
- SRC = $(ARDUINO)/pins_arduino.c $(ARDUINO)/wiring.c \
- $(ARDUINO)/wiring_analog.c $(ARDUINO)/wiring_digital.c \
- $(ARDUINO)/wiring_pulse.c $(ARDUINO)/wiring_serial.c \
-@@ -88,13 +88,13 @@
- CFLAGS = $(CDEBUG) $(CDEFS) $(CINCS) -O$(OPT) $(CWARN) $(CSTANDARD) $(CEXTRA)
- CXXFLAGS = $(CDEFS) $(CINCS) -O$(OPT)
- #ASFLAGS = -Wa,-adhlns=$(<:.S=.lst),-gstabs
--LDFLAGS = -lm
-+LDFLAGS = -L/usr/avr/lib -lm
-
-
- # Programming support using avrdude. Settings and variables.
- AVRDUDE_PORT = $(PORT)
- AVRDUDE_WRITE_FLASH = -U flash:w:applet/$(TARGET).hex
--AVRDUDE_FLAGS = -V -F -C $(INSTALL_DIR)/hardware/tools/avr/etc/avrdude.conf \
-+AVRDUDE_FLAGS = -V -F -C /etc/avrdude.conf \
- -p $(MCU) -P $(AVRDUDE_PORT) -c $(AVRDUDE_PROGRAMMER) \
- -b $(UPLOAD_RATE)
-
diff --git a/dev-embedded/arduino/files/arduino b/dev-embedded/arduino/files/arduino
deleted file mode 100755
index f6b97590109a..000000000000
--- a/dev-embedded/arduino/files/arduino
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-cd /usr/share/__PN__/
-./arduino "$@"
diff --git a/dev-embedded/arduino/files/arduino-1.0-prog_char-fix.patch b/dev-embedded/arduino/files/arduino-1.0-prog_char-fix.patch
deleted file mode 100644
index 727944719d58..000000000000
--- a/dev-embedded/arduino/files/arduino-1.0-prog_char-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/hardware/arduino/cores/arduino/Print.cpp b/hardware/arduino/cores/arduino/Print.cpp
-index ff9b154..e541a6c 100644
---- a/hardware/arduino/cores/arduino/Print.cpp
-+++ b/hardware/arduino/cores/arduino/Print.cpp
-@@ -41,7 +41,7 @@ size_t Print::write(const uint8_t *buffer, size_t size)
-
- size_t Print::print(const __FlashStringHelper *ifsh)
- {
-- const prog_char *p = (const prog_char *)ifsh;
-+ const char PROGMEM *p = (const char PROGMEM *)ifsh;
- size_t n = 0;
- while (1) {
- unsigned char c = pgm_read_byte(p++);
diff --git a/dev-embedded/arduino/files/arduino-1.0.1-build.xml.patch b/dev-embedded/arduino/files/arduino-1.0.1-build.xml.patch
new file mode 100644
index 000000000000..afde2e05b661
--- /dev/null
+++ b/dev-embedded/arduino/files/arduino-1.0.1-build.xml.patch
@@ -0,0 +1,38 @@
+--- arduino-1.0.1/build/build.xml 2012-04-09 00:16:12.000000000 +0100
++++ arduino-1.0.1/build/build.xml 2012-06-25 06:12:09.000000000 +0100
+@@ -24,9 +24,9 @@
+ <fileset dir=".." id="runtime.jars">
+ <include name="core/core.jar" />
+ <include name="app/pde.jar" />
+- <include name="app/lib/ecj.jar" />
++<!-- <include name="app/lib/ecj.jar" /> -->
+ <include name="app/lib/jna.jar" />
+- <include name="app/lib/RXTXcomm.jar" />
++<!-- <include name="app/lib/RXTXcomm.jar" /> -->
+ <include name="app/lib/ant.jar" />
+ <include name="app/lib/ant-launcher.jar" />
+ </fileset>
+@@ -361,16 +361,18 @@
+ </target>
+
+ <target name="linux64-build" depends="linux-build" description="Build linux (64-bit) version">
+- <copy tofile="linux/work/hardware/tools/avrdude" file="linux/dist/tools/avrdude64" overwrite="true" />
+- <copy tofile="linux/work/lib/librxtxSerial.so" file="linux/dist/lib/librxtxSerial64.so" overwrite="true" />
++<!-- <copy tofile="linux/work/hardware/tools/avrdude" file="linux/dist/tools/avrdude64" overwrite="true" /> -->
++<!-- <copy tofile="linux/work/lib/librxtxSerial.so" file="linux/dist/lib/librxtxSerial64.so" overwrite="true" /> -->
+
+- <chmod perm="755" file="linux/work/hardware/tools/avrdude" />
++<!-- <chmod perm="755" file="linux/work/hardware/tools/avrdude" /> -->
+
+ <!-- Unzip AVR tools -->
+- <exec executable="tar" dir="linux/work/hardware">
++<!-- Removed by Paulj - use system installed instead -->
++<!-- <exec executable="tar" dir="linux/work/hardware">
+ <arg value="-xjf"/>
+ <arg value="../../avr_tools_linux64.tar.bz2"/>
+- </exec>
++ </exec>
++-->
+ </target>
+
+ <target name="linux32-run" depends="linux32-build"
diff --git a/dev-embedded/arduino/files/arduino-1.0-script.patch b/dev-embedded/arduino/files/arduino-1.0.1-script.patch
index 323d6a639b18..323d6a639b18 100644
--- a/dev-embedded/arduino/files/arduino-1.0-script.patch
+++ b/dev-embedded/arduino/files/arduino-1.0.1-script.patch
diff --git a/dev-embedded/arduino/files/arduino-script-0017.patch b/dev-embedded/arduino/files/arduino-script-0017.patch
deleted file mode 100644
index aaad17e8ec73..000000000000
--- a/dev-embedded/arduino/files/arduino-script-0017.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- arduino 2009-08-11 19:00:04.000000000 -0400
-+++ arduino 2009-10-17 13:39:14.000000000 -0400
-@@ -8,14 +8,14 @@
- lib/*.jar \
- ;
- do
-- CLASSPATH="${CLASSPATH}:${APPDIR}/${LIB}"
-+ CLASSPATH="${CLASSPATH+$CLASSPATH:}${APPDIR}/${LIB}"
- done
-+CLASSPATH="${CLASSPATH+$CLASSPATH:}$(java-config -dp antlr)"
-+CLASSPATH="${CLASSPATH+$CLASSPATH:}$(java-config -dp rxtx-2)"
- export CLASSPATH
-
--LD_LIBRARY_PATH=`pwd`/lib:${LD_LIBRARY_PATH}
-+LD_LIBRARY_PATH="$(java-config -di rxtx-2)${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}"
- export LD_LIBRARY_PATH
-
--export PATH="${APPDIR}/java/bin:${PATH}"
--
- java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base