summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-11 09:52:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-11 09:52:36 +0000
commitd070988c792b31c7b7606369cad3bb58a18653b4 (patch)
tree04244de46959bfa80ff4079499551c55c7c81e24 /dev-db
parentVersion bump. (diff)
downloadgentoo-2-d070988c792b31c7b7606369cad3bb58a18653b4.tar.gz
gentoo-2-d070988c792b31c7b7606369cad3bb58a18653b4.tar.bz2
gentoo-2-d070988c792b31c7b7606369cad3bb58a18653b4.zip
Version bump for bug #184791. Includes patch for mysql_client_test per bug #160284, thanks to gabrielp@simnet.is.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog8
-rw-r--r--dev-db/mysql/files/digest-mysql-5.0.446
-rw-r--r--dev-db/mysql/mysql-5.0.44.ebuild72
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 4382113f974a..38d5da0b076c 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.418 2007/06/09 14:24:32 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.419 2007/07/11 09:52:36 robbat2 Exp $
+
+*mysql-5.0.44 (11 Jul 2007)
+
+ 11 Jul 2007; Robin H. Johnson <robbat2@gentoo.org> +mysql-5.0.44.ebuild:
+ Version bump for bug #184791. Includes patch for mysql_client_test per bug
+ #160284, thanks to gabrielp@simnet.is.
09 Jun 2007; Tobias Scherbaum <dertobi123@gentoo.org> mysql-5.0.42.ebuild:
ppc stable, bug #178860
diff --git a/dev-db/mysql/files/digest-mysql-5.0.44 b/dev-db/mysql/files/digest-mysql-5.0.44
new file mode 100644
index 000000000000..8b7b41323415
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-5.0.44
@@ -0,0 +1,6 @@
+MD5 a6a557758bfb66557a1182db75b46b2f mysql-5.0.44.tar.gz 24388270
+RMD160 7b380cf13d040149e5f0e75b582124ec996e0b03 mysql-5.0.44.tar.gz 24388270
+SHA256 e3cd455da52769cc7c80845992dedc9092745fcf3ea4d4929ae4181418805973 mysql-5.0.44.tar.gz 24388270
+MD5 6619312d9ec44aba9ffbef530fc03cdc mysql-extras-20070710.tar.bz2 52626
+RMD160 e0f39f1fd35012fb3e2a431379d7b15389e05187 mysql-extras-20070710.tar.bz2 52626
+SHA256 980a5fa500f4136e13bf434f167995248b9c8f96a2c42c96e4d7ad60246ad7fc mysql-extras-20070710.tar.bz2 52626
diff --git a/dev-db/mysql/mysql-5.0.44.ebuild b/dev-db/mysql/mysql-5.0.44.ebuild
new file mode 100644
index 000000000000..d8c4f2da01be
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.44.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44.ebuild,v 1.1 2007/07/11 09:52:36 robbat2 Exp $
+
+MY_EXTRAS_VER="20070710"
+SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
+
+inherit mysql toolchain-funcs
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # mysqladmin start before dir creation
+ mkdir -p "${S}"/mysql-test/var{,/log}
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ if ! hasq "userpriv" ${FEATURES} ; then
+ # As of 5.0.38, these work with the sandbox
+ # but they break if you are root
+ for t in \
+ loaddata_autocom_ndb \
+ ndb_{alter_table{,2},autodiscover{,2,3},basic,bitfield,blob} \
+ ndb_{cache{,2},cache_multi{,2},charset,condition_pushdown,config} \
+ ndb_{database,gis,index,index_ordered,index_unique,insert,limit} \
+ ndb_{loaddatalocal,lock,minmax,multi,read_multi_range,rename,replace} \
+ ndb_{restore,subquery,transaction,trigger,truncate,types,update} \
+ ps_7ndb rpl_ndb_innodb_trans strict_autoinc_5ndb \
+ mysql_upgrade
+ do
+ mysql_disable_test "${t}" "fails as root"
+ done
+ fi
+
+ [ "${PV}" == "5.0.42" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.42"
+ [ "${PV}" == "5.0.44" ] && \
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.44 on big-endian boxes only"
+
+ # We run the test protocols seperately
+ make -j1 test-ns force=--force
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force=--force
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}