summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-04-21 03:00:50 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-04-21 03:00:50 +0000
commit384ad091fb6ad9b5fb6171f70e8f67b3323a02cd (patch)
treeb80e0ceccf57e8fae68e9c9c40944ecc34464df7 /dev-db
parentAdd back lost ebegin. (diff)
downloadgentoo-2-384ad091fb6ad9b5fb6171f70e8f67b3323a02cd.tar.gz
gentoo-2-384ad091fb6ad9b5fb6171f70e8f67b3323a02cd.tar.bz2
gentoo-2-384ad091fb6ad9b5fb6171f70e8f67b3323a02cd.zip
Add patch for GCC 4.3. Fix quoting issues.
(Portage version: 2.2_pre5)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql++/ChangeLog6
-rw-r--r--dev-db/mysql++/files/mysql++-2.3.2-gcc-4.3.patch11
-rw-r--r--dev-db/mysql++/mysql++-2.3.2.ebuild13
3 files changed, 24 insertions, 6 deletions
diff --git a/dev-db/mysql++/ChangeLog b/dev-db/mysql++/ChangeLog
index aaed0c54bb32..241751d82613 100644
--- a/dev-db/mysql++/ChangeLog
+++ b/dev-db/mysql++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/mysql++
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.50 2008/01/16 05:37:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.51 2008/04/21 03:00:49 dirtyepic Exp $
+
+ 21 Apr 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/mysql++-2.3.2-gcc-4.3.patch, mysql++-2.3.2.ebuild:
+ Add patch for GCC 4.3. Fix quoting issues.
16 Jan 2008; Robin H. Johnson <robbat2@gentoo.org>
-files/patch-1.7.34-typo_correction, -mysql++-1.7.26.ebuild,
diff --git a/dev-db/mysql++/files/mysql++-2.3.2-gcc-4.3.patch b/dev-db/mysql++/files/mysql++-2.3.2-gcc-4.3.patch
new file mode 100644
index 000000000000..f9456e8f88e5
--- /dev/null
+++ b/dev-db/mysql++/files/mysql++-2.3.2-gcc-4.3.patch
@@ -0,0 +1,11 @@
+diff -Naur mysql++-2.3.2-orig/lib/const_string.h mysql++-2.3.2/lib/const_string.h
+--- mysql++-2.3.2-orig/lib/const_string.h 2008-03-22 16:16:39.000000000 -0600
++++ mysql++-2.3.2/lib/const_string.h 2008-03-22 16:18:47.000000000 -0600
+@@ -35,6 +35,7 @@
+ #include <iostream>
+ #include <stdexcept>
+ #include <string>
++#include <cstring>
+
+ namespace mysqlpp {
+
diff --git a/dev-db/mysql++/mysql++-2.3.2.ebuild b/dev-db/mysql++/mysql++-2.3.2.ebuild
index 55bd4ad5e56b..006093f8d6c1 100644
--- a/dev-db/mysql++/mysql++-2.3.2.ebuild
+++ b/dev-db/mysql++/mysql++-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.3.2.ebuild,v 1.2 2008/01/16 05:36:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.3.2.ebuild,v 1.3 2008/04/21 03:00:49 dirtyepic Exp $
inherit eutils
@@ -18,9 +18,12 @@ RDEPEND="${DEPEND}
>=virtual/mysql-4.0"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
- for i in ${S}/lib/*.h ; do
+
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+
+ for i in "${S}"/lib/*.h ; do
sed -i \
-e '/#include </s,mysql.h,mysql/mysql.h,g' \
-e '/#include </s,mysql_version.h,mysql/mysql_version.h,g' \
@@ -46,10 +49,10 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
# install the docs and HTML pages
dodoc README* CREDITS ChangeLog HACKERS Wishlist
dodoc doc/*
- cp -ra doc/html ${D}/usr/share/doc/${PF}/html
+ cp -ra doc/html "${D}"/usr/share/doc/${PF}/html
prepalldocs
}