summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2013-05-16 15:12:49 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2013-05-16 15:12:49 +0000
commit154400b208954330f2a754adbd213a4df132c650 (patch)
tree6c06863d396a3ea9a36e5dc8c4daa08255122a2e /dev-db
parentBump to 0.16 and 0.17 branches, should fix #469110 (diff)
downloadgentoo-2-154400b208954330f2a754adbd213a4df132c650.tar.gz
gentoo-2-154400b208954330f2a754adbd213a4df132c650.tar.bz2
gentoo-2-154400b208954330f2a754adbd213a4df132c650.zip
version bump (bug #465944)+ cleanup
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libzdb/ChangeLog10
-rw-r--r--dev-db/libzdb/libzdb-2.10.5.ebuild4
-rw-r--r--dev-db/libzdb/libzdb-2.11.1.ebuild4
-rw-r--r--dev-db/libzdb/libzdb-2.11.2.ebuild (renamed from dev-db/libzdb/libzdb-2.10.3.ebuild)12
4 files changed, 18 insertions, 12 deletions
diff --git a/dev-db/libzdb/ChangeLog b/dev-db/libzdb/ChangeLog
index c0a93f9047a1..3aada883916b 100644
--- a/dev-db/libzdb/ChangeLog
+++ b/dev-db/libzdb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/libzdb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.11 2013/05/10 08:22:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.12 2013/05/16 15:12:49 lordvan Exp $
+
+*libzdb-2.11.2 (16 May 2013)
+
+ 16 May 2013; <lordvan@gentoo.org> -libzdb-2.10.3.ebuild,
+ libzdb-2.10.5.ebuild, libzdb-2.11.1.ebuild, +libzdb-2.11.2.ebuild:
+ removed old unstable version, fixed repoman warnings (thanks to Johan
+ Bergström for pointing
+ this out) + version bump
10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unused flag from metadata
diff --git a/dev-db/libzdb/libzdb-2.10.5.ebuild b/dev-db/libzdb/libzdb-2.10.5.ebuild
index 1f71ed4cfdad..984b604c0b07 100644
--- a/dev-db/libzdb/libzdb-2.10.5.ebuild
+++ b/dev-db/libzdb/libzdb-2.10.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.10.5.ebuild,v 1.6 2013/04/02 15:03:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.10.5.ebuild,v 1.7 2013/05/16 15:12:49 lordvan Exp $
EAPI="4"
@@ -41,7 +41,7 @@ src_configure() {
fi
if use sqlite; then
- myconf+=" --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
else
myconf="${myconf} --without-sqlite"
fi
diff --git a/dev-db/libzdb/libzdb-2.11.1.ebuild b/dev-db/libzdb/libzdb-2.11.1.ebuild
index dbfb168dd58b..679a9aca7dd9 100644
--- a/dev-db/libzdb/libzdb-2.11.1.ebuild
+++ b/dev-db/libzdb/libzdb-2.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.11.1.ebuild,v 1.3 2013/04/02 15:03:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.11.1.ebuild,v 1.4 2013/05/16 15:12:49 lordvan Exp $
EAPI="4"
@@ -41,7 +41,7 @@ src_configure() {
fi
if use sqlite; then
- myconf+=" --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
else
myconf="${myconf} --without-sqlite"
fi
diff --git a/dev-db/libzdb/libzdb-2.10.3.ebuild b/dev-db/libzdb/libzdb-2.11.2.ebuild
index ef341034d397..a729032a4828 100644
--- a/dev-db/libzdb/libzdb-2.10.3.ebuild
+++ b/dev-db/libzdb/libzdb-2.11.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.10.3.ebuild,v 1.4 2013/04/02 15:03:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.11.2.ebuild,v 1.1 2013/05/16 15:12:49 lordvan Exp $
EAPI="4"
-inherit eutils toolchain-funcs autotools-utils
+inherit eutils toolchain-funcs
DESCRIPTION="A thread safe high level multi-database connection pool library"
HOMEPAGE="http://www.tildeslash.com/libzdb/"
@@ -16,6 +16,8 @@ KEYWORDS="~x86 ~amd64"
IUSE="debug doc mysql postgres +sqlite ssl static-libs"
REQUIRED_USE=" || ( postgres mysql sqlite )"
+RESTRICT=test
+
RDEPEND="mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql-base )
sqlite? ( >=dev-db/sqlite-3.7:3[unlock-notify(+)] )
@@ -26,10 +28,6 @@ DEPEND="${RDEPEND}
src_prepare() {
sed -i -e "s|&& ./pool||g" test/Makefile.in || die
- if ( use sqlite); then
- epatch "$FILESDIR/sqlite_configure.patch"
- fi
- eautoreconf
}
src_configure() {
@@ -43,7 +41,7 @@ src_configure() {
fi
if use sqlite; then
- myconf+=" --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
else
myconf="${myconf} --without-sqlite"
fi