summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-05-06 20:46:32 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-05-06 20:46:32 +0000
commit9d84123776ca8d6338a50c47375af597e0104692 (patch)
tree742ef205d6c94a83cd8e877c4a85837f8604fccf /dev-db/sqlite/sqlite-2.8.16-r4.ebuild
parentIgnore output of renice command. (diff)
downloadgentoo-2-9d84123776ca8d6338a50c47375af597e0104692.tar.gz
gentoo-2-9d84123776ca8d6338a50c47375af597e0104692.tar.bz2
gentoo-2-9d84123776ca8d6338a50c47375af597e0104692.zip
Skip tests gracefully, based on my changes last time. Also, migrate those changes to the two sqlite-2 ebuilds.
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'dev-db/sqlite/sqlite-2.8.16-r4.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r4.ebuild64
1 files changed, 34 insertions, 30 deletions
diff --git a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
index 5d823682f046..6bd5eb25c919 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.1 2006/05/04 00:30:05 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.2 2006/05/06 20:46:32 seemant Exp $
inherit eutils toolchain-funcs alternatives
@@ -23,17 +23,17 @@ ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
src_unpack() {
# test
if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
- die "The userpriv feature must be enabled to run tests"
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ ewarn "The testsuite will be skipped."
fi
- if ! use tcltk; then
- die "The tcltk useflag must be enabled to run tests"
- fi
+ if ! use tcltk; then
+ ewarn "The tcltk useflag must be enabled to run tests."
+ ewarn "The testsuite will be skipped."
+ fi
fi
- unpack ${A}
-
- cd ${S}
+ unpack ${A} ; cd ${S}
use hppa && epatch ${FILESDIR}/${PN}-2.8.15-alignement-fix.patch
@@ -48,12 +48,12 @@ src_unpack() {
fi
sed -i -e "s:@@S@@:${S}:g" \
- -e "s:@@CC@@:$(tc-getCC):g" \
- -e "s:@@CFLAGS@@:${CFLAGS}:g" \
- -e "s:@@AR@@:$(tc-getAR):g" \
- -e "s:@@RANLIB@@:$(tc-getRANLIB):g" \
- -e "s:@@ENCODING@@:${ENCODING}:g" \
- ${S}/Makefile.linux-gcc
+ -e "s:@@CC@@:$(tc-getCC):g" \
+ -e "s:@@CFLAGS@@:${CFLAGS}:g" \
+ -e "s:@@AR@@:$(tc-getAR):g" \
+ -e "s:@@RANLIB@@:$(tc-getRANLIB):g" \
+ -e "s:@@ENCODING@@:${ENCODING}:g" \
+ ${S}/Makefile.linux-gcc
}
src_compile() {
@@ -62,29 +62,33 @@ src_compile() {
myconf="${myconf} `use_enable nls utf8`"
if ! use tcltk; then
- myconf="${myconf} --without-tcl"
+ myconf="${myconf} --without-tcl"
fi
econf ${myconf} || die
emake all || die
if use doc; then
- emake doc || die
+ emake doc || die
fi
if use tcltk; then
- cp -P ${FILESDIR}/maketcllib.sh ${S}
- chmod +x ./maketcllib.sh
- ./maketcllib.sh
+ cp -P ${FILESDIR}/maketcllib.sh ${S}
+ chmod +x ./maketcllib.sh
+ ./maketcllib.sh
fi
}
src_test() {
- einfo "sqlite 2.x is known to have problems on 64 bit architectures"
- einfo "if you observe segmentation faults please use 3.x instead"
-
- cd ${S}
- emake test || die "some test failed"
+ if use tcltk ; then
+ if has userpriv ${FEATURES} ; then
+ einfo "sqlite 2.x is known to have problems on 64 bit architectures"
+ einfo "if you observe segmentation faults please use 3.x instead"
+
+ cd ${S}
+ emake test || die "some test failed"
+ fi
+ fi
}
src_install () {
@@ -98,13 +102,13 @@ src_install () {
doman sqlite.1
if use doc; then
- docinto html
- dohtml doc/*.html doc/*.txt doc/*.png
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
fi
if use tcltk; then
- mkdir ${D}/usr/$(get_libdir)/tclsqlite${PV}
- cp ${S}/tclsqlite.so ${D}/usr/$(get_libdir)/tclsqlite${PV}/
- cp ${S}/pkgIndex.tcl ${D}/usr/$(get_libdir)/tclsqlite${PV}/
+ mkdir ${D}/usr/$(get_libdir)/tclsqlite${PV}
+ cp ${S}/tclsqlite.so ${D}/usr/$(get_libdir)/tclsqlite${PV}/
+ cp ${S}/pkgIndex.tcl ${D}/usr/$(get_libdir)/tclsqlite${PV}/
fi
}