summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-02-22 11:28:13 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-02-22 11:28:13 +0000
commit80d9a0dbf9875ee5ed46b8115265a3fa6bffacb0 (patch)
tree4194816b48d840dd947ffc4c55bc3ec629768c71 /dev-db/slony1/files
parentRestricting pypy (diff)
downloadgentoo-2-80d9a0dbf9875ee5ed46b8115265a3fa6bffacb0.tar.gz
gentoo-2-80d9a0dbf9875ee5ed46b8115265a3fa6bffacb0.tar.bz2
gentoo-2-80d9a0dbf9875ee5ed46b8115265a3fa6bffacb0.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-db/slony1/files')
-rw-r--r--dev-db/slony1/files/slony1-2.1.1-ldflags.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-db/slony1/files/slony1-2.1.1-ldflags.patch b/dev-db/slony1/files/slony1-2.1.1-ldflags.patch
new file mode 100644
index 000000000000..35452ad3b852
--- /dev/null
+++ b/dev-db/slony1/files/slony1-2.1.1-ldflags.patch
@@ -0,0 +1,29 @@
+diff -Naur a/Makefile.global.in b/Makefile.global.in
+--- a/Makefile.global.in 2012-01-25 14:13:40.000000000 -0500
++++ b/Makefile.global.in 2012-02-22 06:14:05.240047000 -0500
+@@ -80,7 +80,7 @@
+ subdir=$(slony_subdir)
+
+ override CPPFLAGS := -I${pgincludeserverdir} -I${pgincludedir} $(CPPFLAGS)
+-LDFLAGS = -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
++override LDFLAGS += -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
+
+ ifeq ($(GCC), yes)
+ CFLAGS += -Wall -Wmissing-prototypes -Wmissing-declarations
+diff -Naur a/makefiles/Makefile.linux b/makefiles/Makefile.linux
+--- a/makefiles/Makefile.linux 2012-01-25 14:13:40.000000000 -0500
++++ b/makefiles/Makefile.linux 2012-02-22 06:15:45.652523000 -0500
+@@ -12,9 +12,9 @@
+ endif
+
+ %.so: %.o
+- $(CC) -shared -o $@ $<
++ $(CC) $(LDFLAGS) -shared -o $@ $<
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $<
+
+-sqlmansect = 7
+\ No newline at end of file
++sqlmansect = 7