summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:41:22 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:41:22 +0000
commitfdc729a74b40501107f06c5734ac4a149bb8cabb (patch)
treeeb768a374815865febf59df340f67e01b3b093ea /dev-db/libdbi-drivers
parentRedux a bit code complexity in latest ebuild. (diff)
downloadgentoo-2-fdc729a74b40501107f06c5734ac4a149bb8cabb.tar.gz
gentoo-2-fdc729a74b40501107f06c5734ac4a149bb8cabb.tar.bz2
gentoo-2-fdc729a74b40501107f06c5734ac4a149bb8cabb.zip
Cleanup the ebuild to be eapi4. Drop sqlite2 support to have saner sqlite way. Redux older versions. Stabilise latest on all arches as it emerged on my stable boxen without issue contrary the old stable. Keep old stable around just in case.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/libdbi-drivers')
-rw-r--r--dev-db/libdbi-drivers/ChangeLog14
-rw-r--r--dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff20
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild65
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r2.ebuild86
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r1.ebuild96
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild110
6 files changed, 57 insertions, 334 deletions
diff --git a/dev-db/libdbi-drivers/ChangeLog b/dev-db/libdbi-drivers/ChangeLog
index 11ad7f77862f..1e7210586ac8 100644
--- a/dev-db/libdbi-drivers/ChangeLog
+++ b/dev-db/libdbi-drivers/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/libdbi-drivers
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.51 2010/09/28 17:22:52 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.52 2012/09/13 18:41:22 scarabeus Exp $
+
+ 13 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/libdbi-drivers-0.8.1-oci8.diff, -libdbi-drivers-0.8.1-r1.ebuild,
+ -libdbi-drivers-0.8.1-r2.ebuild, -libdbi-drivers-0.8.3-r1.ebuild,
+ libdbi-drivers-0.8.3-r2.ebuild:
+ Cleanup the ebuild to be eapi4. Drop sqlite2 support to have saner sqlite way.
+ Redux older versions. Stabilise latest on all arches as it emerged on my
+ stable boxen without issue contrary the old stable. Keep old stable around
+ just in case.
*libdbi-drivers-0.8.3-r2 (28 Sep 2010)
@@ -222,4 +231,3 @@
libdbi-drivers-0.7.1.ebuild:
Initial commit. Original ebuild submitted by Max <m.e.bruche@lse.ac.uk>. Bug
#45153.
-
diff --git a/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff b/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff
deleted file mode 100644
index 23916d34cb79..000000000000
--- a/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff
+++ /dev/null
@@ -1,20 +0,0 @@
---- libdbi-drivers-0.8.1/drivers/oracle/dbd_oracle.c.orig 2005-08-31 23:44:53.000000000 +0200
-+++ libdbi-drivers-0.8.1/drivers/oracle/dbd_oracle.c 2006-05-30 13:10:48.000000000 +0200
-@@ -523,7 +523,7 @@
- unsigned int sizeattrib;
- dbi_data_t *data;
- char *ptr, *cols[result->numfields];
-- dword status;
-+ sword status;
-
- /*
- * Prefetch all cols as char *'s
-@@ -700,7 +700,7 @@
- }
-
- /* taken from sqlite3 driver */
--size_t dbd_quote_binary (dbi_conn_t *conn, const unsigned char *orig, size_t from_length, char **ptr_dest ) {
-+size_t dbd_quote_binary (dbi_conn_t *conn, const unsigned char *orig, size_t from_length, unsigned char **ptr_dest ) {
- unsigned char *temp;
- size_t len;
-
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild
deleted file mode 100644
index 0ee2f5913f1e..000000000000
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild,v 1.13 2010/09/28 17:22:52 robbat2 Exp $
-
-inherit eutils
-
-DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
-LICENSE="LGPL-2.1"
-DEPEND=">=dev-db/libdbi-0.8.0
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- sqlite? ( <dev-db/sqlite-3 )
- sqlite3? ( >=dev-db/sqlite-3 )
- firebird? ( dev-db/firebird )"
-
-IUSE="mysql postgres sqlite oci8 firebird sqlite3"
-KEYWORDS="amd64 hppa ppc ~sparc x86"
-SLOT=0
-
-src_unpack() {
- unpack ${A}
- EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/${P}-oci8.diff
-}
-
-src_compile() {
- local myconf=""
- local drivers=""
-# WARNING: the configure script does NOT work correctly
-# --without-$driver does NOT work
-# so do NOT use `use_with...`
- use mysql && drivers="${drivers} mysql" myconf="${myconf} --with-mysql"
- use postgres && drivers="${drivers} pgsql" myconf="${myconf} --with-pgsql"
- use sqlite && drivers="${drivers} sqlite" myconf="${myconf} --with-sqlite"
- use sqlite3 && drivers="${drivers} sqlite3" myconf="${myconf} --with-sqlite3"
- use firebird && drivers="${drivers} firebird" myconf="${myconf} --with-firebird"
- if use oci8; then
- if [ -z "${ORACLE_HOME}" ]; then
- die "\$ORACLE_HOME is not set!"
- fi
- myconf="${myconf} --with-oracle-dir=${ORACLE_HOME} --with-oracle" drivers="${drivers} oracle"
- fi
-# safety check
- if [ -z "${drivers}" ]; then
- die "You have not specified any supported databases in your use flags (mysql, pgsql, sqlite, sqlite3, oracle, firebird)"
- fi
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README README.osx TODO
-}
-src_test() {
- if [ -z "${WANT_INTERACTIVE_TESTS}" ]; then
- ewarn "Tests disabled due to interactivity."
- ewarn "Run with WANT_INTERACTIVE_TESTS=1 if you want them."
- return 0
- fi
- einfo "Running interactive tests"
- emake check || die "Tests failed"
-}
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r2.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r2.ebuild
deleted file mode 100644
index 4c5164cdf005..000000000000
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r2.ebuild,v 1.9 2010/09/28 17:22:52 robbat2 Exp $
-
-inherit eutils
-
-DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
-LICENSE="LGPL-2.1"
-DEPEND=">=dev-db/libdbi-0.8.0
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- sqlite? ( <dev-db/sqlite-3 )
- sqlite3? ( >=dev-db/sqlite-3 )
- !bindist? ( firebird? ( dev-db/firebird ) )"
-
-IUSE="mysql postgres sqlite oci8 firebird sqlite3 bindist"
-KEYWORDS="amd64 hppa ppc sparc x86"
-SLOT=0
-
-src_unpack() {
- unpack ${A}
- EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/${P}-oci8.diff
-}
-
-pkg_setup() {
- local drivers=""
- use mysql && drivers="${drivers} mysql"
- use postgres && drivers="${drivers} pgsql"
- use sqlite && drivers="${drivers} sqlite"
- use sqlite3 && drivers="${drivers} sqlite3"
- if use firebird; then
- if use bindist; then
- eerror "The Interbase Public License is incompatible with LGPL, see bug #200284."
- eerror "Disabling firebird in the build"
- else
- drivers="${drivers} firebird"
- fi
- fi
- if use oci8; then
- if [ -z "${ORACLE_HOME}" ]; then
- die "\$ORACLE_HOME is not set!"
- fi
- drivers="${drivers} oracle"
- fi
- # safety check
- if [ -z "${drivers// /}" ]; then
- die "No supported databases in your USE flags! (mysql, postgres, sqlite, sqlite3, oracle, firebird)"
- fi
-}
-
-src_compile() {
- local myconf=""
- # WARNING: the configure script does NOT work correctly
- # --without-$driver does NOT work
- # so do NOT use `use_with...`
- use mysql && myconf="${myconf} --with-mysql"
- use postgres && myconf="${myconf} --with-pgsql"
- use sqlite && myconf="${myconf} --with-sqlite"
- use sqlite3 && myconf="${myconf} --with-sqlite3"
- use !bindist && use firebird && myconf="${myconf} --with-firebird"
- if use oci8; then
- if [ -z "${ORACLE_HOME}" ]; then
- die "\$ORACLE_HOME is not set!"
- fi
- myconf="${myconf} --with-oracle-dir=${ORACLE_HOME} --with-oracle"
- fi
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README README.osx TODO
-}
-src_test() {
- if [ -z "${WANT_INTERACTIVE_TESTS}" ]; then
- ewarn "Tests disabled due to interactivity."
- ewarn "Run with WANT_INTERACTIVE_TESTS=1 if you want them."
- return 0
- fi
- einfo "Running interactive tests"
- emake check || die "Tests failed"
-}
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r1.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r1.ebuild
deleted file mode 100644
index 3eb40f4a316e..000000000000
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r1.ebuild,v 1.3 2010/09/28 17:22:52 robbat2 Exp $
-
-EAPI=1
-inherit eutils autotools
-
-MY_PV="${PV}-1"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
-LICENSE="LGPL-2.1"
-DEPEND=">=dev-db/libdbi-0.8.3
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- sqlite? ( <dev-db/sqlite-3 )
- sqlite3? ( >=dev-db/sqlite-3 )
- !bindist? ( firebird? ( dev-db/firebird ) )
- doc? ( app-text/openjade )"
-
-IUSE="mysql postgres sqlite oci8 firebird +sqlite3 bindist doc"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-SLOT=0
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-0.8.3-doc-build-fix.patch
- epatch "${FILESDIR}"/${PN}-0.8.3-oracle-build-fix.patch
- epatch "${FILESDIR}"/${PN}-0.8.3-firebird-fix.patch
- cd "${S}"
- eautoreconf
-}
-
-pkg_setup() {
- local drivers=""
- use mysql && drivers="${drivers} mysql"
- use postgres && drivers="${drivers} pgsql"
- use sqlite && drivers="${drivers} sqlite"
- use sqlite3 && drivers="${drivers} sqlite3"
- if use firebird; then
- if use bindist; then
- eerror "The Interbase Public License is incompatible with LGPL, see bug #200284."
- eerror "Disabling firebird in the build"
- else
- drivers="${drivers} firebird"
- fi
- fi
- if use oci8; then
- if [ -z "${ORACLE_HOME}" ]; then
- die "\$ORACLE_HOME is not set!"
- fi
- drivers="${drivers} oracle"
- fi
- # safety check
- if [ -z "${drivers// /}" ]; then
- die "No supported databases in your USE flags! (mysql, postgres, sqlite, sqlite3, oracle, firebird)"
- fi
-}
-
-src_compile() {
- local myconf=""
- # WARNING: the configure script does NOT work correctly
- # --without-$driver does NOT work
- # so do NOT use `use_with...`
- use mysql && myconf="${myconf} --with-mysql"
- use postgres && myconf="${myconf} --with-pgsql"
- use sqlite && myconf="${myconf} --with-sqlite"
- use sqlite3 && myconf="${myconf} --with-sqlite3"
- use !bindist && use firebird && myconf="${myconf} --with-firebird"
- if use oci8; then
- if [ -z "${ORACLE_HOME}" ]; then
- die "\$ORACLE_HOME is not set!"
- fi
- myconf="${myconf} --with-oracle-dir=${ORACLE_HOME} --with-oracle"
- fi
-
- econf $(use_enable doc docs) ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README README.osx TODO
-}
-src_test() {
- if [ -z "${WANT_INTERACTIVE_TESTS}" ]; then
- ewarn "Tests disabled due to interactivity."
- ewarn "Run with WANT_INTERACTIVE_TESTS=1 if you want them."
- return 0
- fi
- einfo "Running interactive tests"
- emake check || die "Tests failed"
-}
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
index 46e66d36f775..526303032482 100644
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
@@ -1,97 +1,79 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild,v 1.1 2010/09/28 17:22:52 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild,v 1.2 2012/09/13 18:41:22 scarabeus Exp $
+
+EAPI=4
-EAPI=1
inherit eutils autotools
-MY_PV="${PV}-1"
-MY_P="${PN}-${MY_PV}"
+MY_P="${P}-1"
DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
LICENSE="LGPL-2.1"
-RDEPEND=">=dev-db/libdbi-0.8.3
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- sqlite? ( <dev-db/sqlite-3 )
- sqlite3? ( >=dev-db/sqlite-3 )
- !bindist? ( firebird? ( dev-db/firebird ) )"
-DEPEND="${RDEPEND}
- doc? ( app-text/openjade )"
-IUSE="mysql postgres sqlite oci8 firebird +sqlite3 bindist doc"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bindist doc firebird mysql oci8 postgres +sqlite"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
SLOT=0
+
+RDEPEND="
+ >=dev-db/libdbi-0.8.3
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-text/openjade )
+"
+
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-0.8.3-doc-build-fix.patch
- epatch "${FILESDIR}"/${PN}-0.8.3-oracle-build-fix.patch
- epatch "${FILESDIR}"/${PN}-0.8.3-firebird-fix.patch
- cd "${S}"
- eautoreconf
-}
+REQUIRED_USE="
+ firebird? ( !bindist )
+ || ( mysql postgres sqlite firebird oci8 )
+"
+
+DOCS="AUTHORS ChangeLog NEWS README README.osx TODO"
pkg_setup() {
- local drivers=""
- use mysql && drivers="${drivers} mysql"
- use postgres && drivers="${drivers} pgsql"
- use sqlite && drivers="${drivers} sqlite"
- use sqlite3 && drivers="${drivers} sqlite3"
- if use firebird; then
- if use bindist; then
- eerror "The Interbase Public License is incompatible with LGPL, see bug #200284."
- eerror "Disabling firebird in the build"
- else
- drivers="${drivers} firebird"
- fi
- fi
- if use oci8; then
- if [ -z "${ORACLE_HOME}" ]; then
- die "\$ORACLE_HOME is not set!"
- fi
- drivers="${drivers} oracle"
- fi
- # safety check
- if [ -z "${drivers// /}" ]; then
- die "No supported databases in your USE flags! (mysql, postgres, sqlite, sqlite3, oracle, firebird)"
- fi
+ use oci8 && [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
}
-src_compile() {
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.8.3-doc-build-fix.patch \
+ "${FILESDIR}"/${PN}-0.8.3-oracle-build-fix.patch \
+ "${FILESDIR}"/${PN}-0.8.3-firebird-fix.patch
+ eautoreconf
+}
+
+src_configure() {
local myconf=""
# WARNING: the configure script does NOT work correctly
# --without-$driver does NOT work
# so do NOT use `use_with...`
- use mysql && myconf="${myconf} --with-mysql"
- use postgres && myconf="${myconf} --with-pgsql"
- use sqlite && myconf="${myconf} --with-sqlite"
- use sqlite3 && myconf="${myconf} --with-sqlite3"
- use !bindist && use firebird && myconf="${myconf} --with-firebird"
+ use mysql && myconf+=" --with-mysql"
+ use postgres && myconf+=" --with-pgsql"
+ use sqlite && myconf+=" --with-sqlite3"
+ use firebird && myconf+=" --with-firebird"
if use oci8; then
- if [ -z "${ORACLE_HOME}" ]; then
- die "\$ORACLE_HOME is not set!"
- fi
- myconf="${myconf} --with-oracle-dir=${ORACLE_HOME} --with-oracle"
+ [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
+ myconf+=" --with-oracle-dir=${ORACLE_HOME} --with-oracle"
fi
- econf $(use_enable doc docs) ${myconf} || die "econf failed"
- emake || die "emake failed"
+ econf \
+ $(use_enable doc docs) \
+ ${myconf}
}
-src_install () {
- emake install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README README.osx TODO
-}
src_test() {
- if [ -z "${WANT_INTERACTIVE_TESTS}" ]; then
+ if [[ -z "${WANT_INTERACTIVE_TESTS}" ]]; then
ewarn "Tests disabled due to interactivity."
ewarn "Run with WANT_INTERACTIVE_TESTS=1 if you want them."
return 0
fi
einfo "Running interactive tests"
- emake check || die "Tests failed"
+ emake check
}