summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-18 14:04:12 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-18 14:04:12 +0000
commitb29c7da231990be21eb6c88ae470401fc8cef144 (patch)
tree21c81ded19fed24404f7a3419a870f42e7fe645a /dev-db/henplus
parentChangeLog fixes (Manifest recommit) (diff)
downloadgentoo-2-b29c7da231990be21eb6c88ae470401fc8cef144.tar.gz
gentoo-2-b29c7da231990be21eb6c88ae470401fc8cef144.tar.bz2
gentoo-2-b29c7da231990be21eb6c88ae470401fc8cef144.zip
install wrapper script, closes 40197
Diffstat (limited to 'dev-db/henplus')
-rw-r--r--dev-db/henplus/ChangeLog7
-rw-r--r--dev-db/henplus/Manifest5
-rw-r--r--dev-db/henplus/files/digest-henplus-0.9.5-r11
-rw-r--r--dev-db/henplus/files/henplus.patch33
-rw-r--r--dev-db/henplus/henplus-0.9.5-r1.ebuild40
5 files changed, 84 insertions, 2 deletions
diff --git a/dev-db/henplus/ChangeLog b/dev-db/henplus/ChangeLog
index 2d8f106e876c..144a5ab2561d 100644
--- a/dev-db/henplus/ChangeLog
+++ b/dev-db/henplus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/henplus
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.3 2004/06/24 21:54:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.4 2004/07/18 14:04:12 axxo Exp $
+
+*henplus-0.9.5-r1 (18 Jul 2004)
+
+ 18 Jul 2004; Thomas Matthijs <axxo@gentoo.org> +henplus-0.9.5-r1.ebuild:
+ install wrapper bin script
*henplus-0.9.5 (16 Feb 2004)
diff --git a/dev-db/henplus/Manifest b/dev-db/henplus/Manifest
index c965525fb368..dbb89ea1aa30 100644
--- a/dev-db/henplus/Manifest
+++ b/dev-db/henplus/Manifest
@@ -1,4 +1,7 @@
+MD5 912a239c1c6a4205ac096237a1d1b466 henplus-0.9.5-r1.ebuild 1160
MD5 e78f4c5229de020da1601d3e936aab1c henplus-0.9.5.ebuild 1054
-MD5 deb3bb02206df26597ac8b8eb8d8d5ba ChangeLog 383
+MD5 2a3129b134b06810bbf5e4613d394b4e ChangeLog 521
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 8bb4e9e0346231c15f8fcd9b836ce86e files/henplus.patch 1003
MD5 cde5d89f324a87299196a42dfffaf617 files/digest-henplus-0.9.5 65
+MD5 cde5d89f324a87299196a42dfffaf617 files/digest-henplus-0.9.5-r1 65
diff --git a/dev-db/henplus/files/digest-henplus-0.9.5-r1 b/dev-db/henplus/files/digest-henplus-0.9.5-r1
new file mode 100644
index 000000000000..7db26f4124e9
--- /dev/null
+++ b/dev-db/henplus/files/digest-henplus-0.9.5-r1
@@ -0,0 +1 @@
+MD5 135e00fddd80ec0cf903171760c02a1b henplus-0.9.5.tar.gz 106161
diff --git a/dev-db/henplus/files/henplus.patch b/dev-db/henplus/files/henplus.patch
new file mode 100644
index 000000000000..4c6fa7038f45
--- /dev/null
+++ b/dev-db/henplus/files/henplus.patch
@@ -0,0 +1,33 @@
+--- bin/henplus 2004-02-02 14:53:28.000000000 +0100
++++ bin/henplus 2004-07-18 15:56:40.061422352 +0200
+@@ -13,20 +13,9 @@
+ JAVA=$JAVA_HOME/bin/java
+ fi
+
+-##------------------
+-THISDIR=`dirname $0`
+-HENPLUSDIR=$THISDIR/../share/henplus
+-
+-# not yet installed ? Then look in the build directory
+-if [ ! -d "$HENPLUSDIR" ] ; then
+- HENPLUSDIR=$THISDIR/../build
+-fi
++HENPLUSDIR=$(dirname $(java-config -p henplus))
+
+-# location of the readline lib.
+-# Modify this, if you installation stores this at a different
+-# position.
+-LD_LIBRARY_PATH=$THISDIR/../lib:/usr/lib/jni:$LD_LIBRARY_PATH
+-CLASSPATH=$CLASSPATH:$THISDIR/../share/java/libreadline-java.jar
++CLASSPATH=$CLASSPATH:$(java-config -p libreadline-java)
+
+ # you may just throw your own jar files in this dir.
+ # (like additional JDBC-drivers, that are not in default
+@@ -66,6 +55,4 @@
+ fi
+ done
+
+-export CLASSPATH LD_LIBRARY_PATH
+-
+-exec $JAVA $JAVA_FLAGS henplus.HenPlus "$@"
++exec $JAVA -cp $CLASSPATH $JAVA_FLAGS henplus.HenPlus "$@"
diff --git a/dev-db/henplus/henplus-0.9.5-r1.ebuild b/dev-db/henplus/henplus-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..50ba3672a6c7
--- /dev/null
+++ b/dev-db/henplus/henplus-0.9.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/henplus-0.9.5-r1.ebuild,v 1.1 2004/07/18 14:04:12 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="HenPlus is a SQL shell that can handle multiple sessions in parallel. The commandline interface with the usual history functions features TAB-completion for commands, tables and columns. Database connect via JDBC."
+HOMEPAGE="http://www.sourceforge.net/projects/henplus"
+SRC_URI="mirror://sourceforge/henplus/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="jikes"
+
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4.1
+ dev-java/libreadline-java
+ jikes? ( >=dev-java/jikes-1.17 )"
+
+RDEPEND=">=virtual/jdk-1.3"
+
+src_unpack() {
+ base_src_unpack && cd ${S}
+ epatch ${FILESDIR}/henplus.patch
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ export CLASSPATH="$CLASSPATH:`java-config --classpath=libreadline-java`"
+
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ java-pkg_dojar build/*.jar
+ dodoc README
+ dobin bin/henplus
+}
+