summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-29 20:50:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-29 20:50:21 +0000
commit07998cff2c62e74876658e5540d89bdc4f25f25f (patch)
tree4a7960bfdd376c81c766f37140285d71374d6b2a /dev-cpp
parentDelete older ebuilds. (diff)
downloadgentoo-2-07998cff2c62e74876658e5540d89bdc4f25f25f.tar.gz
gentoo-2-07998cff2c62e74876658e5540d89bdc4f25f25f.tar.bz2
gentoo-2-07998cff2c62e74876658e5540d89bdc4f25f25f.zip
Set SUPPORT_PYTHON_ABIS (bug #312131).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gflags/ChangeLog8
-rw-r--r--dev-cpp/gflags/gflags-1.2.ebuild32
2 files changed, 25 insertions, 15 deletions
diff --git a/dev-cpp/gflags/ChangeLog b/dev-cpp/gflags/ChangeLog
index d37013586146..f71ebe638704 100644
--- a/dev-cpp/gflags/ChangeLog
+++ b/dev-cpp/gflags/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/gflags
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.7 2009/09/14 10:58:50 dev-zero Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.8 2010/05/29 20:50:21 arfrever Exp $
+
+ 29 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ gflags-1.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #312131).
*gflags-1.2 (14 Sep 2009)
diff --git a/dev-cpp/gflags/gflags-1.2.ebuild b/dev-cpp/gflags/gflags-1.2.ebuild
index e8696aeb0855..ebd26fe4f380 100644
--- a/dev-cpp/gflags/gflags-1.2.ebuild
+++ b/dev-cpp/gflags/gflags-1.2.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-1.2.ebuild,v 1.1 2009/09/14 10:58:50 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-1.2.ebuild,v 1.2 2010/05/29 20:50:21 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
-inherit python
+inherit distutils
DESCRIPTION="Google's C++ argument parsing library with python extensions."
HOMEPAGE="http://code.google.com/p/google-gflags/"
@@ -14,16 +16,18 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="python"
-DEPEND="python? ( dev-lang/python )"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="gflags.py"
src_compile() {
default
if use python; then
cd python
- python_version
- "${python}" setup.py build || die "python build failed"
+ distutils_src_compile
fi
}
@@ -36,16 +40,18 @@ src_install() {
if use python; then
cd python
- python_version
- "${python}" setup.py install --root="${D}" --no-compile || die "python install failed"
- python_need_rebuild
+ distutils_src_install
fi
}
pkg_postinst() {
- python_mod_optimize
+ if use python; then
+ distutils_pkg_postinst
+ fi
}
pkg_postrm() {
- python_mod_cleanup
+ if use python; then
+ distutils_pkg_postrm
+ fi
}