summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2009-05-08 09:09:04 +0000
committerIlya Volynets <iluxa@gentoo.org>2009-05-08 09:09:04 +0000
commit2c00ee0ed8b1afc5cfaf5719355bf687e181c222 (patch)
treefa226305898f2cbe6e0f041a79340a88163bb1f8 /dev-cpp/sptk
parentOpenOffice.org 3.1.0. All the language packs and amd64-support are back (diff)
downloadgentoo-2-2c00ee0ed8b1afc5cfaf5719355bf687e181c222.tar.gz
gentoo-2-2c00ee0ed8b1afc5cfaf5719355bf687e181c222.tar.bz2
gentoo-2-2c00ee0ed8b1afc5cfaf5719355bf687e181c222.zip
Switch SPTK over to cmake-utils eclass
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/sptk')
-rw-r--r--dev-cpp/sptk/ChangeLog6
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.10.ebuild43
2 files changed, 21 insertions, 28 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 08be0b98b105..3509805392e4 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.56 2009/04/25 12:35:22 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.57 2009/05/08 09:09:04 iluxa Exp $
+
+ 08 May 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ sptk-3.5.8.10.ebuild:
+ Switch over to cmake-utils eclass
25 Apr 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
sptk-3.5.8.10.ebuild:
diff --git a/dev-cpp/sptk/sptk-3.5.8.10.ebuild b/dev-cpp/sptk/sptk-3.5.8.10.ebuild
index de408b0ff315..047c71bb4e5a 100644
--- a/dev-cpp/sptk/sptk-3.5.8.10.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.8.10.ebuild
@@ -1,10 +1,10 @@
# Copyright 2006-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.10.ebuild,v 1.5 2009/04/25 12:35:22 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.10.ebuild,v 1.6 2009/05/08 09:09:04 iluxa Exp $
EAPI=1
-inherit eutils flag-o-matic multilib
+inherit multilib cmake-utils
IUSE="fltk odbc doc sqlite excel postgres aspell mysql"
@@ -24,35 +24,25 @@ RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
aspell? ( >=app-text/aspell-0.50 )"
DEPEND="${RDEPEND}
- dev-util/cmake
doc? ( app-doc/doxygen )"
-sptk_use_enable() {
- if use ${1}; then
- SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
- else
- SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-}
+CMAKE_IN_SOURCE_BUILD=1
src_compile() {
- sptk_use_enable postgres POSTGRESQL
- sptk_use_enable mysql MYSQL
- sptk_use_enable sqlite SQLITE3
- sptk_use_enable odbc ODBC
- sptk_use_enable aspell ASPELL
- sptk_use_enable fltk FLTK
- sptk_use_enable excel EXCEL
+ local mycmakeargs="$(cmake-utils_use_no postgres POSTGRESQL)
+ $(cmake-utils_use_no mysql MYSQL)
+ $(cmake-utils_use_no sqlite SQLITE3)
+ $(cmake-utils_use_no odbc ODBC)
+ $(cmake-utils_use_no aspell ASPELL)
+ $(cmake-utils_use_no fltk FLTK)
+ $(cmake-utils_use_no excel EXCEL)"
- cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} -DNO_EXAMPLES:BOOLEAN=TRUE . || die "Configuration Failed"
+ mycmakeargs="${mycmakeargs} -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} -DNO_EXAMPLES:BOOLEAN=TRUE"
+ einfo "mycmakeargs=${mycmakeargs}"
- emake || die "Parallel Make Failed"
+ cmake-utils_src_configure
+ cmake-utils_src_compile
if use doc; then
cd "${S}"
einfo "Fixing sptk3.doxygen"
@@ -65,9 +55,8 @@ src_compile() {
src_install () {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc README AUTHORS
+ DOCS="README AUTHORS"
+ cmake-utils_src_install
dodir /usr/share/doc/${PF}
cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}