summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-18 15:28:10 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-18 15:28:10 +0000
commit8d8c27e18149506df47433cd07b8dbf94e64aac1 (patch)
treed1f445fe546a911278e1524e4e5a7b781ccd86ff /app-text
parentChanged econf||die to econf (diff)
downloadgentoo-2-8d8c27e18149506df47433cd07b8dbf94e64aac1.tar.gz
gentoo-2-8d8c27e18149506df47433cd07b8dbf94e64aac1.tar.bz2
gentoo-2-8d8c27e18149506df47433cd07b8dbf94e64aac1.zip
Changed unpack||die to unpack
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostscript/ghostscript-7.05.3-r1.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/app-text/ghostscript/ghostscript-7.05.3-r1.ebuild b/app-text/ghostscript/ghostscript-7.05.3-r1.ebuild
index fb186413f82a..152b9d7acc96 100644
--- a/app-text/ghostscript/ghostscript-7.05.3-r1.ebuild
+++ b/app-text/ghostscript/ghostscript-7.05.3-r1.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.05.3-r1.ebuild,v 1.8 2002/12/09 04:17:44 manson Exp $
-
-IUSE="X cups"
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.05.3-r1.ebuild,v 1.9 2002/12/18 15:28:10 vapier Exp $
S=${WORKDIR}/espgs-${PV}
DESCRIPTION="ESP Ghostscript -- an enhanced version of GNU Ghostscript with better printer support"
SRC_URI="ftp://ftp.easysw.com/pub/ghostscript/espgs-${PV}-source.tar.bz2
-ftp://ftp.easysw.com/pub/ghostscript/gnu-gs-fonts-std-6.0.tar.gz
-ftp://ftp.easysw.com/pub/ghostscript/gnu-gs-fonts-other-6.0.tar.gz
-http://lxm3200.sourceforge.net/lxm3200-0.4.1-gs5.50-src.tar.gz"
+ ftp://ftp.easysw.com/pub/ghostscript/gnu-gs-fonts-std-6.0.tar.gz
+ ftp://ftp.easysw.com/pub/ghostscript/gnu-gs-fonts-other-6.0.tar.gz
+ http://lxm3200.sourceforge.net/lxm3200-0.4.1-gs5.50-src.tar.gz"
HOMEPAGE="http://www.easysw.com/"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="x86 ppc sparc "
+IUSE="X cups"
DEPEND=">=media-libs/jpeg-6b
>=media-libs/libpng-1.2.1
@@ -22,35 +21,29 @@ DEPEND=">=media-libs/jpeg-6b
X? ( virtual/x11 )"
src_unpack() {
- unpack espgs-${PV}-source.tar.bz2 || die
- unpack gnu-gs-fonts-std-6.0.tar.gz || die
- unpack gnu-gs-fonts-other-6.0.tar.gz || die
- unpack lxm3200-0.4.1-gs5.50-src.tar.gz || die
+ unpack espgs-${PV}-source.tar.bz2
+ unpack gnu-gs-fonts-std-6.0.tar.gz
+ unpack gnu-gs-fonts-other-6.0.tar.gz
+ unpack lxm3200-0.4.1-gs5.50-src.tar.gz
cat ${FILESDIR}/lxm3200-cups.diff | patch -p1 -d ${S} || die "lxm3200 patch failed"
cp ${WORKDIR}/lxm3200-0.4.1-gs5.50-src/gdevlx32.c ${S}/src/ || die
# Brother HL-12XX support
cp ${FILESDIR}/gs7.05-gdevhl12.c ${S}/src/gdevhl12.c || die
mv ${S}/src/Makefile.in ${S}/src/Makefile.in.orig
sed 's#^\(DEVICE_DEVS6=.*\)$#\1 $(DD)hl1240.dev $(DD)hl1250.dev#' \
- < ${S}/src/Makefile.in.orig \
- > ${S}/src/Makefile.in \
- || die
+ ${S}/src/Makefile.in.orig > ${S}/src/Makefile.in || die
}
src_compile() {
use X && myconf="--with-x" || myconf="--without-x"
use cups && myconf="${myconf} --enable-cups" || myconf="${myconf} --disable-cups"
- econf \
- --with-gimp-print \
- ${myconf} || die "./configure failed"
-
+ econf --with-gimp-print ${myconf}
make || die "make failed"
}
src_install() {
- einstall \
- install_prefix=${D} || die "make install failed"
+ einstall install_prefix=${D}
cd ${WORKDIR}
cp -a fonts ${D}/usr/share/ghostscript || die