summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 16:35:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 16:35:09 +0000
commit66c141aa95565eff23997d2a6572c4f3b9d24888 (patch)
tree697554fc2a672be3f2a6a97d95adff7908c79c45 /app-text
parentVersion bumped. No longer exclude /etc/udev/rules.d from config_protect. (diff)
downloadgentoo-2-66c141aa95565eff23997d2a6572c4f3b9d24888.tar.gz
gentoo-2-66c141aa95565eff23997d2a6572c4f3b9d24888.tar.bz2
gentoo-2-66c141aa95565eff23997d2a6572c4f3b9d24888.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14926-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pytextile/ChangeLog8
-rw-r--r--app-text/pytextile/pytextile-2.1.4.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/app-text/pytextile/ChangeLog b/app-text/pytextile/ChangeLog
index effc2abe9922..41218e18df9a 100644
--- a/app-text/pytextile/ChangeLog
+++ b/app-text/pytextile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pytextile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.18 2009/04/03 18:48:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.19 2009/12/05 16:35:09 arfrever Exp $
+
+*pytextile-2.1.4 (05 Dec 2009)
+
+ 05 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pytextile-2.1.4.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*pytextile-2.1.3 (03 Apr 2009)
diff --git a/app-text/pytextile/pytextile-2.1.4.ebuild b/app-text/pytextile/pytextile-2.1.4.ebuild
new file mode 100644
index 000000000000..370a7dc4b815
--- /dev/null
+++ b/app-text/pytextile/pytextile-2.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/pytextile-2.1.4.ebuild,v 1.1 2009/12/05 16:35:09 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+NEED_PYTHON="2.5"
+
+inherit distutils
+
+MY_PN="textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python implementation of Textile, Dean Allen's Human Text Generator. Textile simplifies the work of creating (X)HTML."
+HOMEPAGE="http://pypi.python.org/pypi/textile"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}