summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-04-05 20:55:52 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-04-05 20:55:52 +0000
commit31fb9de6ba89f3948be028328d05610981894fa4 (patch)
tree261a1382544feb75f07e009edcf1b1bd1d28544a /app-text
parentEAPI 5 bump wrt bug 543906.L (diff)
downloadgentoo-2-31fb9de6ba89f3948be028328d05610981894fa4.tar.gz
gentoo-2-31fb9de6ba89f3948be028328d05610981894fa4.tar.bz2
gentoo-2-31fb9de6ba89f3948be028328d05610981894fa4.zip
EAPI 5 bump wrt bug 543906.
Signed-off-by: monsieurp@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/jing/ChangeLog10
-rw-r--r--app-text/jing/jing-20091111-r2.ebuild83
2 files changed, 90 insertions, 3 deletions
diff --git a/app-text/jing/ChangeLog b/app-text/jing/ChangeLog
index c748f650c672..351d23ceb2d0 100644
--- a/app-text/jing/ChangeLog
+++ b/app-text/jing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/jing
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/jing/ChangeLog,v 1.28 2014/08/03 07:23:12 sera Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/jing/ChangeLog,v 1.29 2015/04/05 20:55:52 monsieurp Exp $
+
+*jing-20091111-r2 (05 Apr 2015)
+
+ 05 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +jing-20091111-r2.ebuild:
+ EAPI 5 bump wrt bug 543906.
03 Aug 2014; Ralph Sennhauser <sera@gentoo.org> -jing-20030619-r3.ebuild:
Remove old
@@ -107,4 +112,3 @@
13 May 2004; <mkennedy@gentoo.org> +metadata.xml, +jing-20030619.ebuild:
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
-
diff --git a/app-text/jing/jing-20091111-r2.ebuild b/app-text/jing/jing-20091111-r2.ebuild
new file mode 100644
index 000000000000..7ad3d918e70f
--- /dev/null
+++ b/app-text/jing/jing-20091111-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/jing/jing-20091111-r2.ebuild,v 1.1 2015/04/05 20:55:52 monsieurp Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jing: A RELAX NG validator in Java"
+HOMEPAGE="http://thaiopensource.com/relaxng/jing.html"
+SRC_URI="http://jing-trang.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-java/ant-core:0
+ dev-java/iso-relax:0
+ dev-java/relaxng-datatype:0
+ dev-java/saxon:9
+ dev-java/xalan:0
+ dev-java/xerces:2
+ dev-java/xml-commons-resolver:0"
+RDEPEND="${COMMON_DEPEND}
+ >=virtual/jre-1.5"
+DEPEND="${COMMON_DEPEND}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+# Avoid bogous QA warning, no usable build.xml. The one that exists belongs to
+# the examples.
+S="${WORKDIR}/${P}/src"
+
+src_unpack() {
+ default
+
+ mkdir -p "${S}" || die
+ pushd "${S}" >/dev/null || die
+ unpack ./../src.zip
+ popd >/dev/null
+
+ # get the resourses from prebuilt jar
+ # http://code.google.com/p/jing-trang/issues/detail?id=84
+ mkdir -p "${S}"/target/classes || die
+ pushd "${S}"/target/classes >/dev/null || die
+ unpack ./../../../bin/${PN}.jar
+ find -name '*.class' -exec rm {} + || die
+ popd >/dev/null
+}
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.jar' -exec rm -v {} + || die
+
+ #remove bundled relaxng-datatype
+ rm -rv org || die
+
+ # for use with saxon:6.5
+ rm -v com/thaiopensource/validate/schematron/OldSaxonSchemaReaderFactory.java || die
+ sed -i -e '/OldSaxonSchemaReaderFactory/d' \
+ target/classes/META-INF/services/com.thaiopensource.validate.SchemaReaderFactory || die
+}
+
+JAVA_GENTOO_CLASSPATH="ant-core,iso-relax,relaxng-datatype,saxon-9,xalan,xerces-2,xml-commons-resolver"
+
+#src_test() {
+# # would need some test files could probably take this from the gcj version
+# #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.TestDriver || die
+# #java -cp ${cp} com.thaiopensource.datatype.relaxng.util.TestDriver || die
+# #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.CategoryTest \
+# # || die
+#}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${PN} --main com.thaiopensource.relaxng.util.Driver
+
+ use doc && dohtml ../doc/*html
+ use examples && java-pkg_doexamples ../sample
+}