summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2008-07-18 22:32:16 +0000
committerSerkan Kaba <serkan@gentoo.org>2008-07-18 22:32:16 +0000
commit15462c8b3e9f3c4c1da77f5842038ed72ba4d7c1 (patch)
tree183cd72de628e5e8fbc1412d42ea1e6d5fb54ad5 /app-text/zpspell
parentInitial addition. Ebuild and Java code written by me. (diff)
downloadgentoo-2-15462c8b3e9f3c4c1da77f5842038ed72ba4d7c1.tar.gz
gentoo-2-15462c8b3e9f3c4c1da77f5842038ed72ba4d7c1.tar.bz2
gentoo-2-15462c8b3e9f3c4c1da77f5842038ed72ba4d7c1.zip
Initial ebuild. Fixes bug #156099.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 x86_64)
Diffstat (limited to 'app-text/zpspell')
-rw-r--r--app-text/zpspell/ChangeLog10
-rw-r--r--app-text/zpspell/Manifest5
-rw-r--r--app-text/zpspell/files/gcc-4.3.patch11
-rw-r--r--app-text/zpspell/metadata.xml10
-rw-r--r--app-text/zpspell/zpspell-0.4.1.ebuild31
5 files changed, 67 insertions, 0 deletions
diff --git a/app-text/zpspell/ChangeLog b/app-text/zpspell/ChangeLog
new file mode 100644
index 000000000000..eed272e73e23
--- /dev/null
+++ b/app-text/zpspell/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/zpspell
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/zpspell/ChangeLog,v 1.1 2008/07/18 22:32:15 serkan Exp $
+
+*zpspell-0.4.1 (18 Jul 2008)
+
+ 18 Jul 2008; Serkan Kaba <serkan@gentoo.org> +files/gcc-4.3.patch,
+ +metadata.xml, +zpspell-0.4.1.ebuild:
+ Initial ebuild. Fixes bug #156099.
+
diff --git a/app-text/zpspell/Manifest b/app-text/zpspell/Manifest
new file mode 100644
index 000000000000..04a25d287431
--- /dev/null
+++ b/app-text/zpspell/Manifest
@@ -0,0 +1,5 @@
+AUX gcc-4.3.patch 320 RMD160 59ad84c8e9815345cca4d75e9b48eb5b97648974 SHA1 1fdb0c158633982cd632796e4445a75a4a4d68c2 SHA256 ea0b2a14a5014d6e0c23de3f2276e9f703507500a6a1383764a9efca2ca682ff
+DIST zpspell-0.4.1.tar.bz2 10408 RMD160 6634f674df13d0b17564a982927523872f4afdc0 SHA1 91a52fa492c49697331748627e88ef068380a488 SHA256 b87e1b7c4f43af40cc90e05bef2f4f680e849f1f156167d93284281c9226a196
+EBUILD zpspell-0.4.1.ebuild 713 RMD160 f8af7851690de8497d6406edca6e909cc1dd9ae3 SHA1 dd2f97d874d553d7007a495b68ef7765050aa03a SHA256 20396112e8b9ed2665ef0161f85b2710186aebcaebfcc4a86301de1a55e4a2f7
+MISC ChangeLog 294 RMD160 9c475bad9795ee142c647639718bcd48e576b7fd SHA1 414f00bf9bf234c34ca2e1fd5046052da92c5626 SHA256 ea17ee50d12cdd83d45e23ec65bbc1042ec15c0a5231d9592085f86a5cd08442
+MISC metadata.xml 292 RMD160 6e2715b1e46eec24c66e8f750f7edf8cc3cb7962 SHA1 c7db2fb6d6a9ba34d3c3b6166f5c60bca70cd7f3 SHA256 fcb84d92a48c8e66792c10f87ce8158fab173a768d18a56b333d089693acc8ec
diff --git a/app-text/zpspell/files/gcc-4.3.patch b/app-text/zpspell/files/gcc-4.3.patch
new file mode 100644
index 000000000000..c497259dd29f
--- /dev/null
+++ b/app-text/zpspell/files/gcc-4.3.patch
@@ -0,0 +1,11 @@
+diff -pruN zpspell-0.4.1-orig/main.cpp zpspell-0.4.1/main.cpp
+--- zpspell-0.4.1-orig/main.cpp 2008-03-18 11:29:06.000000000 +0200
++++ zpspell-0.4.1/main.cpp 2008-03-18 11:29:28.000000000 +0200
+@@ -15,6 +15,7 @@
+
+ #include <iostream>
+ #include <getopt.h>
++#include <cstring>
+
+ #include "zstring.h"
+ #include "zsconn.h"
diff --git a/app-text/zpspell/metadata.xml b/app-text/zpspell/metadata.xml
new file mode 100644
index 000000000000..1f153382114a
--- /dev/null
+++ b/app-text/zpspell/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>serkan@gentoo.org</email>
+ <name>Serkan Kaba</name>
+ <description>Maintainer</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/zpspell/zpspell-0.4.1.ebuild b/app-text/zpspell/zpspell-0.4.1.ebuild
new file mode 100644
index 000000000000..a4ba55ade62b
--- /dev/null
+++ b/app-text/zpspell/zpspell-0.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/zpspell/zpspell-0.4.1.ebuild,v 1.1 2008/07/18 22:32:15 serkan Exp $
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Zemberek-Pardus spell checker interface."
+HOMEPAGE="http://www.pardus.org.tr/projeler/masaustu/zemberek-pardus"
+SRC_URI="http://cekirdek.uludag.org.tr/~baris/zpspell/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/zemberek-server"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/gcc-4.3.patch
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS README || die
+}
+
+pkg_postinst() {
+ elog "Please visit ${HOMEPAGE} for"
+ elog "documentation on how to configure and run Zemberek spellchecker for KDE."
+}