summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-08-20 20:59:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-08-20 20:59:41 +0000
commitdfeb260b6a2eec034d1b0c869c7866c918c21fef (patch)
tree3fcac3f7b1d95040c57727131d9097afc77cb9b6 /app-text/wdiff
parentstable on ppc64, bug #58503 (Manifest recommit) (diff)
downloadgentoo-2-dfeb260b6a2eec034d1b0c869c7866c918c21fef.tar.gz
gentoo-2-dfeb260b6a2eec034d1b0c869c7866c918c21fef.tar.bz2
gentoo-2-dfeb260b6a2eec034d1b0c869c7866c918c21fef.zip
Add a patch to fix the segfaulting when wdiff is run as a user. Problem reported and fixed by: Mikko Ruuska <mikko.ruuska@solidtech.com> in bug #60543
Diffstat (limited to 'app-text/wdiff')
-rw-r--r--app-text/wdiff/ChangeLog9
-rw-r--r--app-text/wdiff/Manifest3
-rw-r--r--app-text/wdiff/files/digest-wdiff-0.5-r12
-rw-r--r--app-text/wdiff/files/wdiff-0.5-segfault-fix.diff20
-rw-r--r--app-text/wdiff/wdiff-0.5-r1.ebuild47
5 files changed, 80 insertions, 1 deletions
diff --git a/app-text/wdiff/ChangeLog b/app-text/wdiff/ChangeLog
index f5aaa2828d4a..db9f213317cf 100644
--- a/app-text/wdiff/ChangeLog
+++ b/app-text/wdiff/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/wdiff
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/ChangeLog,v 1.7 2004/06/28 04:18:57 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/ChangeLog,v 1.8 2004/08/20 20:59:41 seemant Exp $
+
+*wdiff-0.5-r1 (20 Aug 2004)
+
+ 20 Aug 2004; Seemant Kulleen <seemant@gentoo.org>
+ +files/wdiff-0.5-segfault-fix.diff, +wdiff-0.5-r1.ebuild:
+ Add a patch to fix the segfaulting when wdiff is run as a user. Problem
+ reported and fixed by: Mikko Ruuska <mikko.ruuska@solidtech.com> in bug #60543
28 Jun 2004; Ciaran McCreesh <ciaranm@gentoo.org> wdiff-0.5.ebuild:
Added ~sparc, ~mips
diff --git a/app-text/wdiff/Manifest b/app-text/wdiff/Manifest
index 7f43d53fb081..2bc92de58581 100644
--- a/app-text/wdiff/Manifest
+++ b/app-text/wdiff/Manifest
@@ -1,3 +1,6 @@
MD5 f8e7a31aced0c9f217d9afa8fb3d2d39 wdiff-0.5.ebuild 956
MD5 6af4ec19ac597a5fdafd766a8d477eeb ChangeLog 1012
+MD5 0603c77ecfe87caf0ab685e1ed5d977b wdiff-0.5-r1.ebuild 999
MD5 d6f2ef7713b8a0187fd684b0d8010347 files/digest-wdiff-0.5 128
+MD5 9857b4daaad6db84f5c7dd600a7e7b4c files/wdiff-0.5-segfault-fix.diff 487
+MD5 d6f2ef7713b8a0187fd684b0d8010347 files/digest-wdiff-0.5-r1 128
diff --git a/app-text/wdiff/files/digest-wdiff-0.5-r1 b/app-text/wdiff/files/digest-wdiff-0.5-r1
new file mode 100644
index 000000000000..492c83e04f6c
--- /dev/null
+++ b/app-text/wdiff/files/digest-wdiff-0.5-r1
@@ -0,0 +1,2 @@
+MD5 7f9c78f5dd6fb4f3dabe28fbd4d14319 wdiff-0.5.tar.gz 129267
+MD5 9a919e76ca95db105427d827ed1a4c31 wdiff-0.5-gentoo.diff.bz2 253
diff --git a/app-text/wdiff/files/wdiff-0.5-segfault-fix.diff b/app-text/wdiff/files/wdiff-0.5-segfault-fix.diff
new file mode 100644
index 000000000000..d0e837993b10
--- /dev/null
+++ b/app-text/wdiff/files/wdiff-0.5-segfault-fix.diff
@@ -0,0 +1,20 @@
+--- wdiff.c 2004-08-16 14:21:05.000000000 +0300
++++ wdiff.c.fixed 2004-08-16 14:22:06.000000000 +0300
+@@ -910,7 +910,8 @@
+ static void
+ complete_input_program (void)
+ {
+- fclose (input_file);
++ if (input_file != NULL)
++ fclose (input_file);
+ wait (NULL);
+ }
+
+@@ -1303,6 +1304,7 @@
+ initialize_strings ();
+ reformat_diff_output ();
+ fclose (input_file);
++ input_file = NULL;
+ }
+
+ /* Clean up. Beware that input_file and output_file might not exist,
diff --git a/app-text/wdiff/wdiff-0.5-r1.ebuild b/app-text/wdiff/wdiff-0.5-r1.ebuild
new file mode 100644
index 000000000000..9eaa40710dec
--- /dev/null
+++ b/app-text/wdiff/wdiff-0.5-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/wdiff-0.5-r1.ebuild,v 1.1 2004/08/20 20:59:41 seemant Exp $
+
+inherit eutils
+
+IUSE="build"
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="http://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~mips"
+
+DEPEND="sys-libs/libtermcap-compat
+ sys-apps/diffutils
+ sys-apps/less"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-segfault-fix.diff
+}
+
+src_compile() {
+ # Cannot use econf here because the configure script that
+ # comes with wdiff is too old to understand the standard
+ # options.
+
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ if ! use build
+ then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+}