summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-22 20:40:49 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-22 20:40:49 +0000
commit5ba2fc5e7d01fa813db8ef75a2f4925b672ca1fe (patch)
treed1ea40f62b967e98407cde1497fcbe1fdba35bda /app-text/highlight
parentAdd texlive-fontutils as additional dependency for TeXLive 2009, bug 303475. (diff)
downloadgentoo-2-5ba2fc5e7d01fa813db8ef75a2f4925b672ca1fe.tar.gz
gentoo-2-5ba2fc5e7d01fa813db8ef75a2f4925b672ca1fe.tar.bz2
gentoo-2-5ba2fc5e7d01fa813db8ef75a2f4925b672ca1fe.zip
Add prefix keywords, support; bump EAPI
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-text/highlight')
-rw-r--r--app-text/highlight/ChangeLog7
-rw-r--r--app-text/highlight/highlight-2.9.ebuild16
2 files changed, 14 insertions, 9 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index d0019840ee9c..4677ede80826 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/highlight
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.25 2009/05/04 20:14:33 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.26 2010/02/22 20:40:49 abcd Exp $
+
+ 22 Feb 2010; Jonathan Callen <abcd@gentoo.org> highlight-2.9.ebuild:
+ Add prefix keywords, support; bump EAPI
*highlight-2.9 (04 May 2009)
diff --git a/app-text/highlight/highlight-2.9.ebuild b/app-text/highlight/highlight-2.9.ebuild
index e191496b0890..83fac8fbbd23 100644
--- a/app-text/highlight/highlight-2.9.ebuild
+++ b/app-text/highlight/highlight-2.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-2.9.ebuild,v 1.3 2009/05/04 20:24:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-2.9.ebuild,v 1.4 2010/02/22 20:40:49 abcd Exp $
-EAPI=2
+EAPI=3
inherit eutils toolchain-funcs
DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
@@ -11,7 +11,7 @@ SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="qt4"
RDEPEND="qt4? ( x11-libs/qt-gui:4
@@ -20,16 +20,16 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -i -e 's:-O2::' -e 's:CFLAGS:CXXFLAGS:g' \
- -e 's:qmake-qt4:/usr/bin/qmake:' \
+ -e 's:qmake-qt4:${EPREFIX}/usr/bin/qmake:' \
src/makefile || die "sed failed"
}
src_compile() {
- emake -f makefile CXX="$(tc-getCXX)" \
+ emake -f makefile PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ CXX="$(tc-getCXX)" \
|| die "emake failed"
if use qt4; then
- emake -j1 -f makefile CXX="$(tc-getCXX)" gui \
+ emake -j1 -f makefile PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ CXX="$(tc-getCXX)" gui \
|| die "emake gui failed"
fi
}
@@ -38,10 +38,12 @@ src_install() {
dodir /usr/bin
emake -f makefile DESTDIR="${D}" \
+ PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ \
install || die "emake install failed"
if use qt4; then
emake -f makefile DESTDIR="${D}" \
+ PREFIX="${EPREFIX}" conf_dir="${EPREFIX}"/etc/highlight/ \
install-gui || die "emake install-gui failed"
doicon src/gui-qt/${PN}.xpm
domenu ${PN}.desktop