summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-12-27 21:37:36 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-12-27 21:37:36 +0000
commitcce82323087fcbcf62bbc2a1d9b7f9a2e76f01fc (patch)
tree22a394c641bf4302f94e2fce5cd686cf832924ea /app-shells
parentForce pgrp synchronization (diff)
downloadgentoo-2-cce82323087fcbcf62bbc2a1d9b7f9a2e76f01fc.tar.gz
gentoo-2-cce82323087fcbcf62bbc2a1d9b7f9a2e76f01fc.tar.bz2
gentoo-2-cce82323087fcbcf62bbc2a1d9b7f9a2e76f01fc.zip
Force pgrp synchronization
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653) The session will hang cases where you 'su' (not 'su -') and then run a piped command in emacs. This problem seem to happen due to scheduler changes kernel side - although reproduceble with later 2.4 kernels, it is especially easy with 2.6 kernels.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog13
-rw-r--r--app-shells/bash/Manifest5
-rw-r--r--app-shells/bash/bash-2.05b-r9.ebuild105
-rw-r--r--app-shells/bash/files/digest-bash-2.05b-r98
4 files changed, 127 insertions, 4 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index d2fbe5a2db89..f62aa11b385a 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.25 2003/12/15 09:19:41 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.26 2003/12/27 21:36:59 azarah Exp $
+
+*bash-2.05b-r9 (27 Dec 2003)
+
+ 27 Dec 2003; Martin Schlemmer <azarah@gentoo.org> bash-2.05b-r9.ebuild:
+ Force pgrp synchronization
+ (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653)
+
+ The session will hang cases where you 'su' (not 'su -') and then run a piped
+ command in emacs. This problem seem to happen due to scheduler changes kernel
+ side - although reproduceble with later 2.4 kernels, it is especially easy
+ with 2.6 kernels.
13 Dec 2003; Guy Martin <gmsoft@gentoo.org> bash-2.05b-r7.ebuild:
Marked stable on hppa.
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index 9c35b52c7ce8..7e050793edde 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -1,13 +1,12 @@
MD5 e56d41ca654c42349b80a107aa2525f5 bash-2.05b-r4.ebuild 1851
MD5 201e6ea6e18ac8aef2a1b2e4d6d65300 bash-2.05b-r7.ebuild 2145
-MD5 818fb80f427c3914bf2f5cbc12435d82 ChangeLog 6228
+MD5 b73270c6dddc6f68c2cd997b2524699a ChangeLog 6684
MD5 69838bc876547044ffde5cccfdd496b6 bash-2.05b-r8.ebuild 2287
MD5 7a604a7af0a8fa85c591aa394bf5d5df bash-2.05b-r3.ebuild 1743
MD5 7788484f5384e08b5a7fd93fd79bfc58 bash-2.05a-r3.ebuild 1903
MD5 1fe3ae8adb7ef006f5b507fa2639ca8f bash-2.05b-r6.ebuild 2028
MD5 77e35f69ed898e2b8c4981dc8f9feaad bash-2.05b-r5.ebuild 2033
-MD5 9ae9348e5c77afd8a0f1a2f3678de0dc bash-2.05b-r9.ebuild 2812
-MD5 e96327e37ebc0d6bfd1551a1bccac495 .bash-2.05b-r9.ebuild.swp 12288
+MD5 11fbe17fa62118bf926229c1863648af bash-2.05b-r9.ebuild 2700
MD5 3b905c7c9341c9009bd68f14c047815e files/bash-2.05b-rbash.patch 804
MD5 867b3b11e48acac6d09794c8d36cb204 files/digest-bash-2.05b-r4 296
MD5 582fb9ed0ca44627978ce6836a5000dc files/config-top.h.diff 487
diff --git a/app-shells/bash/bash-2.05b-r9.ebuild b/app-shells/bash/bash-2.05b-r9.ebuild
new file mode 100644
index 000000000000..779b581a622e
--- /dev/null
+++ b/app-shells/bash/bash-2.05b-r9.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.1 2003/12/27 21:36:59 azarah Exp $
+
+inherit eutils flag-o-matic gnuconfig
+
+# Official patches
+PLEVEL="x002 x003 x004 x005 x006 x007"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="mirror://gnu/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ ${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~ia64 ~mips ~ppc64"
+IUSE="nls build"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+
+ # Remove autoconf dependency
+ sed -i -e "/&& autoconf/d" Makefile.in
+
+ # Readline is slow with multibyte locale, bug #19762
+ epatch ${FILESDIR}/${P}-multibyte-locale.patch
+ # Segfault on empty herestring
+ epatch ${FILESDIR}/${P}-empty-herestring.patch
+ # fix broken rbash functionality
+ epatch ${FILESDIR}/${P}-rbash.patch
+
+ # Enable SSH_SOURCE_BASHRC (#24762)
+ sed -e 's:^.*\(#define SSH_SOURCE_BASHRC\).*$:\1:' \
+ -i config-top.h
+
+ # Force pgrp synchronization
+ # (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653)
+ #
+ # The session will hang cases where you 'su' (not 'su -') and
+ # then run a piped command in emacs.
+ # This problem seem to happen due to scheduler changes kernel
+ # side - although reproduceble with later 2.4 kernels, it is
+ # especially easy with 2.6 kernels.
+ echo '#define PGRP_PIPE 1' >> config-bot.h
+}
+
+src_compile() {
+
+ # If running mips64, we need updated configure data
+ use mips && gnuconfig_update
+
+ filter-flags -malign-double
+
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ use build \
+ && rm -rf ${D}/usr \
+ || ( \
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+
+ ebegin "creating info symlink"
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+ eend $?
+ )
+}
diff --git a/app-shells/bash/files/digest-bash-2.05b-r9 b/app-shells/bash/files/digest-bash-2.05b-r9
new file mode 100644
index 000000000000..cda4481c8b5e
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-2.05b-r9
@@ -0,0 +1,8 @@
+MD5 5238251b4926d778dfe162f6ce729733 bash-2.05b.tar.gz 1956216
+MD5 acac0949285525a5920d80f2aa4668de bash-2.05b-gentoo.diff.bz2 2744
+MD5 2957bbe5f6db1830d649d1071baba63c bash205b-002 755
+MD5 2828e78563927b806246e2b4806ee0f5 bash205b-003 2356
+MD5 6bf89831209ba6d208943d2ebaa7fe3a bash205b-004 1110
+MD5 311b7f0e3dabec51767bfabe6afd4ded bash205b-005 2217
+MD5 f8a86d0a66b51080f3fbc5cc34ef1a06 bash205b-006 3155
+MD5 37d2acecc9146883f9b331c03b274f21 bash205b-007 1072