summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-03-02 08:54:49 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-03-02 08:54:49 +0000
commitd9ca29b057e00ca41262447502ee812b6d351311 (patch)
treeae39fa5ac50d7fb35a23315c1c06a2490aa5f2aa /app-shells/tcsh/tcsh-6.13-r1.ebuild
parentUse bash builtins for testing. Added MYTH_NICE option. (diff)
downloadgentoo-2-d9ca29b057e00ca41262447502ee812b6d351311.tar.gz
gentoo-2-d9ca29b057e00ca41262447502ee812b6d351311.tar.bz2
gentoo-2-d9ca29b057e00ca41262447502ee812b6d351311.zip
russian characters problems as per bug #83732
(Portage version: 2.0.51.18)
Diffstat (limited to 'app-shells/tcsh/tcsh-6.13-r1.ebuild')
-rw-r--r--app-shells/tcsh/tcsh-6.13-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-shells/tcsh/tcsh-6.13-r1.ebuild b/app-shells/tcsh/tcsh-6.13-r1.ebuild
new file mode 100644
index 000000000000..ff143ed09e80
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.13-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.13-r1.ebuild,v 1.1 2005/03/02 08:54:49 dragonheart Exp $
+
+inherit eutils
+
+MY_P="${PN}-${PV}.00"
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
+ mirror://gentoo/tcsh-complete"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~mips"
+IUSE="perl"
+
+RDEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ perl? ( dev-lang/perl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd ${S}
+
+ epatch ${FILESDIR}/tcsh-6.13.00-utmp.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-dspmbyte.patch
+ epatch ${FILESDIR}/tcsh-6.11.00-termcap.patch
+ epatch ${FILESDIR}/tcsh-6.12.00-setpgrp.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-charset.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-iconv.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-glob.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-arch.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-fcntl.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-winchg.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-codeset.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-closem.patch
+ epatch ${FILESDIR}/tcsh-6.13.00-cstr.patch
+}
+
+src_compile() {
+ econf --prefix=/ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install install.man || die
+
+ if use perl ; then
+ perl tcsh.man2html || die
+ dohtml tcsh.html/*.html
+ fi
+
+ dosym /bin/tcsh /bin/csh
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ insinto /etc
+ newins ${FILESDIR}/csh.cshrc_new csh.cshrc
+ newins ${FILESDIR}/csh.login_new csh.login
+
+ insinto /etc/skel
+ newins ${FILESDIR}/tcsh.config .tcsh.config
+
+ insinto /etc/profile.d
+ doins ${FILESDIR}/tcsh-settings ${FILESDIR}/tcsh-aliases ${FILESDIR}/tcsh-bindkey ${DISTDIR}/tcsh-complete
+}