summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Diener <sediener@gentoo.org>2003-09-29 15:44:31 +0000
committerStephen Diener <sediener@gentoo.org>2003-09-29 15:44:31 +0000
commitc06181d0b4303536764755b19a3a4e7ea3dcb547 (patch)
tree7a9299757092d1f61c7d215bff1f70f5905d1879 /app-sci/bioperl-run
parentInitial import. (diff)
downloadgentoo-2-c06181d0b4303536764755b19a3a4e7ea3dcb547.tar.gz
gentoo-2-c06181d0b4303536764755b19a3a4e7ea3dcb547.tar.bz2
gentoo-2-c06181d0b4303536764755b19a3a4e7ea3dcb547.zip
Initial import.
Diffstat (limited to 'app-sci/bioperl-run')
-rw-r--r--app-sci/bioperl-run/ChangeLog10
-rw-r--r--app-sci/bioperl-run/Manifest3
-rw-r--r--app-sci/bioperl-run/bioperl-run-1.2.2.ebuild55
-rw-r--r--app-sci/bioperl-run/files/bioperl-run-Pise-test-patch.diff22
-rw-r--r--app-sci/bioperl-run/files/digest-bioperl-run-1.2.21
-rw-r--r--app-sci/bioperl-run/metadata.xml6
6 files changed, 96 insertions, 1 deletions
diff --git a/app-sci/bioperl-run/ChangeLog b/app-sci/bioperl-run/ChangeLog
new file mode 100644
index 000000000000..ddfff041eb2c
--- /dev/null
+++ b/app-sci/bioperl-run/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-sci/bioperl-run
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl-run/ChangeLog,v 1.1 2003/09/29 15:44:23 sediener Exp $
+
+*bioperl-run-1.2.2 (29 Sep 2003)
+
+ 29 Sep 2003; <sediener@gentoo.org> bioperl-run-1.2.2.ebuild, metadata.xml,
+ files/bioperl-run-Pise-test-patch.diff:
+ Initial Import. Built of of the bioperl ebuild from Gontran Zepeda.
+
diff --git a/app-sci/bioperl-run/Manifest b/app-sci/bioperl-run/Manifest
index 78f3c7b60ce7..cc1c11a39b61 100644
--- a/app-sci/bioperl-run/Manifest
+++ b/app-sci/bioperl-run/Manifest
@@ -1,4 +1,5 @@
-MD5 6067a45f6fb66752507cdc23d43a950c bioperl-run-1.2.2.ebuild 1468
+MD5 15507f5b9847ebed6801f6236267370d bioperl-run-1.2.2.ebuild 1476
MD5 e8b4df3df76800c376905734d8043cfa metadata.xml 216
+MD5 423ff8a3bd149f48d91048329099543d ChangeLog 446
MD5 21ad123058f1e670f289ee1a87de4e82 files/bioperl-run-Pise-test-patch.diff 722
MD5 b23d441d6d3f1d4ed3dead4c3dc2799b files/digest-bioperl-run-1.2.2 69
diff --git a/app-sci/bioperl-run/bioperl-run-1.2.2.ebuild b/app-sci/bioperl-run/bioperl-run-1.2.2.ebuild
new file mode 100644
index 000000000000..58a79d24816c
--- /dev/null
+++ b/app-sci/bioperl-run/bioperl-run-1.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl-run/bioperl-run-1.2.2.ebuild,v 1.1 2003/09/29 15:44:23 sediener Exp $
+
+inherit perl-module eutils
+CATEGORY="app-sci"
+
+DESCRIPTION="collection of tools for bioinformatics, genomics and life science research : subset required to run analyses"
+HOMEPAGE="http://www.bioperl.org/"
+#SRC_URI="http://www.cpan.org/modules/by-module/Bio/${P}.tar.gz"
+SRC_URI="http://www.bioperl.org/ftp/DIST/${P}.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Algorithm-Diff
+ dev-perl/File-Temp
+ dev-perl/IO-String
+ dev-perl/XML-Parser"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # remove interactiveness
+ epatch ${FILESDIR}/bioperl-run-Pise-test-patch.diff
+}
+
+src_compile() {
+ # there's a test to run for BioGFFDB if using mysql
+ perl-module_src_compile || die "compile failed"
+ # make test
+## perl-module_src_test || die "src test failed"
+}
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+
+ # bioperl scripts and examples
+ einfo 'Adding bioperl examples and scripts to /usr/share/...'
+ dodir /usr/share/${PF}/scripts
+ #insinto /usr/share/${PF}/scripts
+ cd ${S}/scripts/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/scripts; tar xf -)
+ dodir /usr/share/${PF}/examples
+ cd ${S}/examples/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/examples; tar xf -)
+ cd ${S}
+
+}
diff --git a/app-sci/bioperl-run/files/bioperl-run-Pise-test-patch.diff b/app-sci/bioperl-run/files/bioperl-run-Pise-test-patch.diff
new file mode 100644
index 000000000000..5683347a6b52
--- /dev/null
+++ b/app-sci/bioperl-run/files/bioperl-run-Pise-test-patch.diff
@@ -0,0 +1,22 @@
+--- Makefile.PL.original 2003-09-28 23:33:16.000000000 -0400
++++ Makefile.PL 2003-09-28 23:33:50.000000000 -0400
+@@ -73,19 +73,6 @@
+ my $DISTNAME = "bioperl-run";
+ my $VERSION = "1.2.2";
+
+-my $proceed = prompt("Do you want to run the Pise tests (requires a network connection) y/n",'n');
+-if( $proceed =~ /^[yY]/) {
+- my $address = prompt("Enter your email address (no default)",'');
+-
+- if (open T,">t/pise-email.test") {
+-print T "$address\n";
+-close T;
+- } else { warn("Cannot open file t/pise-email.test for writing - no Pise tests will be run"); }
+-} else {
+- if( -e "t/pise-email.test" ) {
+-unlink "t/pise-email.test";
+- }
+-}
+ #$do_autoload_finesse = 0;
+ #$NAME = 'Bio';
+ #$DISTNAME = "GFD";
diff --git a/app-sci/bioperl-run/files/digest-bioperl-run-1.2.2 b/app-sci/bioperl-run/files/digest-bioperl-run-1.2.2
new file mode 100644
index 000000000000..cf92f27aa20d
--- /dev/null
+++ b/app-sci/bioperl-run/files/digest-bioperl-run-1.2.2
@@ -0,0 +1 @@
+MD5 2ffbaa69e713f102f86c7b7462ccff52 bioperl-run-1.2.2.tar.gz 811989
diff --git a/app-sci/bioperl-run/metadata.xml b/app-sci/bioperl-run/metadata.xml
new file mode 100644
index 000000000000..8a4bcd47220d
--- /dev/null
+++ b/app-sci/bioperl-run/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer><email>sediener@gentoo.org</email></maintainer>
+</pkgmetadata>