summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-02-16 15:43:08 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-02-16 15:43:08 +0000
commit1fa8123b76ab21334cd77edb2bfc7f9fbebad61e (patch)
tree7806146db6a74a4abfd6dac43477418789158a4a /app-pda
parentstable ppc, bug 245092 (diff)
downloadgentoo-2-1fa8123b76ab21334cd77edb2bfc7f9fbebad61e.tar.gz
gentoo-2-1fa8123b76ab21334cd77edb2bfc7f9fbebad61e.tar.bz2
gentoo-2-1fa8123b76ab21334cd77edb2bfc7f9fbebad61e.zip
Add gcc 4.3.3 compile fix wrt bug #257506, Version bump because of transition to EAPI2
(Portage version: 2.2_rc23/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/ChangeLog11
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.3-glibc-open.patch12
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild128
3 files changed, 149 insertions, 2 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index 4c7c0edab391..caff95d86e7e 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/pilot-link
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.42 2008/07/27 13:57:36 loki_val Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.43 2009/02/16 15:43:08 jokey Exp $
+
+*pilot-link-0.12.3-r1 (16 Feb 2009)
+
+ 16 Feb 2009; Markus Ullmann <jokey@gentoo.org>
+ +files/pilot-link-0.12.3-glibc-open.patch, +pilot-link-0.12.3-r1.ebuild:
+ Add gcc 4.3.3 compile fix wrt bug #257506, Version bump because of
+ transition to EAPI2
27 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+files/pilot-link-0.11.8-gcc43.patch, pilot-link-0.11.8.ebuild,
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.3-glibc-open.patch b/app-pda/pilot-link/files/pilot-link-0.12.3-glibc-open.patch
new file mode 100644
index 000000000000..90c0e11a9c68
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.3-glibc-open.patch
@@ -0,0 +1,12 @@
+diff -urN ./pilot-link-0.12.3.orig/src/pilot-schlep.c ./pilot-link-0.12.3/src/pilot-schlep.c
+--- ./pilot-link-0.12.3.orig/src/pilot-schlep.c 2006-10-12 16:21:21.000000000 +0200
++++ ./pilot-link-0.12.3/src/pilot-schlep.c 2009-02-16 16:09:25.321851803 +0100
+@@ -38,7 +38,7 @@
+ fd;
+ pi_buffer_t *buffer;
+
+- fd = open(filename, O_WRONLY | O_CREAT | O_TRUNC);
++ fd = open(filename, O_WRONLY | O_CREAT | O_TRUNC, S_IRUSR | S_IWUSR);
+ if (fd < 0)
+ return -1;
+
diff --git a/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild b/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild
new file mode 100644
index 000000000000..77d4f9f3d6c5
--- /dev/null
+++ b/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild,v 1.1 2009/02/16 15:43:08 jokey Exp $
+
+EAPI=2
+
+inherit perl-module java-pkg-opt-2 eutils autotools distutils
+
+DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
+HOMEPAGE="http://www.pilot-link.org/"
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+
+IUSE="perl java python png readline threads bluetooth usb debug"
+
+BOTH_DEPEND="virtual/libiconv
+ >=sys-libs/ncurses-5.6-r1
+ >=dev-libs/popt-1.10.7
+ perl? ( >=dev-lang/perl-5.8.8-r2 )
+ python? ( >=dev-lang/python-2.4.4-r4 )
+ png? ( >=media-libs/libpng-1.2.18-r1 )
+ readline? ( >=sys-libs/readline-5.2_p4 )
+ usb? ( >=dev-libs/libusb-0.1.12 )
+ bluetooth? ( >=net-wireless/bluez-libs-3.10 )"
+
+DEPEND="${BOTH_DEPEND}
+ java? ( >=virtual/jdk-1.4 )"
+
+RDEPEND="${BOTH_DEPEND}
+ java? ( >=virtual/jre-1.4 )"
+
+src_prepare() {
+ # Fixing some broken configure switches and automagic deps.
+ epatch "${FILESDIR}/${PN}-0.12.2-readline.patch"
+ epatch "${FILESDIR}/${PN}-0.12.2-threads.patch"
+ epatch "${FILESDIR}/${P}-png.patch"
+
+ # Upstream's check for Werror was wrong. Fixes bug 194921.
+ epatch "${FILESDIR}/${PN}-0.12.2-werror_194921.patch"
+
+ # We install the Java bindings using the eclass functions so we disable
+ # their installation here.
+ use java && epatch "${FILESDIR}/${P}-java-install.patch"
+
+ # We install the Python bindings using the eclass functions so we disable
+ # their makefile.am rules here
+ use python && epatch "${FILESDIR}/${P}-distutils.patch"
+
+ # Upstream patch to fix 64-bit issues.
+ epatch "${FILESDIR}/${P}-int_types.patch"
+
+ # Fix Glibc open without mode error
+ epatch "${FILESDIR}/${P}-glibc-open.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # tcl/tk support is disabled as per upstream request.
+ econf \
+ --includedir=/usr/include/libpisock \
+ --enable-conduits \
+ --with-tcl=no \
+ --without-included-popt \
+ --disable-compile-werror \
+ $(use_enable threads) \
+ $(use_enable usb libusb) \
+ $(use_enable debug) \
+ $(use_with png libpng $(libpng-config --prefix)) \
+ $(use_with bluetooth bluez) \
+ $(use_with readline) \
+ $(use_with perl) \
+ $(use_with java) \
+ $(use_with python) \
+ || die "econf failed"
+}
+
+src_compile() {
+ # Unfortunately, parallel compilation is badly broken. cf. bug 202857.
+ emake -j1 || die "emake failed"
+
+ if use perl ; then
+ cd "${S}/bindings/Perl"
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+
+ if use python; then
+ cd "${S}/bindings/Python"
+ distutils_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS || die "installing docs failed"
+
+ if use java ; then
+ cd "${S}/bindings/Java"
+ java-pkg_newjar ${PN}.jar
+ java-pkg_doso libjpisock.so
+ fi
+
+ if use perl ; then
+ cd "${S}/bindings/Perl"
+ perl-module_src_install
+ fi
+
+ if use python; then
+ cd "${S}/bindings/Python"
+ distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+ fi
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}