summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-03-04 10:35:38 +0000
committerTorsten Veller <tove@gentoo.org>2008-03-04 10:35:38 +0000
commit8e6dad371193102bd1483971cf262645303afa6d (patch)
treea7991ac289e331b601f65f26494e2c33584a1584 /app-office
parentMark ~x86 wrt bug #210854. Thanks to Michał Wołonkiewicz <volon@vp.pl> for ... (diff)
downloadgentoo-2-8e6dad371193102bd1483971cf262645303afa6d.tar.gz
gentoo-2-8e6dad371193102bd1483971cf262645303afa6d.tar.bz2
gentoo-2-8e6dad371193102bd1483971cf262645303afa6d.zip
Added patch for bug #210944
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog6
-rw-r--r--app-office/gnucash/files/SplitP.h.patch18
-rw-r--r--app-office/gnucash/gnucash-2.2.3.ebuild8
3 files changed, 30 insertions, 2 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 70b7fe247345..5be1fd17fcee 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.155 2008/03/03 09:20:00 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.156 2008/03/04 10:35:38 tove Exp $
+
+ 04 Mar 2008; Torsten Veller <tove@gentoo.org> +files/SplitP.h.patch,
+ gnucash-2.2.3.ebuild:
+ Added patch for bug #210944
*gnucash-2.2.4 (03 Mar 2008)
diff --git a/app-office/gnucash/files/SplitP.h.patch b/app-office/gnucash/files/SplitP.h.patch
new file mode 100644
index 000000000000..64a18c810f59
--- /dev/null
+++ b/app-office/gnucash/files/SplitP.h.patch
@@ -0,0 +1,18 @@
+http://bugzilla.gnome.org/show_bug.cgi?id=512166
+https://bugs.gentoo.org/show_bug.cgi?id=210944
+
+Fixed in gnucash-2.2.4
+
+Index: src/engine/SplitP.h
+===================================================================
+--- src/engine/SplitP.h (revision 16884)
++++ src/engine/SplitP.h (revision 16885)
+@@ -149,7 +149,7 @@
+ Split * xaccSplitClone (const Split *s);
+
+ Split *xaccDupeSplit (const Split *s);
+-G_INLINE_FUNC void mark_split (Split *s);
++void mark_split (Split *s);
+
+ void xaccSplitVoid(Split *split);
+ void xaccSplitUnvoid(Split *split);
diff --git a/app-office/gnucash/gnucash-2.2.3.ebuild b/app-office/gnucash/gnucash-2.2.3.ebuild
index fa8fafe5f816..9d4b1c2a800f 100644
--- a/app-office/gnucash/gnucash-2.2.3.ebuild
+++ b/app-office/gnucash/gnucash-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.2.3.ebuild,v 1.7 2008/02/20 12:26:52 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.2.3.ebuild,v 1.8 2008/03/04 10:35:38 tove Exp $
inherit autotools eutils gnome2
@@ -71,6 +71,12 @@ pkg_setup() {
fi
}
+src_unpack(){
+ gnome2_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/SplitP.h.patch
+}
+
src_compile() {
econf \
$(use_enable debug) \