summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-01-25 21:46:18 +0000
committerPeter Weller <welp@gentoo.org>2007-01-25 21:46:18 +0000
commit08a69402187e92609f848aed64bd097f132cf718 (patch)
tree9e5a037a91f035e7fef519074c9a3087e9a1cce8 /app-office
parentQA: fixing KEYWORDS; bug #163818 (diff)
downloadgentoo-2-08a69402187e92609f848aed64bd097f132cf718.tar.gz
gentoo-2-08a69402187e92609f848aed64bd097f132cf718.tar.bz2
gentoo-2-08a69402187e92609f848aed64bd097f132cf718.zip
Moved instances of epatch from src_compile to src_unpack. Added patch to -2.4.6 so it works on x86-fbsd
(Portage version: 2.1.2-r4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/abiword-2.4.5-r1.ebuild14
-rw-r--r--app-office/abiword/abiword-2.4.6.ebuild11
-rw-r--r--app-office/abiword/files/freebsd_fix.patch11
4 files changed, 33 insertions, 10 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 1705218fc1ff..287aa184af92 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.165 2007/01/25 05:10:46 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.166 2007/01/25 21:46:18 welp Exp $
+
+ 25 Jan 2007; Peter Weller <welp@gentoo.org> +files/freebsd_fix.patch,
+ abiword-2.4.5-r1.ebuild, abiword-2.4.6.ebuild:
+ Moved instances of epatch from src_compile to src_unpack. Added patch to
+ -2.4.6 so it works on x86-fbsd
25 Jan 2007; Marius Mauch <genone@gentoo.org> abiword-2.4.4.ebuild,
abiword-2.4.5.ebuild, abiword-2.4.5-r1.ebuild, abiword-2.4.6.ebuild:
diff --git a/app-office/abiword/abiword-2.4.5-r1.ebuild b/app-office/abiword/abiword-2.4.5-r1.ebuild
index af5c37126d0c..a62171c7bb94 100644
--- a/app-office/abiword/abiword-2.4.5-r1.ebuild
+++ b/app-office/abiword/abiword-2.4.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.5-r1.ebuild,v 1.3 2007/01/25 05:10:46 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.5-r1.ebuild,v 1.4 2007/01/25 21:46:18 welp Exp $
inherit eutils fdo-mime alternatives
@@ -38,13 +38,15 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}/abi
-src_compile() {
- # Patch taken from debian to use full path for file history
- epatch ${FILESDIR}/11_history_fullpath.dpatch
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
- # Patch taken from debian to prevent crash on exit
- epatch ${FILESDIR}/16_fcfini_crash.dpatch
+ epatch ${FILESDIR}/11_history_fullpath.dpatch
+ epatch ${FILESDIR}/11_fcfini_crash.dpatch
+}
+src_compile() {
# this is a hack since I don't want to go hack in the gnome-vfs
# headerfiles. The issue is about gnome-vfs containing "long long"
# which makes gcc 3.3.1 balk
diff --git a/app-office/abiword/abiword-2.4.6.ebuild b/app-office/abiword/abiword-2.4.6.ebuild
index 3d0cdd683746..31e44bd63738 100644
--- a/app-office/abiword/abiword-2.4.6.ebuild
+++ b/app-office/abiword/abiword-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.6.ebuild,v 1.3 2007/01/25 05:10:46 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.6.ebuild,v 1.4 2007/01/25 21:46:18 welp Exp $
inherit alternatives eutils fdo-mime
@@ -40,10 +40,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P}/abi"
-src_compile() {
- # Patch from debian to use fullpath for file history
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
epatch ${FILESDIR}/11_history_fullpath.dpatch
+ epatch ${FILESDIR}/freebsd_fix.patch
+}
+src_compile() {
econf $(use_enable debug) \
$(use_enable debug symbols) \
$(use_enable gnome) \
diff --git a/app-office/abiword/files/freebsd_fix.patch b/app-office/abiword/files/freebsd_fix.patch
new file mode 100644
index 000000000000..9e95194c18bf
--- /dev/null
+++ b/app-office/abiword/files/freebsd_fix.patch
@@ -0,0 +1,11 @@
+--- src/af/util/xp/ut_iconv.cpp.orig Tue Jan 10 00:18:13 2006
++++ src/af/util/xp/ut_iconv.cpp Tue Jan 10 00:18:31 2006
+@@ -67,7 +67,7 @@
+ #if defined (WIN32) || defined(__QNXNTO__) || defined(__CYGWIN__) || \
+ (defined (__MACH__) && defined (__APPLE__)) || \
+ (defined(TARGET_OS_MAC) && TARGET_OS_MAC) || \
+-defined (__AIX__) || defined(__OpenBSD__) || \
++defined (__AIX__) || defined(__OpenBSD__) || defined (__FreeBSD__) || \
+ (defined(__linux__) && defined(__powerpc__) && (__GLIBC__ <= 2) && (__GLIBC_MINOR__ <= 1))
+
+ #define ICONV_CONST const